Style error: Australian Guide to Legal Citation (AGLC)

Hi there,

I have used manuscripts (item type) for citing parliamentary debates, however, there is a comma missing from between the full date of the debate and the pinpoint. I have tried fixing this using the visual CSL editor by adding a comma prefix in the manuscript-catchall macro but that has put an additional comma before the chamber.

I'm not sure where I have gone wrong here. Any advice would be gratefully appreciated.

Also, what may help in resolving this is if I could add manuscripts to the example citations in the visual CSL editor. Is this possible?

Many thanks

  • Can you post here an example of correct and incorrect citation? And can you upload your item from Zotero to the group library for testing purposes?

    If you see the CSL code you can find, that prefix before manuscript-catchall is implemented already on line 482.
  • edited November 27, 2017
    As an aside, is there are a reason you're using Manuscript rather than a better match, such as Hearing?

    If you are doing legal citations, you might find it useful to switch to Juris-M, a version of Zotero with much-expanded legal functionality, including numerous additional legal item types.
  • They're using manuscript based on the sample entry here:
    I assume.
    I can take a look.
  • Thank you to you all. I have uploaded the item to Zotero group library for testing.

    Currently, the citation appears:
    South Australia, *Parliamentary Debates*, Legislative Council, 28 September 2011 3991 [* denoting italics].

    The citation should appear:
    South Australia, *Parliamentary Debates*, Legislative Council, 28 September 2011, 3991 [with a comma before the pinpoint/page number]

    Yes, @adamsmith is correct, the reason why I'm using manuscript is because that is the recommended item type in the AGLC samples.

    In relation to Juris-M, @bwiernik, I converted to Juris-M a year or two ago but at that time the closest referencing style I could use was the NZ style or the OSCALA (from memory). I was hoping I would be able to make either of these styles more AGLC compliant but I just didn't know how - even after reading the instructions on the Juris-M github website. With my thesis examination date approaching, I decided to jump back to Zotero and the AGLC style there. I only just discovered @adamsmith's video tutorial ( over the weekend and found that really useful so maybe once my thesis is submitted I'll give Juris-M another go. A Juris-M specific video tutorial would be really helpful though as the style editors appear to be quite different. Maybe one already exists?

    Thank you again!

  • edited November 28, 2017
    Oh yes, I see your problem, you use page number in the locator. You have to add
    prefix=", " before the code for locator writing not in the manuscript-catchall macro. Unfortunately, add the prefix to the line 530 does not work correctly.
  • Thanks @LiborA! Is there a way to get an example of a manuscript in the visual editor window under example citations? I'm having trouble locating where exactly to add the prefix in the visual editor (see
  • You can add items exported from Zotero as CSL JSON under "Example Citations" --> "Advanced" in the visual editor, but why not just use the style editor in Zotero at that point (it's in the Cite pane of the preferences). Big advantage there is that you can try any item in your library with the code right away.
  • Thank you @adamsmith! I ended up uploading the manuscript type to the visual editor. As you can see from this screenshot (, the delimiter doesn't seem to be working (like what happened in that YouTube tutorial you held) but I can add the comma as a prefix. However, there is a space that is left between the date and the prefix.

    I tried to make the change to the delimiter in the raw code (at lines 509 and I tried 510) but neither seemed to work.
Sign In or Register to comment.