Zotero crashes Word

edited November 20, 2017
Hi there,

I'm having trouble with Zotero crashing Microsoft Word. It started happening in recent months when I attempted to insert a footnote in a large document with 100+ footnotes. The insert footnote box would open, then Word would crash, closing all documents. Now it's happening more frequently on even small Word documents, with only a few citations. I don't remember this happening before the last big update.

I'm using Office 2016 on Windows 10 (with Fall Creators Update).

Can anyone offer any help?

Many thanks in advance,
Jonathan R.
  • What specific version number for Word? And does the problem happen when you insert a regular Word footnote or only when using Zotero to add a note?
  • 16.0.8625.2121

    As best as I can tell, it only happens when inserting a Zotero footnote.

    Thanks for getting back to me!
  • Hi, I'm having the same problem, on a new document, attempting to create the first Zotero footnote. My word version is 1705 (Build 8201.220 Click-to-Run). I had quite a few word documents open at the time, a couple were large with a lot of footnotes. I tried twice and word crashed twice.
  • For both of you, does Word crash if you insert a Zotero footnote into an empty new document with just that one open?

    @SophieGreenway You should upgrade to the latest stable Word version -- 1710 (16.0.8625.2121)
  • Thank you- I have tried to update Word but it says all up to date. I tried a blank document and that works fine, and have now tried my original document where the problem arose, and that's fine too. I will talk to my university, which supplied Office, about the version of Word.
  • It's difficult to answer that question, since Zotero doesn't crash my documents every time I insert a citation. That said, after a few tests, no, Zotero is not crashing an empty Word document that's the only one open.

    Despite being unpredictable, the crashing is happening increasingly often, so I'm pretty desperate for a fix. Any help anyone?
  • edited December 3, 2017
    Ok, lets try this fix. Follow these instructions carefully:

    1. Open zotero installation folder (default C:\Program Files (x86)\Zotero)
    2. Navigate to extensions\zoteroWinWordIntegration@zotero.org
    3. Download 2010-libs-build.zip
    4. Remove the contents of the folder you had opened and replace them with the contents from the zip (you will need to navigate to zotero-word-for-windows-integration-2010-libs-build within the zip file).
    5. Restart Zotero

    Use Zotero with Word as you do normally and report if you still get any crashing (or, if you don't)
  • Okay, I've done so. I'll report back after a bit of normal working. Thanks so much.
  • Alas, after working well yesterday afternoon, Zotero has started crashing Word again. Should I uninstall Zotero entirely and re-install?

    Also, I wonder if Zotero is recording these incidents as errors that I can report, given that Word, rather than Zotero, crashes.

    Thanks for the continued help.
  • edited December 3, 2017
    Ok, let's try Simon's build.

    Same instructions as above, please let us know if this works fine.
  • So far, everything seems to be working again. I even have my references which are written more quickly in my thesis (sometimes I had to wait several seconds for a new reference to be added).
  • Okay, I'm trying the new build. I'll report back. Thanks as always.
  • Hi friends,

    So far, this build seems to solve the problem! Thanks for all the help. I'll report back if the problem recurs, especially when I return to some longer, more heavily footnoted documents.

    Cheers, and thanks again,
Sign In or Register to comment.