Import Citavi quotations

Dear all,

I tried to import my Citavi-based library to Zotero, and all went smoothly, except that I haven't found a way to import the quotations from Citavi as well. The abstracts did export, but not one quotation.
Is a direct export possible? If so, could you explain how to proceed? That would be grant!
  • which export format did you use?
    Open it with a text editor and see if the quotations are in there. If they are we can likely do something from the Zotero side, otherwise you'll need to find a way to get that data out of Citavi first.
    I don't think we'll write a direct export from Citavi's database (which I believe is MS Access based?) but there may be other ways.
    Find out from Citavi if the quotation info is in any export they provide.
  • Wow, this is indeed immediate feedback, thank you very much!
    Well, I use Citavi Version 2.5 and that one supports exports into BibTeX, RIS, Endnote and Endnote Tagged Import Format.
    I tried all three with the same result: no quotations were exported. Indeed, when I open the files (BibTeX, RIS etc.) with a text editor, the quotations are not present.
    I will get in touch with the Citavi people, ask what can be done and post their reply here.
  • Following up on this one: Citavi support told me that I could re-name the .ctv-file (that contains all the data of a project) into .mdb and then simply open it with MS-Access.
    That worked indeed, but now I'm stuck: I do see all the data, but everything in different tables, some containing all the book titles, others all the authors, etc. And one chart also contains all the quotations. But how can I make Zotero import that and link it accordingly?
    Any help is appreciated.
  • edited March 14, 2013
    The data would need to be in BibTeX or RIS. Otherwise it's just a proprietary database format, and you'd need to write custom code to get it into Zotero. So you'd have to talk to Citavi about the quotations not appearing in those output formats.
  • Thank you for the quick reply again, although, of course, that definitively brings my import ambitions to a dead halt. And I doubt that Citavi (being a for-profit-company) is interested in telling me how to get away from their programme.
    If anyone reads this and knows how to proceed with the code (i.e. using the .mdb-file to import into Zotero), please revive this thread! I presume that quite a few people might be interested in that.
  • edited March 14, 2013
    And I doubt that Citavi (being a for-profit-company) is interested in telling me how to get away from their programme.
    If you really believe that you should put in the extra weekend of work and run away from Citavi now. From what I've seen from Citavi support they're actually relatively good about such things, but you must be able to get any data out of software in a relatively standardized way.
    One reason is that otherwise you're essentially hostage to that company.
    The other reason is that Citavi is run by a small company that has already miscalculated once when they put all their money on Windows and now are basically shut out of the increasingly important Mac market. There is no guarantee that they'll be around in 10 or 20 years. And what then? (There is no guarantee that Zotero will be around in 20 years, either, of course, but Zotero data is _much_ more portable).
  • You are right about both Citavi support (they are friendly and helpful) and about the slippery slope of nevertheless ending up being a "hostage" of their product.
    From what I have gathered, Citavi is basically two programmes rolled into one: A bibliography manager quite like Zotero, and a knowledge management software (that's the part where the quotations are). They linked these two quite nicely together in their software, but the downside is that their bibliographies use .bib or .ris formats, while the knowledge management is MS-Access-based. Being quite unfamiliar with both of these formats, I simply do not know how to proceed to bring the latter into a form that can be read by Zotero (or any other bibliography manager, for that matter), e.g. converting it into notes attached to the item. Citavi support told me that there simply is no field in the .bib or .ris-files to export this kind of data.
    Or maybe, by using Access, I could somehow create a whole new sqlite-database from the .mdb-file and then somehow merge that with the Zotero-database that already contains some items, but as mentioned, with my limited knowledge of Access, I am simply stuck here.
  • Or maybe, by using Access, I could somehow create a whole new sqlite-database from the .mdb-file and then somehow merge that with the Zotero-database that already contains some items
    No, not really. See this thread for an explanation of why that wouldn't really work.
  • I'll look into this when I have some time. I'd be interested in adding support for Citavi -> Zotero migration. Probably will take me a while though
  • That would be really great. Thanks already for taking this into consideration.
  • As another acquaintance has come across the same issue here (after I recommended Zotero), I'd like to resurrect this thread and enquire if there is anything on the horizon concerning easy Citavi-to-Zotero-migration. Anything, anyone?
  • As I was looking up the same issue (since I have several "projects" in Citavi containing references with linked quotations), it would be great if someone could reply to this. At this moment, the only way of importing notes from Citavi is doing so manually by copy-pasting text as well as applying any tags. An onerous process, which stops being feasible at the moment when you have more than a few dozen of notes...
  • Apologies, I digged into this further and found that the Zotero team already developed a dedicated Citavi importer and a solution is posted here:

    Many thanks!
  • Hey folks, I did exactly what's described there
    to import my Citavi library (from Citavi 4 on a Mac), but am then told that Zotero (latest version on a Mac) cannot import the file format. Do you know what might be the problem?
    Many thanks!
  • Could you open the .ctv5 file with a text editor and post the first ~10 lines here, please? You'll need to put <code> before them and </code> after them so they show up properly.
  • Thanks for the quick response! and sorry for double posting, didn't know it's not allowed. Here we go:

    SQLite format 3@ Ç Œ ÕWÇ-‚'.ù˚ˆÒÏÁ‚›ÿ”Œ…ƒø∫µ∞´¶°úóíçàÉ~ytoje`[VQLGB=83.)$autoindex_CategoryCategory_1CategoryCategoryÑz!--âtableCategoryCategoryCREATE TABLE Category (ID TEXT CONSTRAINT PK_Category PRIMARY KEY, CreatedBy TEXT, CreatedByCitaviId TEXT, CreatedBySid TEXT, CreatedOn DATETIME, ModifiedBy TEXT, ModifiedByCitaviId TEXT, ModifiedBySid TEXT, ModifiedOn DATETúqõpôoónñlïkîjìiíhêgåeàbÑ_Ä\|YxVsSnOiKfGcE`C\AX>S;Q7N5K2F1A-<)7%2!,(%"! :fi ä˚ˆÒÏÁ‚›ÿ”Œ…ƒø∫µ∞´¶°úóíçàÉ~ytoje`[VQLGB=83.)$¸˜ÚÌË„fiÇ}ÅÅEYÅEYEba4b2ba4-616f-4338-8086-55816ba55f23sS-1-5-21-4112557996-2536214275-1069032519-100
  • Yes, that doesn't look right at all. Zotero is looking for something like this:

    But I'm just seeing that this may require Citavi 5 upwards, so it's possible this won't work with Citavi 4 -- @zuphilip do you happen to know?
  • @adamsmith - I updated to Citavi 5 on the other Mac. That worked fine but the backups files *.ctv5bak do not behave like zip files but like normal files (that cannot be opened on the Mac, opening them in the VM opens them as project in citavi, they can't be read by a text editor). changing them to *.xml and then importing them in Zotero shows the same failure as before, file format can't be opened.
    Any clue what this might be?
  • That worked fine but the backups files *.ctv5bak do not behave like zip files but like normal files
    What happens when you open a Terminal in the directory where that file is (right-click on the folder > “Services” > “New Terminal at Folder”) and run:
    unzip [File].ctv5bak
  • (If you don't see that menu option in Services (it's not enabled for me), you can also open Terminal via Spotlight, type "cd " (that's "cd" followed by a space"), drag the folder into the terminal window to paste the path, and then press Return. You can then run the unzip command.)
  • edited December 8, 2017
    @dstillman @noksagt

    Like dstillman I didn't see that option so I did what he said.
    The result was:
    MacBook-Air:~ sina$ cd filename.ctv5bak
    -bash: cd: filename.ctv5bak: Not a directory
    MacBook-Air:~ sina$ unzip filename.ctv5bak
    Archive: filename.ctv5bak
    inflating: firsthalfoffilename.ctv5
    MacBook-Air:~ sina$

    But no new files showed up at the original location.
  • You misunderstood. You need to drag the FOLDER the archive is in, not the archive itself to the Terminal window.
  • edited December 8, 2017
    :) Thanks!
    It indeed got me one step further - but unfortunately only that:
    So I repeated the same thing with the Folder now, then unzipped the file, and indeed a new file *.ctv5 was created at the same location. When I imported this file in Zotero, it didn't complain about the format, created a library with the accurate name but then reported a problem, asking me to check whether the file was correct and try again.

    Who can help me get to the next level? (Thanks so much in advance!)
  • Could you paste a few lines of the extracted file from a text editor again?
  • and in addition to that the exact error message you're getting (untranslated) as well as well as an error report ID: right after this occurs.
  • File on Text Edit:
    <?xml version="1.0" encoding="utf-8"?>
    <CitaviExchangeData Version="" FilePath="C:\Users\SFB700IT\Documents\Citavi 5\Projects\PhD - nothing less\PhD - nothing less.ctv5" Changeset="0">
    <DefaultValue />
    <DefaultValue />

    it goes on similarly for a while, then:
    <LastChangeTime>20.11.2017 22:36:48</LastChangeTime>

    and so forth...
  • error message:
    Fehler _ Ein Fehler ist aufgetreten beim Importieren der ausgewählten Datei. Bitte überprüfen Sie, ob die Datei korrekt ist und versuchen Sie es erneut.
  • The error report ID: 200994914

    Thanks!!! I am very curious now :)
  • @dstillman could you take a look at the error, please
    @zuphilip can you tell if the Citavi XML looks right?
  • These lines from the file looks okay for me. I just updated to the new Citavi 5.7 version and tested the import again. This works for me. @sbirkholz Can you share your file online somewhere, e.g. as a gist?
Sign In or Register to comment.