Report ID: 169164383 Can't save web page

Report ID: 169164383

I can't figure out how to add a web page to Zotero.
Steps to reproduce:

1. Start Zotero.
2. Navigate to
4.Clike save web page with snapshot to zotero

Zotero displays the message An error occurred while saving this item. Try again, and if the issue persists see Getting Help for more information.
  • That saves for me, and you're getting an error that suggests some sort of conflict with the connector. See Troubleshooting Translator Issues. (I know this is for a web page save, but whatever problem is causing this is likely a general problem.)
  • @dddang: Actually, before you follow those steps, could we see a Debug ID for a save attempt that fails?
  • i repeat above steps,i notice standalone zotero app report an error with id 1951527579
  • edited November 12, 2017
    That's a Report ID from Zotero. We'd want a Debug ID from the Zotero Connector.
  • edited November 13, 2017
    Zotero standlone submit with debug id D503117527
  • edited November 13, 2017
    Connector submit with debug id is D803222369
  • So just to clarify, is the issue here that snapshots aren't saving? Because it looks like the webpage item itself saved successfully, but then the attachment failed to save.

    Do any pages work? E.g., can you save this page? Could we see a Debug ID from Zotero for that?
  • edited November 14, 2017
    Yes. I can save that example page and snapshots both without any problem.

  • @dstillman :So,does there any solution for this problem?
  • That's really wired.....i place -console augument in zotero.exe ,then i can save sanpshot now.....
  • That definitely didn't fix it, but restarting your browser or Zotero could have.
  • @dstillman I had tryied restarted browser or zotero for hundred times ,but this problem still exist. i debuged the connector extersion and proved that when call /connector/saveSnapshot of zotero it returned http 500 internal error. that's why i can't save snapshot.
    if i know how to debug zotero client maybe i can tell you why zotero cause error.
  • @dddang: Is it working for you now, or are you still getting an error?
  • edited December 4, 2017
    @dstillman it's still causing error. i decided to build zotero client source code and debug the error.

    Or,maybe you can send me a debugable zotero i do not need install linux to build from source .....
  • There's no need whatsoever to build the client to debug this — we have your Debug ID that shows the error. It just wasn't clear that you were still having trouble. We'll look into it.
  • it's obviously you and your team did not know the real source of error.
  • edited December 4, 2017
    Sorry, what? You implied a few messages ago that the issue was resolved, so we didn't look into it further. If you're still having trouble, we can keep investigating.

    This is the error you're getting:
    Win error 2 during operation move on file C:\Users\[…]\Zotero\storage\tmp-KgKVJ4 (系统找不到指定的文件。
    There's a very good chance this is due to security software on your system interfering with Zotero's file operations, so start by temporarily disabling anything you're running. This isn't an error anyone else has reported, so it's something specific to your system.

    -console doesn't change any behavior in Zotero, which is why I said it wouldn't have fixed this. It's also very slow, which is why we don't recommend even using it for debugging anymore. If you find that snapshot saving reliably works when you pass that flag and doesn't work when you don't, it may be due to its making Zotero run slowly, perhaps giving some security software time to perform operations on files. But I'd still be pretty surprised if -console really made a reliable difference.
  • edited December 4, 2017
    ...that can not explain why i can save snapshot of some web pages but the others can not.... and it's obviously before move file error we have a database transaction rollback.

    BTW:i reviewd this error on MAC os 10.12,Centos 7 and windows 7,10 platform. security software ??? may be you can not test on unicode(Like chinese language system) environment....

    (4)(+0000012): SELECT itemID, title FROM items JOIN itemNotes USING (itemID) WHERE libraryID=? AND itemID NOT IN (SELECT itemID FROM itemAttachments) AND itemID IN (2626) [1]

    (3)(+0000013): Loaded itemData in 我的文库 in 41 ms

    (1)(+0000032): Rolled back DB transaction CHPr3ZwY


    (1)(+0000002): Error: Win error 2 during operation move on file C:\Users\dddang\Zotero\storage\tmp-pHbgZb (系统找不到指定的文件。 ) (No stack trace) From previous event: Zotero.HTTP</this.loadDocuments/onLoad@chrome://zotero/content/xpcom/http.js:940:20

  • Security software could absolutely cause some saved pages not to work.

    The transaction rollback is in response to the move error, not the other way around.
    i reviewd this error on MAC os 10.12,Centos 7 and windows 7,10 platform. security software ???
    We can only work with the information you give us, so it doesn't make sense to keep sharing new details and then acting shocked that we haven't yet accounted for those.

    If you're getting this on another OS, we'd want to see a Debug ID from there too.
  • Do you have 'storage' symlinked to another drive, or is it a normal folder?
  • I review all debug log on other platform . all of those platform post same move file error.
    no.i did not make is a normal folder on all platform.

    i do not have only security software on linux or mac system.
  • A Debug ID for a failure on Mac or Linux would still be helpful.

    Do the same pages fail across all three platforms, and fail consistently on the same computer, or is it more random?

    As I said above, your original example URL saves for me on macOS, though saving the snapshot is taking long enough currently that the connector times out after 15 seconds and shows an error. That's just cosmetic, though — the client saves the page fine, though, and doesn't generate the move error.
  • i submitted a debug id with D934088100 on my mac .....
    i save the same page of avove .all of three platforms reported same error.move file cause not found error.i think the system did not create the tmp storage of snapshot case the error.
  • If you sort /Users/dddang/Zotero/storage directory by modification time and watch the most recent files while the save is happening, do you see a tmp-* being created at any time during the process?

    Basically what should happen here is that Zotero should attempt to save the webpage (using the same saving code as "Save Page As…" in Firefox) to a tmp-* directory in 'storage'. When the save completes, Zotero creates an attachment item, and within that same DB transaction it moves the tmp-* directory to a regular 8-character storage directory. In your case, when it goes to do the move, it's getting an error that the directory doesn't exist. So either the directory isn't being created at all, it's being deleted by something else before it's moved, or files within the directory are in the process of changing (e.g., if the end of the save isn't being properly detected and it's starting to move it too soon) and that somehow shows up as a 'move' error.

    Since this is happening for you on three different platforms and hasn't been reported by anyone else, my best guess is that something about your network connection is causing this. I tested the Baidu page above with an artificially slowed-down network connection and it worked fine, but it's possible that if, say, a specific request for one of the page components is blocked or throttled, that could somehow cause problems here. But we may be able to figure out more if you watch what happens in the 'storage' directory during the save.
  • edited March 29, 2018
    Yes. the tmp* directory did not create while save snapshot.

    Finally,i find what happened for this problem.

    If some web page request a resouce that waste much more time,then zotero client will never receive onDocumentReady event,so this error occured....

    May be zotero can detect this scene and call stop load page method,just save partial document.
Sign In or Register to comment.