Firefox connector won't save web pages

I'm using newly installed Zotero and Zotero Connector for Firefox on Windows 10. I am unable to save sites classified as web pages by the connector to my offline library (I do not use expensive). I have the Zotero Standalone open, click the button, and nothing happens. It will save the page I am writing this on, as well as some others. Here are the pages that it would not save today:


And I've just submitted a debug report on the first one of those.


John Anderson
  • you'd need to post the debug ID for the report you submitted (or a new one) here.
  • Oh, sorry. Here's a new one for the same page: D1613626462
  • Do you press the button and nothing at all occurs? Could you produce a debug ID where you reload the page?
  • Yes, nothing happened. Here's a debug report while reloading the page and then saving: D478209929. It worked, though I didn't do anything different than usual, except debugging while reloading and saving immediately after. But that shouldn't matter, I would think. I hadn't yet done any troubleshooting either. I tried the other pages I listed above, and they work, too. Weird.
  • Hard to say, but as long as it's working -- my top guesses for what fixed this would be a browser restart or a the page reload, but just guessing, of course. As long as it works, I'd leave it at that. If it fails again, I'd also be interested to see if disabling other extensions has an impact.
Sign In or Register to comment.