[5.0 beta] Saved searches and collections

edited February 16, 2017
I have some Saved Searches that I had made in 4.x that included Collection and Saved Search as conditions. In 5.0, with the combining of Saved Searches and Collections in Advanced Search, the text content of these search criteria was wiped out.
  • I have experienced something similar after an upgrade from to 5.0-beta.141+058a4b1. If I click on any of my saved searches that reference a Collection, I get the message "An error has occurred. Please restart Zotero" (Report ID 1565324900).

    If I right-click to edit the saved search, I also get the same error. But I can access the edit screen, where the Collection name is empty. I can then select the Collection name from the drop down box, re-start Zotero, and the saved search with a Collection works. I can also do this for multiple saved searches and then all these saved searches that reference a collection work.
  • I think this should be fixed in the latest build, 142. Let me know if not.
  • edited February 18, 2017
    Would the fix you did have worked for group libraries? These were all group libraries. (I don't have any libraries synced to my client at the moment where I could check. I've since re-created the affected saved searches.)
  • Oh, no, it wouldn't — I'm pretty sure this fixes the error mc was seeing, but it sounds like yours might have been different. What do you mean by "the text content"? At least when it's working properly, the "value" side should be a drop-down with a list of collections and searches.
  • The "value" column was just a bunch of blank text boxes for the collection/saved search conditions.
  • @bwiernik: That should be fixed now too.
  • Is there a way to sync saved searches to appear in the web interface?
  • Not currently no (they do sync across computers). I believe that's planned.
Sign In or Register to comment.