Cannot import .bib

When I try to import an article bib file from (try, all I get is a pop-up saying 'importing...'. The pop up stays there indefinitely and nothing shows up in zotero.
In the zotero connector preferences, import bibtex into zotero is enabled, but the list of enabled hostnames is empty.
I'm using chrome and zotero 5.0.20.
Best regards,
  • For whatever it is worth, this works fine for me in 5.0.21 and the current translators on both chrome and firefox.

    You may need to look at debug output to figure out what's getting hung up for you.

    But, more basically: do other sites work with the connector? Does the BibTeX import if you load it into Zotero Standalone manually?
  • We've actually had several reports of RIS/bibtex direct import not working via connector from various pages now, though I can't replicate the problem either; posting a debug ID from the connector here that covers trying to import RIS would be helpful:

  • I posted debug info (ID: D958642537) for clicking the 'import into bibtex' on the aes page I quoted above. Zotero was updated to 5.0.21. I still get just the 'importing into bibtex' message.
  • What's selected in the left-hand pane when you try this? I can reproduce this if I have "Unfiled Items" or "Duplicate Items" selected. We'll fix this, but if you select a regular collection this should work.
  • Regarding the question if bibtex import works:
    - I usually copy the bib file contents to the clipboard and then import from clipboard in zotero. That works.
    - When I import a bibfile through file->import... the item is imported but in a newly created collection. Is that normal?
  • to dstillman:
    Typically I have either 'my library' selected or a subcollection (e.g. 'audio' in the case of aes papers)
    I seldom look in the unfiled or duplicate collections.
  • But what's selected now? You shouldn't get this error for a normal collection.

    Also, while we'll fix this, note that you can just click the Save to Zotero button on that page — there shouldn't be any need to use the BibTeX link, or certainly to copy/save BibTeX. What happens when you just click the button?
  • Of coarse I verified that I had 'my library' selected, with the same effect. What I meant is that it goes wrong every time for me, not only in the rare occasion that I have duplicate items selected. The chance of having this problem in the first week after this new feature is public (it is a new feature of zotero 5 isn't it?) would be around zero then.

    The zotero button works fine, but the bibtex import feature is more useful on a page like this:
  • Does the same thing happen after you restart Zotero?

    Not sure what "new feature" you're referring to — there's nothing particularly new here.
  • It happens on my work desktop and my work laptop. I will try to confirm on my home laptop (windows and linux) but so far this behaviour has been consistent over zotero restarts and system restarts on all the computers I have tried it on.

    New feature because (quote from the blog): "Clicking on a BibTeX or RIS file that is served correctly by the website will prompt to import its data into Zotero. If you choose ‘Cancel’, you can download the file normally.
    Note that this feature requires Zotero 5.0."

    I didn't get the prompt to upgrade until very recently.
  • edited September 22, 2017
    (Right, that blog post is from early July, and the feature has been available in the Chrome connector for longer. You also wouldn't have been prompted to upgrade, since we haven't prompted 4.0 users to upgrade yet — you would've had to have upgraded manually. It looks like this bug was introduced in 5.0.12 in mid-August.)

    I was able to reproduce this. It looks like it happens in the library root or the special views, but not in a collection or subcollection — that's why I was asking exactly what you had selected when seeing this. There'll be a new 5.0 Beta version with a fix in a few minutes, and the fix will be included in 5.0.22 in a few days.

    You generally don't want to use this feature when there's a save button, though. On this page, you'll get much better metadata, as well as a PDF and snapshot, if you use the save button. (Granted, Zotero is saving via embedded metadata on this site, and there's no particular reason that should be better than the BibTeX, but it is here. On a site with an actual translator, you'll almost certainly get better metadata from the save button.) For that search result page, it's true that this feature is helpful at the moment, because there's no translator for this site and there's not currently a great way for a site to offer embedded metadata for search results, but we're hoping to offer better options for sites to use.
  • Oops, you're completely right, I did upgrade manually and it only happens when I'm in 'my library'. I was not aware that 'my library' is not a collection in the same sense as the user defined collections.
    Thanks very much for the support!
  • I cannot import from regardless where I am in Z5 (root, collection or subcollection makes no difference). Nothing happens, but the blank extra firefox tab is made. This is in 5.0.21.
    Testing from can import if I am in a collection, but not just to my library.

    I need to think in a new way if I can't use my library as the incoming collection anylonger, but I guess this is a bug in me.
  • From D737883353 (not in a collection)
    From D1058623797 (not in a collection)
    From D1021357189 (in a collection)
  • @Grode: As I say above, the error importing a RIS/BibTeX into non-collections is fixed for the next version. WorldCat's use of a new tab breaks our RIS/BibTeX interception (and I don't know off-hand if we can work around that), but there's no need to use it on WorldCat, where you can just use the normal Save to Zotero button.
  • (I've created an issue to address the problem with RIS/BibTeX files that open in new tabs. But as always, when the save button is available, as it is on WorldCat, you want to use that instead.)
  • Aha, new habit to me, but that is okay. I checked and that works.
Sign In or Register to comment.