Report IDs: 61369549 & 1313747532

The Zotero Error Report says to post the Report ID & a description of the problem on the forums. I looked unsuccessfully for a general topic for such reports, so I'm posting my report here. Sorry if I overlooked a more appropriate, less obtrusive place.

Report ID 61369549: Using Zotero 5.0.17 with the Zotfile plugin on an iMac running OS X Yosemite Version 10.10.5, I tried to bring up the context menu for an item so I could use Manage Attachments > Rename Attachments . This was unsuccessful so I tried restarting the computer. Activity Monitor said Zotero was not responding, so I force-quit it. Then the system rebooted. I logged in and restarted Zotero. It indicated it was syncing. But after a while it quit, saying the process was taking too long.

Report ID 1313747532: This may be associated with another problem. The sync error icon is saying item 167/UIKEICSR has a filename too long.

I went through the process and reported both errors.
  • For the second error, the messages are about notes that are too long, not filenames.
  • Thanks.

    I tried to take a shot of the error message window, but the popup to activate Evernote's snapshot facility closes the error message window. So I'll just have to describe it.

    The part that led me astray is a text string ending with "&FileNam...' too long for item '167/UIKEICSR'." Since "too long" immediately follows "FileNam," I interpreted the message accordingly.

    Now that I know it's a note that's too long, what's the best way to track down the offending item?

    (My Zotero database has about 10,000 items, so tracking the long note down manually is not an option.)
  • search using "All fields and tags" for the string in the error message. Make sure to search in all groups.

    The other error sounds very much like Zotfile's, so you'd need to report there, so one-off errors are not going to be an easy fix, so your best chances would be if you can replicate this.
  • Not getting results. Here's what I did:

    1. Set drop-down menu in search box to "All Fields & Tags"
    2. Copy and pasted the error message string into the search box
    3. The search returns nothing

    BTW, the copied string is: ContentscovernlReader.dll@BookID=56468&FileNam
  • and you emptied your trash and tried this separately in all groups?
  • Think so. Trash is empty, and I do not belong to any groups. So no groups (other than myself) are present in the current session.

    Is it possible that the search string (ContentscovernlReader.dll@BookID=56468&FileNam) is wrong? The actual text in the message has an ellipse (...) after FileNam, and I'm assuming this is inserted to indicate the string has been truncated for the display.
  • try some subsections of the string -- maybe those without special characters. It can't really be the wrong string as Zotero just copies from the note that prevents sync from going through.
    @danstillman shouldn't there be a button in the error message that leads to the note in question?
  • edited September 8, 2017
    Searching for "Contentsc" yields nothing.
    Searching for "56468" yields 4 items, all from the same book. None have any notes.

    Dan: no doubt there should be a button that leads to the note, but there isn't. The only button is one for reporting the error.

Sign In or Register to comment.