He perdido la biblioteca en un upgrade /lost my library

Alguien puede ayudar? can anybody help?
  • Could you say a bit more? Update to which version, what exactly happened, how does your library look now, etc.
    Feel free to write in Spanish
  • Gracias Adams, el tema es que actualicé el sistema operativo de Mac y perdí el chrome. Tras pasarme una mañana en el genius bar, el genius de turno me recomendó crear un usuario nuevo. Resolví el tema chrome pero luego me di cuenta que no tenía la bibliografía de zotero. Estoy en plena tesis doctoral (o sea que imagina mi humor).
    Pero yo creo que salvé el archivo adecuado en una copia de Time machine que creo es zotero.sqlite
    Sin embargo, no hay manera de que me lo abra. Creo que está colocado en el sitio adecuado pero no se ve nada.
  • Utilizo al version de zotero 4.0
  • edited August 24, 2017
    para recuperar tu biblioteca desde una copia the zotero.sqlite, vea
  • La biblioteca (cuando voy a citar) aparece vacía
  • I followed all the steps and it is not working. Possibly I don´t have the correct data file.
    However Time machine has been copying the hd for months/years and I am not able to find the zotero.sqlite anywhere.

    At this point I don´t think I have the data file located. I had one but it is only 1mb and it does not work.

    Please provide tips to locate it within the back up copies: I cannot find a folder for zotero or the file itself

  • If you used to acess the library from a different computer, using Zotero standalone and sycronization, you still have a copy of that library in the said computer on the apropriate folder/location.
  • Thanks PeresGil...unfortunately i did not
  • I new user was created in the Mac computer and the older user was deleted immediatly? If not you still can acess the older user and its files. After creating a new user the appropriate process was to transfer the files from the older user to the new one also, the home folder of the older user should have been saved on an external drive just in case.
  • As last ressource you still can try to use recovery software on the drive. The kind of software people use to try to recover deleted files when there is not any kind of backup, online or offline.
  • But timemachine should really handle this and provide a proper back-up. The Zotero 4.0 library location for Standalone was /​Users/<​username>/​Library/​Application Support/​Zotero/​Profiles/[​randomstring]/​zotero
    Check that on your backup.
  • I followed the appropriate process to a point...but really did not pay attention to that file...neither the genius at the genius bar. And due to space requirements, I ended up deleting the old user. So, in theory, the old back ups are accesible for an old user only that does not exist now. However, I have created the old user again, since I remember the password...same that the new one...and in theory, it seems possible to access to the backup files...the problem is still the same....there is no zotero folder or zotero file....

    anyhow...thanks...I have an appointment with another genius at Mac later this evening....if he is not able to figure it out,....i may give up or try your last suggestion....before starting to input the data again manually....

    thanks anyway
  • Please show the genius you are working with the message from adamsmith. It is unlikely that a random Apple support employee would know where to look for a specific program’s backup in the time machine archive.
  • Hello all. The genius was able to show me/access the hidden folders files from the back-up. But not able to copy the necessary files.
    I think I solved the problem by finding the storage folder and zoter.sqlite file in the FIREFOX folder. Then, did what advised by you in previous messages: move those to the desktop in an temp folder and then copy their corresponding back-ups in the active folder of zotero under Zotero.
    The library seems to be intact.

    As a suggestion, I recommend to advise people that it is OK to remove files from a Folder like Firefox and copy the backup files into a different folder (Zotero). The genius had a problem believing that - I can understand- that would make a bit more clear I think.

    now, I have a final problem for which I ask for help:
    when I try to sync zotero so I have the library in the web, it gives me a message of conflict that says:
    Resolución de conflicto
    El siguiente item se ha cambiado en múltiples ubicaciones. Elija la versión que desea conservar, y entonces pulse continuar
    it shows:
    objeto local borrado
    objeto remoto (red colour)
    unir objeto

    apparently the choice is between objeto local or remoto...I imagine that I have to choose remoto but it scares me that it says objeto local borrado (since I just get it back)

    don´t want to lose it again

    please advise, thanks

  • What you are seeing is just a conflict between the local version of the item and the one stored on the remote server (this usually happens if the item were edited in two different places). You don't have to be concerned. Just look at the two versions of the item shown in the popup and choose to keep the one that is more correct. Zotero will keep the version you pick. If they look the same to you, just pick one (it doesn't matter which in that case).
Sign In or Register to comment.