Connector unable to communicate with the Zotero

Hello, the report ID is 1170571350

I am using Ubuntu 16.04 with Firefox. I recently upgraded to the new Zotero and switched to the Zotero Connector instead of the old Firefox version. I had to fix some issues with the library, but worked it out, and everything was fine. Now I started Zotero today and it said it was installing some updates. After this the Connector can't communicate with the application, although "Zotero Connector Server is Available", according to
Any ideas? I tried simply restarting Firefox and Zotero, disabling uBlockOrigin, but it doesn't help.
  • edited August 23, 2017
    If you can reach the page manually then it's likely not a proxy or firewall issue, but one related to extensions or firefox privacy settings. Try installing the Connector in a new Firefox profile and see if it works there.
  • I tried creating a fresh profile and installing the connector - it helps. What could be the problem in my profile?
  • No ideas? What should I try to disable, maybe?
  • If you go to the Connector Preferences do you see the "Proxies" tab at all?
  • Ok, there's another bug that causes Proxies tab to not be displayed, but if you see it, then you are not affected. In that case there's nothing specific we can recommend if you don't want to reset the profile. The way to go is to disable extensions and tweak firefox preferences until it works. You can quickly see which preferences are non-default in your profile by navigating to about:config (they'll be bold), although the prefs have little context/explanation, so you'll have to figure that out by guessing/googling.
  • OK, I disabled a bunch of add-ons, and now it seems to work... I think all of them were related to feedly though, so maybe that was the problem. If there is interest in it, I can try to test whether that was the issue.
  • I'm still receiving the "Saving Item…
    This item could not be saved because Zotero is not open or is unreachable. Please open Zotero and try again."

    Do I need to turn off all my addons?
  • Certainly for testing, yes.
  • After disabling all my addons I still get the same message.
    Saving Item…
    This item could not be saved because Zotero is not open or is unreachable. Please open Zotero and try again.
  • and to be clear -- you have Zotero Standalone running when you try?
  • When I have Zotero Standalone running everything works perfect. I just want to be able to save pdfs even when the standalone is not running, like with the previous connector version.
  • Rigth, I don't think saving a PDF to the server directly is currently possible.
  • I got this error when I was viewing a PDF file in Chrome and tried to save it with the extension button. It seems the plug-in has a bug, since it should not suggest saving it if it is not possible.
  • edited June 11, 2020
    @fuhrmanator: This thread is almost three years old. Start a new thread and explain exactly what you're trying and what's happening.
Sign In or Register to comment.