Firefox update & Zotero add-on Error

I used the Zotero plugin for Firefox this morning and I believe that after an automatic Firefox update today, the plugin has disappeared. Under Add-ons it shows it as "Legacy" but I can no longer access my files.
Any advice?
  • As far as I know the Firefox 55 update shouldn't have changed anything, other than showing that Legacy badge in the Add-ons pane.

    We could debug this, but the easiest thing to do would be to install Zotero 5.0 and the new Zotero Connector for Firefox, which you'll need to do in the near future anyway due to changes coming in Firefox 57 (as explained in A Unified Zotero Experience).
  • edited August 8, 2017
    Unfortunately, I don't think my files were the worry is that they are deleted and won't be restored with the new install.
    Thoughts? What about restoring an older Firefox version?
  • edited August 8, 2017
    No, you wouldn't have lost any data just by upgrading Firefox.

    Let's back up. What do you mean by "can no longer access my files"?

    If you mean that you reset Firefox and see an empty Zotero library, see Restore After Firefox Reset. If you mean something else, we'd need more details.
  • Firefox upgraded automatically this afternoon. I use the Zotero plugin (which wasn't synced to my desktop library). Currently, I can only see the Zotero "legacy" in my Add-ons Manager, but can't open Zotero or access my PDFs.
  • but can't open Zotero or access my PDFs
    Right, but what do you mean by that?
  • Previously I would open Zotero in my browser and would see my entire library. Now, I can open the desktop version of Zotero, but my files are not there. I've searched for the zotero.sqlite file, but the only one is years out of date. When I go to the Zotero website, my Library is empty as I was not syncing them.
  • But why can't you open Zotero in Firefox? Again, Zotero for Firefox is still compatible with Firefox 55 — nothing has changed on that front yet. Firefox 57 will require that new Zotero Connector for Firefox, and at that point you'll need to use the standalone Zotero program to access your data, but that's not the case yet.

    If you have the standalone Zotero program installed, though, you can just point it at the 'zotero' directory in your Firefox profile directory.

    There's essentially no way that upgrading Firefox would've deleted your data, so it's still on your system.
  • Thank you! I found it using the Firefox profile directory. (When I searched for the zotero.sqlite file previously, that folder had been excluded because it was in my Library folder, which was hidden by the OS).
  • I'm having a similar issue after the Firefox 55 update today. The Zotero icon is no longer visible on my browser. When manually trying to open Zotero from the toolbar, this message appears: There was an error starting Zotero.

    I've been using for years, but never had this problem. I'm kind of at a loss as to how to proceed. Any suggestions would be appreciated.
  • Can you provide a Report ID after seeing this error?
  • I don't think that's possible since I can't open Zotero.

  • Looks like I'm using Zotero according to the extension info. Not sure if that helps.
  • Sorry, that's true. How about a Debug ID from Firefox startup, using the "Enable after restart" option? You should be able to open the Zotero preferences from the Firefox Add-ons pane, even if you can't open Zotero, though I'm not positive the debug output logging functionality will work. (If not, there's something else we can try.)
  • I'm running the Debug Output Log by submitting to Zotero server, but it's been running for about 30 minutes. Still no Debug ID.
  • It would be immediate. Just view the output, copy it, and email to with a link to this thread.
  • Nothing opens when View Output is clicked.

    I'm a teacher who is screwed without access to Zotero files. Would it work to download Zotero again and direct it to my existing zotero.sqlite file (providing it still exists)?
  • Actually, hang on — I can reproduce this in Firefox 55. Sorry for the trouble. We'll have a fix out shortly. If you're in a rush, you can upgrade to Zotero 5.0.
  • I'll hang tight if there might be an quicker solution...thanks.
  • OK, Zotero is out now with fixes for Firefox 55.
  • Great. Would I be able to update with my current situation, or do I need to install as if starting from scratch?
  • You can update from the Add-ons pane or reinstall from the download page. No difference.
  • Okay, thank you.
  • unfortunately not working in my case with firefox 55.0 (32-Bit). at the add-ons pane I get the message that an error occurred while downloading. I tried several times and restarted FF.
  • I note that this issue also occurred with the current builds of Juris-M firefox plugin, and all of the auxilliary plugins (Myles, Word plug in, etc)
    @fbennett any chance that this is a quick fix?
  • @ccba3689: Sorry about that. Installing from the download page was working, but there was a problem with the update mechanism. Try again now.
  • thanks a lot, zotero updated automatically today
Sign In or Register to comment.