Zotero 5.0.6 (Standalone) MS Word Addin Fails to load


I am facing this issue since I first upgraded to 5.0.
The zotero addin in word is totally non responsive almost 95% of the time.
I have tried reinstalling a fresh copy of Z5, after performing complete cache cleaning and registry cleaning with CCleaner. I have tried deleting the zotero.dot file and reinstalled the MS word integration.

The problem persists.

Any suggestions?
  • Is it fine in a new document? Are you working on a very big document? Did anything else change in your computer?
  • Thank you for the quick response
    Its an 8000~ word document with around 50 references.
    I have tried waiting for the interface to load for over a minute at a time before clicking it again but it doesn't load.
    I have removed mendeley from my system, whose word addin vanished once I updated Zotero to v5. Besides that, I dont think anything else changed in my computer
  • Is it fine in a new document? Was it fine for this document with Zotero 4.0? Could you submit a Debug ID for clicking the plugin button (you should wait a minute, before submitting)?
  • The problem persists in new/ blank files.
    It was working fine with the latest version of Z4.
    I will be submitting the debug ID shortly. It started to work all of a sudden and, correct me if i am wrong, I don't think the debug script submitted now will be of any use.
  • Yeah, we'd want the debug log to capture the plugin function going wrong.
  • I guess you are using a actual Version of Word.

    With older Word-Versions, there were advices to copy the whole Text in the Word-File to a new, empty word document, if such failures occured.

    You could try this without risk, but I'm not sure if e.g. the fields with the Citations are copied correctly with this was - but it's worth a try.

    In older Word-Versions there also was the advice NOT to copy the last paragraph-mark in the document, but the whole text before, cause in this last paragraph-mark there is the link to the normal.dot, which normally caused those problems.

    I would not delete the normal.dot without having a copy of it!
  • Thank you for your responses.

    I ran the debug logger and left it alone for about two minutes. The problem went away due to some reason. I thought it must be temporary like before but I have restarted my laptop some 5-7 times since yesterday and restarted Zotero for over 15 times and it is working fine.

    One odd thing did happen, which may point out the underlying fault. After the first system restart that I did yesterday, a folder appeared on my desktop named Firefox old data. Maybe the issue was linked with FF? [because I don't use that browser, so it wasn't me who triggered this old data dump].

    @HThole I tried copying a few paragraphs into a new file with "keep source formatting" option to keep the citation fields intact. The problem persisted.
    I am using MS Word 2016, all updates installed, on a Win 10 machine.
  • @"Sajid Nadeem" Is there a possibility to make an integrity-check in Zoteros library?

    And as you are writing about the "Firefox old data"-folder: Did you try to install Firefox and the Zotero Connector? Maybe this helps.
  • @HThole I did see a "Check Database Integrity" option in Advanced tab in preferences. Haven't tried it though. My issue got resolved automatically due to some unknown reason after a whole week of trying various solutions.

    I do have Firefox installed and I think It had the Zotero Connector installed too. Don't remember for sure as I haven't used FF for over 3 months.
  • @"Sajid Nadeem" O.k., I guess that your Firefox was totally out of date and performed a number of updates, and then the Zotero Connector had to be updated, too.
  • @HThole As per my humble knowledge, FF only installs the latest update, and not the ones you have missed. Plus it gives a popup message to restart Firefox once the updated has been downloaded and is ready to install.

    Besides, I was using Z connector on chrome which was working great and was updated when z5 came out.

    Maybe Z5 also tried to update Z connector in Firefox and that's what caused this issue? [Don't know for sure whether Z5 installs connectors automatically, just a guess]
    For several reinstalls of Z5 that i did over the last week, i deleted Z connector from chrome and not FF. Maybe that's why it somehow finally dumped the old data ?
  • I think so. Maybe this gives a hint for the users as well as the developers to work out some scary problems, if they occur again... like having the ghost of Firefox old data dump, when you update Zotero.

    This "Firefox old data dump" seems to be the real browser history...
  • Agreed. Maybe our spit balling gives the developers some idea about the problem to resolve the bugs.
  • edited July 25, 2017
    Firefox and the Zotero Connector have no effect on word processor integration in Zotero 5.0.
  • @dstillman Yes, but it seems that an old Firefox-Version made that problems wheninstalling Zotero 5, as i get it here. I could imagine that, as I keep my software up to date, and no one maybe will have tested what happens when when you install Zotero on a system where you updated e.g. your Chrome-extensions, but not Firefox.

    This is a rare case, and it's only a guess which is halfway educated.

    On my System all Zotero 5 related updates work perfect.
  • The issue returned yesterday. I again tried clearing cache and restarting my laptop but it didn't work. But when I started logging to submit a debug report, suddenly the bug went away !
    So I guess that's the solution for the time being.
    Threaten Zotero to tell on it and it will start working fine :)
  • The bug has resurfaced.
    Please review this debug ID.

  • That's not a valid Debug ID. Could you try again?
Sign In or Register to comment.