Bibliography Italics Problem


Using Chicago style with full bibliography, when I got to create the bibliography at the end of the essay: the first two letters of a book are NOT in italics, and the rest of the book is in italics.

ex. Dumarçay, Jacques, and Pascal Royère. Cambodian Architecture: Eighth to Thirteenth Centuries. Translated by Michael Smithies. Leiden: Brill, 2001.

The "Ca" is in regular font, and the rest of the Title in "Cambodian . . . " is in italics.

Is anyone else running into this problem?


  • Hi All,

    I am still having the same problem as above, I just download Zotero 1.0.4, but the bibliography still gives the title of the book with the first two letters as regular font and the rest correct in Italics.

    So, with a bibliography of a few hundred books, I have to go in and manually change the first two letters of every book to Italics to get it to work right, is no-one else running into this problem?


  • Hi again,

    Actually, now that I take closer look at it, it is now doing all sorts of crazy things in the bibliography.

    Now it is taking the first letter in normal font of various items and changing them to italics!

    Please help!

  • And again,

    The only information that I can add -- the first 4 bibliographic entries look fine. No problems. It starts with the 5th. Bibliographic entries # 2-4 are the same author, so I have a repeated author for 3 and 4 and this is represented by "---". Could that be causing some kind of problem?

    I will play and see if this is the case.

  • Hi All,

    OK, so sorry for all this. After weeks of struggling, I just got lucky.

    It seems that two of the letters in the 5th bibliographic entry had French accents which were NOT a single letter, but a combination of a letter (the e) and an accent (the grave accent). Once I changed that to a single letter rather than a combination of the two, it put all the formatting back one, and then I had to change a c as well.

    Very strange, but it is fixed.

    I write this just in case someone else has the same problem, the fix is to be sure that each letter is a single letter rather than a having the accent be a separate coding.

    Take care,

  • I have encountered the same problem, but with the Word plugin. Although my citations appear correct in the csl preview, the Italics are nearly always offset about 13-15 characters. For example:

    Renfrew, C. The Emergence ITALIC STARTS of Civilization: The Cyclades and the Aegean in the Third Millennium B.C. Studies in ITALIC ENDS Prehistory. London: Methuen and Co., Ltd., 1972.

    I have tried removing the hanging indent both in Word and in csledit, and I've also made sure that there are no foreign characters. Yet the glitch keeps on happening. Previous posts seem to have resolved the issue, so I wonder - am I alone here?
  • No, you are not alone...
    Same issue: The first part of the bibliography is fine, then after some 20 entries, the Italics starts to move away from the beginning of the title/journal title by one, two and later up to 5 letters, including at the same time an increasing amount of letters from the following field, place of publisher for books or volume and issue for journals.

    I don't know about a proper solution but for me the problem occured in word on a windows (XP) maschine but didn't occur when I use word on my Mac.
  • I just downloaded Zotero 1.5 and I still have the same problem!
  • I join you guys. Have the same problem with these italic mix ups ...
  • I've just downloaded 1.5 as well with the new Word plugin to support it (Word 2007 on Vista), and am seeing this exact same problem for the first time. In most of the styles I have tried, the italics (or underlining in the MLA underlining style) are misaligned with the text to be underlined, starting two or three characters after the start of the title, and ending two or three characters into the next item (usually the place of publication). I have accented characters (everyday ones such as é and í) in a number of the author names and titles. The offset does seem to increase with the number of accented characters, and the offset accumulates, but it's not a simple one-to-one relationship (one accent = one character offset) as far as I can tell. I've published several papers in the past using Zotero (pre 1.5) and works in Spanish, and this is the first time I've noticed this problem. I have updated to the latest styles in the repository, and still get the same problem. I'm sure it's a bug in the plugin, and may be related to utf-8 double-byte characters? (Guess.)
  • OK, I've done some investigating and have discovered something interesting. The offsetting of the italics occurs for records which contain diacritics where I've downloaded the entry from a library database (OPAC style). If I look in my bibliography at the first point where the problem occurs, and go into Zotero and edit the fields where there are diacritics by retyping them myself and then "Refresh" the bibliography, the problem goes away for that line. I can then go through my bibliography retyping fields until all offending entries have been removed.
    This must be a characterset issue. It's odd that Zotero displays the diacritics correctly, but the Word plugin is clearly miscounting the length in downloaded records. Perhaps the source encodes the characters with some kind of \x001 or similar coding and the characters don't get fully translated into existing charactersets unless they are manually typed in?
  • @Geoffrey: Great suggestion, your solution did it for me too. Just retyping the entry where it began to cause trouble. Saved me a lot of reformatting.
  • After working with this for a few days, I notice that despite the workaround suggested above (retyping diacritics in fields imported from databases), the Word plugin seems to get "reset" from time to time, and I get offset italics again. This time, the workaround is to select a different style in the plugin options, allow the document to reformat with the new style, then go back to the options and select the original style. After reformat, the italics are no longer offset. Strange. Looks like we might be looking at two different bugs.
  • I could sort my list with Geoffrey's work-around suggestion. Thanks!

    It applies equally to German and Scandinavian letters that don't exist in the English alphabet. They are properly displayed in the Zotero database after downloaded from a library database, and the plug-in displays them as well, but the italics get messed up from the next references onwards.
  • I'm also seeing a similar issue in footnotes and bibliography with the SBL style. When records with a non-English character from a Roman alphabet (e.g., î) written as the letter plus an accent mark (e.g., i + circumflex) rather than as a single, unicode character (e.g., "Latin Small Letter I With Circumflex" – Alt+0238) are used in compound citations or a bibliography, italics in the following citations (within the same compound note) or bibliography entries are offset. Replacing these "letter plus accent mark" combinations with the equivalent, single character seems to resolve the issue.

    When using non-Roman alphabets, however (e.g., Greek, Hebrew), can this italics issue still be resolved somehow? For example, ῆ (i.e., η + circumflex, written separately) causes italics to offset in subsequent citations and bibliographic entries. Yet, if I open the Windows character map, this combination (and several others besides) does not appear to be available in the Unicode set as a single character.

    Thanks so much for the help!

    Windows XP SP3, Microsoft Office 2003, Firefox 3.0.10, Zotero 2.0b5, Zotero Word Plugin 1.0.4b
  • I had the same problem. One solution would be to have the Word-plugin taking care of these characters in the step of formatting (to get rid of shifting of the formatting, it seems that these characters are just not "counted" in the right way).
    Or these characters could be all replaced (automatically) in the Zotero library, as a kind of data base house-keeping, and/or already by the site translators when importing the bibliographic data.
  • Hi,

    I'm also having the same problem, mainly for the bibliography, after a few references (3 pages), and not (only once in fact) in the footnotes (Chicago Style). If I get the bibliography directly from Zotero, no problem, so the problem is clearly on the plugin side.

    As far as I can see, in my case, it has seemingly nothing to do with diacritics, and rewriting the fields doesn't change anything. Changing the style before coming back to the original style doesn't change anything either.

    I'm using Zotero 1.0.10, but I was considering moving to Zotero 2. But seemingly some of you have the same problem... (same problem with Python than with VBA?)

    Have someone found another type of solution ?
  • I hear the new Word plugins (to released soon, I hope — though 'in a few days' has proven to be a very loosely used term here) have been recoded, so chances are this problem is gone with the new version that comes with Zotero 2.0beta7.
Sign In or Register to comment.