Zotero 5 (185) - Bug: Can't insert field

Hello to all
Working on a docx file for a few days. I might not have inserted new references since last update (185). This morning, I tried and obtained an error message:
can't pass the string "1" to argument 3 of unsigned_short insertField(struct document_t*, char16_t*, unsigned_short, struct field_t**)

Strangely enough, if I copy an already existing reference, paste it and modify it, everything is fine.
Log number: D2084229797
  • Does it happen in a completely empty new document?
  • No. In a new empty document, everything is fine
  • Sorry about that. We will push out an updated version of beta in the next 24 hours fixing the bug.
  • A new beta version is out with a fix for this.
  • I just received the exact same error after updating to the newest beta version. I got the same error in documents in which I was already working, but Zotero worked fine in a new, empty document.

    After checking Zotero for updates just in case I missed something, I discovered that if you go into Document Preferences and switch your citation style to something other than what you are using, then switch it back, you no longer get the error when trying to add in new citations.
  • This is certainly fixed in Beta 186 onwards. What version of Zotero are you running? Can you provide a Report ID?
  • adomasven - Just submitted a report; here's the ID: 389582191. I get the error in any document that I've already been working in. But it doesn't happen when I work in new, blank documents. And I can fix it by going to Doc Prefs, switching the citation style, and then switching it back. I'm running Beta 188. Thanks!
  • What style are you using?
  • American Sociological Association (ASA)
  • Ok, there was another bug, fixed in the Beta 194 out now. Thanks for reporting, @smorris11
  • Thanks, @adomasven! Just updated to Beta 194, and it fixed the original issue. However, another problem has come up. Now, when I click in a citation to edit it - say, to add another author to the cite, the citation box either comes up empty (when normally, it shows what is currently in the cite) OR it continues to show whatever citation I first tried to edit, even if I click on and try to edit another citation.

    I am not getting an error, however, so I am not sure how to report it. Thoughts?
  • We'd want a Report ID for that too.
Sign In or Register to comment.