[Juris-M] - HeinOnline Translator not working - Report ID unavailable

Dear All - the translator for HeinOnline stopped working on my PC. First, it stopped saving PDFs directly to ML-Zotero, then it stopped saving citations as well.

I hope you can solve this problem.

The last error report that I have is the following, but it doesn't seem relevanto to the issue I have...

[JavaScript Error: "1449151979627 Toolkit.Telemetry ERROR TelemetryStorage::loadAbortedSessionPing - error removing ping: PingReadError JS Stack trace: PingReadError@TelemetryStorage.jsm:80:15 < TelemetryStorageImpl.loadPingFile<@TelemetryStorage.jsm:1448:13" {file: "resource://gre/modules/Log.jsm" line: 749}]
[JavaScript Error: "TypeError: this._recipeManager is null" {file: "resource://gre/modules/LoginManagerParent.jsm" line: 185}]
[JavaScript Error: "Item is not case, statute, bill, order or gazette, and has no title" {file: "chrome://zotero/content/xpcom/translation/translate.js" line: 590}]
[JavaScript Error: "TypeError: aRequestOrigin is null" {file: "resource://gre/modules/commonjs/toolkit/loader.js -> resource://jid1-f9uj2thwoam5gq-at-jetpack/lib/shared/policy.js" line: 94}]
[JavaScript Error: "ReferenceError: Zotero is not defined" {file: "chrome://freelawferret/content/browser.js" line: 14}]
[JavaScript Error: "Item is not case, statute, bill, order or gazette, and has no title" {file: "chrome://zotero/content/xpcom/translation/translate.js" line: 590}]

[JavaScript Error: "Item is not case, statute, bill, order or gazette, and has no title" {file: "chrome://zotero/content/xpcom/translation/translate.js" line: 590}]
Could not read chrome manifest 'file:///C:/Program%20Files%20(x86)/Mozilla%20Firefox/chrome.manifest'.
[JavaScript Error: "Item is not case, statute, bill, order or gazette, and has no title" {file: "chrome://zotero/content/xpcom/translation/translate.js" line: 590}]

version => 4.0.26m512, platform => Win32, oscpu => Windows NT 6.1; WOW64, locale => en-US, appName => Firefox, appVersion => 42.0, extensions => RTF/ODF Scan for Zotero (1.0.22, extension), Free Law Ferret (1.0.129, extension), Zotero Word for Windows Integration (3.5.2, extension), Abbreviations for Zotero (1.0.202, extension), Codec video OpenH264 realizzato da Cisco Systems, Inc. (1.4, plugin), Modulo Primetime Content Decryption fornito da Adobe Systems, Incorporated (15, plugin), Adobe Acrobat (, plugin), Gaaiho Doc (, plugin), VLC Web Plugin (, plugin), Silverlight Plug-In (5.1.40728.0, plugin), Lightbeam (1.3.0, extension, disabled), QuickTime Plug-in 7.7.8 (, plugin, disabled), Microsoft Office 2010 (14.0.4730.1010, plugin, disabled), Microsoft Office 2010 (14.0.4761.1000, plugin, disabled), Java Deployment Toolkit 6.0.450.6 (6.0.450.6, plugin, disabled)
  • It's possible this is generally broken, but you should update to the latest version of MLZ, which is juris-m, available from
  • Thank you. I have installed Juris-M and now I don't even have the button that I usually clicked to add a citation from HeinOnline to Zotero...what can I do?
  • edited December 4, 2015
    Ok, now I can see the button, but it still tells me there is an error with the translator and I have no report ID.
  • could you edit the title of this thread (edit your first post) to include [juris-m] so that the developer sees this. He's also the last person to work on the Hein Online translator.
  • Done - I forgot to say I'm using Firefox (latest version).
  • Thanks to adamsmith for fielding this, sorry to be late to the party.

    The current version of the HeinOnline translator in Juris-M works only against search lists. You'll get an error when attempting to download an individual item, but the same item selected from the Zotero/Juris-M pulldown list should come through fine, with the attachment.

    I won't have time to work on the translator for another couple of weeks, but that should be right for the present. If downloads from the search listings are not working, let me know and I'll take an early look.
  • Hi again! I still have issues with the translator for HeinOnline: it doesn't save the citation correctly and it does not download the pdf. Is there a fix for these issues?

    Thank you!
  • I am having a problem with the Heinonline translator. It is inputting the variables correctly, but every field is being entered with a leading "- " (hyphen space). Is anyone else having this issue?
  • Hi - yes, I am having the same issue. Also, the translator only picks the starting page of the articles, instead of putting the first and and the last page.
  • I know that issue, it's an old flaw in the translator that I thought had been washed out. Here is the current translator version:


    If you drop that into the ./translators subdirectory in your zotero data directory and restart, it should work better.
  • Thank you, fbennet. Can you please explain more in detail the procedure to update the translator? When I click on the link, a webpage is shown. What should I do exactly?

    I am using Juris-M on firefox: where can I find the subdirectory?

  • Sure thing. The first step is to save that page to a file HeinOnline.js on your desktop. Then find your Zotero library following these instructions:


    (Just follow the instructions for finding in it Preferences, immediately under "Locating your Zotero Library" -- you shouldn't need to worry about default locations, etc.)

    Your Zotero data folder will have a subdirectory translators. Copy the HeinOnline.js file into that folder. Then restart Zotero, and if all goes well you'll be back in business.
  • Perfect, problem solved! Thank you!
  • Excellent. I'm not sure why the translator didn't update properly. That's one for me to investigate when time permits.
  • edited June 20, 2017
    Just a note that this problem continues. With the most recent update of Juris-M addon (for FF 54), the translator for HeinOnline reverted to adding in the extra hyphen. The above fix, replacing the translator manually, solved the problem as before. I thought you would be interested to know that (some?) translators are not updating correctly (or are updating incorrectly)?
  • Translator updates have been fixed in JM5, will map the change to JM4 shortly and post back.
  • edited June 20, 2017
    Translator updates should be working in the latest JM4 release.

    In haste,
Sign In or Register to comment.