Can't pull citation and/or pdf files from JSTOR on Windows 10 64 bit


As in the title, I'm having trouble with Zotero working with JSTOR on Windows 10 64 bit (running Release Preview).

In Firefox (tried both 32-bit and 64-bit versions), regardless of whether I use the Zotero add-on alone or as a connector to Zotero Standalone, I can't get pdf files saved. Yes, I accept terms and conditions first every time. I am only able to save citation data and saving pdfs fails, even when I click save in the window in which I have the pdf open. I tried the Zotero 5 beta and it's actually having even more problems than the old Zotero. On article page it saves the article as a webpage (it doesn't recognise it's an article). On pdf view (via the Firefox built-in pdf viewer) it tries to save the pdf without metadata and fails.

I got Google Chrome connector to work with JSTOR ONCE. It worked for a day and then stopped (since then I reinstalled Zotero Standalone and Chrome connector multiple times, but it didn't help). And now when I try to save anything it shows it is saving, but it never does - and the box in lower right corner that says it is saving stays there until I refresh the page (it only says to which folder it is saving, the article data never appears there).

I used Zotero as a Firefox add-on on Windows 10 32-bit Release Preview on the same laptop and it worked like a charm. I have it installed on Vista 32-bit on the same machine and it works without issues.

I really am running out of ideas. Any help will be greatly appreciated.
Sign In or Register to comment.