[5.0 Beta] apparently stuck at "saving to..."

When I click on the connector (Firefox) to save something, the little window on the bottom right corner gets stuck on the very first message "saving to...". It doesn't even list the full set of things (PDF, etc.) that would end up saving. But it really works, everything gets saved. It's just an issue with the progress message.
  • Does this happen on every site? If you go to extension preferences, does it say that Zotero is available? If not you should look here.

    If Zotero is available, could you provide a Debug ID for a save operation?
  • It's happened in every single place I've visited, but I've just installed 5.0 beta in order to try to help with bug detection. Zotero is available, yes.

    Debug ID is D804891378, I've done it with MathSciNet.

  • Did you try restart Zotero and Firefox? I have sometimes the same problem, but restart helps.
  • Yes, I tried, but it was of no help.
  • @fmuro: Thanks. Could we also see a Debug ID from Zotero?
  • @dstillman sorry, maybe I didn't understand it, isn't that what I gave above?
  • You gave one for the connector. The Zotero client is separate, also explained in the instructions.
  • Thanks for clarifying! That happened in my office's desktop, I'll do is tomorrow, as son as I arrive.
  • @dstillman for Zotero: The Debug ID is D1114229288.
  • OK, I have the impression that the message ended up disappearing in the last debug ID import. It was an MSP journal. Then I tried an Elsevier journal and it didn't catch the pdf (the message was therefore stuck there). I restarted zotero and then it did it. I tried again with the same journal (no restarting) and it worked again. Then I tried with MathSciNet and here there seems to be always a problem. I check my last MathSciNet imports and (unlike I believed) they didn't work out well, the snapshot file is empty in all cases. I reseted the translator (which I had modified according to https://forums.zotero.org/discussion/comment/269271#Comment_269271) but then nothing at all was saved, as reported in that thread. I think it's definitely related to the MathSciNet translator. Maybe it gets stuck and it spreads the disease to processes which are run afterwards... If I can help in any way to further debug this, please ask. Thanks for your help!
  • It's definitely a problem with snapshots. I also experienced the arxiv translator not saving snapshots, but it was solved after a restart.
  • Are you sure saving on MathSciNet works? I get the "Saving to..." message, but the progress window disappears and nothing is ever saved in my library. Seems that the translator does not detect any valid items. Might just be a translator issue.
  • Oh right, I missed your earlier comment. Do you actually have an example URL where it consistently saves the items in Zotero, but does not show progress properly?
  • @adomasven no, when it gets stuck, the problem is with the snapshot, just a blank file is saved, or no file at all, but I hand't noticed this, I just noticed that PDFs were being saved so I thought everything was OK, but it wasn't.
  • Bump! Any chance this will be solved soon? I mean, I don't want to try to put pressure. It's great what you offer us for free. More than great, invaluable, but I heavily depend on this translator. Could you consider the possibility of temporarily not downloading mathscinet snapshots if fixing the issue is difficult? In this way the translator would not hang and libraries won't get populated with blank snapshots. Thanks in advance for your help!
  • I haven't tested this in the beta, but I'm not seeing this error in 4.0. Can someone else check on 5.0?
  • assuming this applies to all of MathSciNet: http://www.ams.org/mathscinet-getitem?mr=3278772

    (requires site license; if you're only seeing the "Relay" version of the page, Zotero won't detect)
  • @fmuro Sorry it took so long. I couldn't reproduce a month ago, when I was testing this, with the URLs I had, but adamsmith's URL reliably reproduces the problem. A fix for indicator/hang should be out shortly.

    Regarding the snapshots I have not managed to get to the bottom of it, but I am getting inconsistent results. Something to do with proxying and MathSciNet evil javascript cookie hacks to try and deny crawlers saving the contents of the pages. I've created an issue to track this, but I'm not sure when the fix will be out.
  • @adomasven Thanks!!! You, Zotero developers, all of you, are nice and responsive people which make the job of many of use infinitely easier.
  • I'm bringing this forward because today it doesn't get stuck!! I'm running 5.0 beta version 183. I'm surprised because github doesn't reflect any change to the translator, so maybe it had to do with other parts of Zotero? Concerning the snapshots, most of them contain all the relevant data although they don't look exactly like the original web page, there are some glitches.

    All these are great improvements, folks, thanks!!!
Sign In or Register to comment.