Local attachments files not updated to their latest version/Papership/Webdav


I have set up zotero to store my attachments on a webdav hosted by box.com. I access the files on Papership both on my ipad and iphone. Here's the situation I am confronted to:

1/ I annotate a PDF from Zotero using Preview for example
2/ Sync it to the webdav server
3/ I can open it with Papership and see my annotations
4/ If I add more annotations in Papership
5/ Sync it
6/ Open in Zotero, my modifications are present and the latest file is synced in my local database

But if
1/ I open a PDF in Papership
2/ Add some annotations
3/ Sync
4/ Open the PDF in Zotero, my annotations are NOT present and though the Modification date corresponds to the last modification date, if I select Show File, the modification date in the file browser is the original one when the entry was created, which means the file has not been updated to its latest version.

I have tried resetting the file sync history with no avail.

I thought Papership was the problem but I have also tried annotating with Goodreader and got the same result.

I have also tried on many files and the results I get are consistent.

Would you have any idea?

  • edited May 27, 2016
    That still points to a problem in PaperShip, so you'll need to talk to them. We can only provide support for syncing in official Zotero clients.

    (For help thinking about this, see Files Not Syncing — but here "Computer A" is PaperShip. You'd want to look at whether the appropriate .prop/.zip files are being modified on your WebDAV server after syncing with PaperShip, and also whether the lastsync file is being updated properly.)
    I thought Papership was the problem but I have also tried annotating with Goodreader and got the same result.
    What matters is what you're syncing with, not what's doing the annotations. I assume you're still talking about syncing with PaperShip.
  • Thanks Dan for your swift answer!

    One element I forgot to mention though is that the syncing does work between Papership apps: any annotations which was made on the iPad for example do show up after sync on my iphone and vice versa. Even Zotero does notice a modification in the file as it displays the right modification date.

    So then if it has nothing to do with the .prop/.zip files which seem to be updated correctly in this case, it may be the lastsync file which is not properly updated?

    I'll talk to Papership and post what they answer here too.

  • I'm having the same trouble.
  • Me three. Anybody able to resolve this issue? I have heard nothing from their customer service either. I'm starting to regret my Papership purchase.
  • Same here, I cant even get annotations to sync between PaperShip (iphone - iPad). Any word from the Papership customer service would be appreciated.
  • Also having trouble but not sure of an alternative to PaperShip on iPad. I need to investigate further but I thought one possibility for the issue may be that the file name for the pdf seems to change during the process of creating newer annotated versions of the paper?
Sign In or Register to comment.