Zotfile 5.0 Beta (for Zotero 5)

Zotero 5 is around the corner and requires a significant update to add-ons. Zotfile 5.0 is designed to be compatible with Zotero 5.0. However, it's unlikely to be ready in time for Zotero 5. BUT you can help by testing Zotfile 5.0. Just install the version from the 5.0 branch at https://github.com/jlegewie/zotfile/tree/5.0. Installing this version requires some manual steps. I might put an xpi online later but for now that's how it us. What I don't have time for but desperately need is systematic testing. So if you want to help: test all the different features with various options but don't use your main database. If something doesn't work, post here or open an issue on github with detailed steps to reproduce and preferably an error message.


Some known issues are here: https://github.com/jlegewie/zotfile/issues?q=is:open+is:issue+milestone:5.0
  • Hi @Joscha,
    Cannot install this as my Firefox 49 will not allow me to install an unsigned version. What needs to be done?
    Kind Regards,
  • Thanks @Joscha. I have started using Firefox developer edition. A few things are still breaking, but this is the fun I suppose of learning how to fix things and work with it. You have done a great job with the ZotFile.
  • Great. Please report any bugs with the exact steps to reproduce and possibly any error messages: http://zotfile.com/#reporting-a-bug
  • @Joscha Hi. zotfile does not move files in custom folder when renaming them
  • Just to clarify: the 5.0 version of Zotfile can only be installed in Zotero 5, correct?
  • @Gabriel_p it is.

    @arinbasu this is a workaround that has been working for me the last couple of days: http://www.ghacks.net/2016/08/14/override-firefox-add-on-signing-requirement/
  • edited January 23, 2017
    There's no more Zotero for Firefox after 5.0 — only a standalone Zotero 5.0 version and a Zotero Connector for Firefox — so add-on signing is no longer relevant.
  • I am using the beta version of Zotero 5.0 - in Ubuntu - and would like to use also the beta version of Zotfile but I cannot figure out how to install it. Could somebody kindly provide a brief indication of how to do this?
    With thanks.
  • I have now managed to install Zotfile 5.0 (it wasn't as difficult as I imagined) but I cannot access the Preferences. There is no gear icon in Zotero 5.0. In the Add-ons there is a Preferences button for Zotfile but clicking it does nothing.
    With thanks.
  • Open Zotero Standalone; then in the "Window" Menu >Add-ons Manager. You'll see Zotfile listed there; > choose preferences and you're in.
  • Thank you: but in Zotero 5.0 standalone on Ubuntu there is no Window menu item. There is, however, a Tools item, and this has an Add-ons item. Using this allows me to see the Preferences button, but, clicking on it has no effect.
  • Sorry to hear. Maybe try re-installing the add-on? Beyond that I'm at a loss here, working from a German Mac version. Any Linux users that can help?
  • Thank you again. Removed and reinstalled Zotfile Add-on but still no luck. I believe that I am preparing the xpi file correctly, having followed the instructions in the readme.md file:

    1. download `.zip` file from github
    2. extract `.zip` file
    3. recreate `.zip` file containing all the files at the top level, i.e.,
    install.rdf and the chrome directory need to be at the root of the .zip file
    and not under zotfile/
    4. rename the file to `.xpi`
    5. Install
    - For zotero firefox: drag & drop on firefox
    - For zotero standalone: In Zotero Standalone go to 'Tools->Add-ons->Tools for all Add-ons (the small, drop-down wheel menu next to the 'Search all Add-ons' box)->Install Add-on From File' and pick the .xpi file

    For Linux, Mac OS X or Cygwin users, there is a `Makefile` which takes care of creating the `.xpi` file.
    Simply run `make` instead of steps 3 and 4 above [NB this is what I did].
  • edited January 24, 2017
    Extracting annotations works as expected with Zotfile (5.0.0b2 + Zotero 5beta119). However, whenever a link in the extracted zotero note is clicked, and the option "Open link" is chosen a) no link is opened and b) all links in the note are being removed. I.e. "Open link" behaves as I would expect from "Remove links".
  • Regarding my comment above, following experimentation, I found that the Makefile does not put all of the required files into the zip/xpi file. I did this manually and Zotfile beta 2 does now work with Zotero 5.0 beta (currently 120).
  • @"yusuf martin" Can you elaborate? Which files are missing from the xpi when you use the Makefile?

    @kithairon I can confirm that. Pretty sure it's related to Zotero's update to TinyMCE 4
    Probably has to be fixed on the zotero side but maybe I am wrong. Not sure when I will be able to look into it.
  • Joscha: the 'chrome' folder is missing when I run Makefile (and I have just run it again to double check).
  • Installed Zotero-5.0-beta.134+0570c2e and ZotFile5 as described in https://github.com/jlegewie/zotfile/tree/5.0 . Everything seems to be smooth for the moment
  • would it be possible to post a .xpi file for Zotero 5? or at least an explanation of what is meant by "recreate .zip file" in the installation instructions, for basic folx like me who don't know what that means?

    also, just putting it out there that the loss of the Watch Folder function seems like a shame to me - it was really useful in the (frequent) scenarios where items have to be downloaded as pdfs without using the Zotero browser plugin. it also seemed to work really well in previous versions - is there no chance of this being restored? do others concur?

  • When Zotfile 5.0 is ready for release, there will be pre-built .xpi files available for download from zotfile.com and GitHub as there are now. At the moment, Zotfile 5.0 is in beta (like Zotero 5.0).

    The Watch folder had major negative impacts on performance, so it won't be restored, at least not in its current form. Do note, though, that there are several ways you can still very quickly add a pdf to an existing item. First, you can still download the pdf to what was formerly your "watch folder", then right-click on the item in Zotero and choose "Attach new file". Second, you can directly drag the favicon from the pdf being viewed in your browser to the the item in the Zotero--that will download it and attach it directly to the item.
  • Thanks - I understand it's still in beta. In the meantime, could someone explain how to "recreate .zip file"? I'm concerned I haven't done it right and that this might be causing the ongoing issues I'm having with renaming etc.
  • if ZotFile is working at all, the .zip file is not the problem.
  • just renewing my request for explanation of how to install zotfile 5. I understand that it's still in beta and so most people using it will be across the programming lingo, but I've installed Zotero 5 on both Mac and PC now, and managed to get Zotfile 5 working on the latter but don't understand how to use the Makefile function. when I run Makefile through terminal I get the following:

    dyn-49-127-107-172:~ benhjorth$ /Users/benhjorth/zotfile-5-1.0/Makefile ; exit;
    /Users/benhjorth/zotfile-5-1.0/Makefile: line 1: all:: command not found
    /Users/benhjorth/zotfile-5-1.0/Makefile: line 3: -include: command not found
    /Users/benhjorth/zotfile-5-1.0/Makefile: line 5: shell: command not found
    /Users/benhjorth/zotfile-5-1.0/Makefile: line 5: RELEASE:=: command not found
    /Users/benhjorth/zotfile-5-1.0/Makefile: line 7: zotfile.xpi:: command not found
    zip warning: name not matched: chrome.manifest
    zip warning: name not matched: defaults
    zip warning: name not matched: install.rdf

    zip error: Nothing to do! (chrome.zip)
    /Users/benhjorth/zotfile-5-1.0/Makefile: line 11: zotfile-%-fx.xpi:: command not found
    /Users/benhjorth/zotfile-5-1.0/Makefile: line 12: $@: ambiguous redirect
    /Users/benhjorth/zotfile-5-1.0/Makefile: line 14: Makefile.in:: command not found
    /Users/benhjorth/zotfile-5-1.0/Makefile: line 17: FORCE:: command not found
    Saving session...
    ...copying shared history...
    ...saving history...truncating history files...
  • edited April 12, 2017
    I guess I don't understand why? As I say above -- if you're able to install ZotFile and it runs, you're building the zip correctly. Why bother with the commandline tool that you're not comfortable with?

    But if you really want to:
    cd /Users/benhjorth/zotfile-5-1.0/
    should work and does for me on linux, though can't test on Mac. I want to be very clear, though, that this will do exactly the same as the manual zip/rename instructions.
  • sorry if I wasn't clear: I had successfully installed Zotfile 5 on the PC using the manual zip/rename, but couldn't replicate this on the Mac. but your instructions saved the day, so thanks.
  • however I can now confirm that I'm having the same renaming / refiling error on both the PC and Mac: with the "subfolder defined by %c" option ticked, the attachments are being saved to a new directory called 'undefined' under the Custom directory I've chosen (/Users/bensefth/Dropbox/zotero/library), and then the collection folders as they exist in the library. So that instead of .../zotero/library/masters/hegel they're being saved in .../zotero/library/undefined/masters/hegel, etc.

    surely I can't be the only person to be experiencing this...?
  • no-one else having this "undefined" folder problem with renaming / refiling? on the verge of giving up and reverting to zotero + zotfile 4 (and assuming I'm gonna lose anything added to library whilst trying to use 5...)
  • edited April 17, 2017
    (version 4 and 5 are sync compatible, so while you wouldn't be able to downgrade the local database, you can make sure everything is synced to the server and then sync back to Zotero 4.) This seems like an odd error, though, so I'd make sure you don't have anything off in the folder or subfolder location.
Sign In or Register to comment.