Endnote import:no translator could be found for the given file

I just installed zotero. Seems OK.
I am trying to import from Endnote 6. I set the export filter to Refman and then exported to a file. I tried to import and got the error message:
"no translator could be found for the given file"

The exported file from Endnote is at:
(Sorry for the hassles with Rapidshare. It's the best I could do on a short notice)
I also pasted the file at the end of this post.

Any help or suggestions welcomed.

The endnote exported file follows:

1 D. F. Guthaner, L. Wexler, D. R. Enzmann, S. J. Riederer, G. S. Keyes, W. F. Collins, and W. R. Brody, "Evaluation of peripheral vascular disease using digital subtraction angiography," Radiology 147, 393-398 (1983).
2 E. H. Meijering, W. J. Niesssen, and M. A. Viergever, "Retrospective motion correction in digital subtraction angiography: a review," IEEE Trans Med Imaging 18, 2-21 (1999).
3 E. H. W. Meijering, W. J. Niessen, J. Bakker, A. J. van der Molen, G. A. P. de Kort, R. T. H. Lo, W. P. T. M. Mali, and M. A. Viergever, "Reduction of Patient Motion Artifacts in Digital Subtraction Angiography: Evaluation of a Fast and Fully Automatic Technique," Radiology 219, 288-293 (2001).
4 J. Ricke, F. Fischbach, T. Freund, U. Teichgraber, E. L. Hanninen, R. Rottgen, U. Engert, H. Eichstadt, and R. Felix, "Clinical results of CsI-detector-based dual-exposure dual energy in chest radiography," Eur Radiol 13, 2577-2582 (2003).
5 H. Schmitt, M. Grass, S. Heiland, S. Hahnel, and K. Sartor, "Image Stacking with Entropy Values in Conventional Angiography: Initial Experience," Radiology 230, 294-298 (2004).
6 C. Walsh, D. Murphy, and N. O'Hare, "Development of a quality assurance protocol for peripheral subtraction imaging applications," Phys Med Biol 47, N91-97 (2002).
7 G. J. Whitman, L. T. Niklason, M. Pandit, L. C. Oliver, E. H. Atkins, O. Kinnard, A. H. Alexander, M. K. Weiss, K. Sunku, E. S. Schulze, and R. E. Greene, "Dual-energy digital subtraction chest radiography: technical considerations," Curr Probl Diagn Radiol 31, 48-62 (2002).
  • That isn't an RIS format. It is some kind of citation style. RIS looks like:
  • Thanks. After fighting with Endnote for a while, I got it to work.

  • I use EndNote X1 and wanted to move to Zotero.
    However I can't import my library into Zotero.
    When I try to import setting the type of file to EndNote in Zotero I got "no translator could be found for the given file".
    The possible export options in EndNote are: *.txt, *.rtf, *.htm, *.xml.
    I tried all types and always got: "no translator could be found for the given file".
    Any suggestion?
  • Can you look at the export file, just as Bob did?

    You must properly select the RIS export style & should double-check that the resulting file is actually a (plain txt) RIS file.
  • Unfortunately, I can't see any possibility to set up RIS style. I can only choose type of file during export. I got something similar to Bobs first post. I don't know how to set up RIS output :(
  • I don't have Endnote X1, but RIS is selected as a "output style," rather than a file format. Also see past threads for how tos (hopefully little has changed in X1):
  • OK, I exported my library from EndNote as RIS. I do an import into Zotero and whole Firefox freezes after showing popup window progress "Importing items..."
    I tried few times...
  • The RIS import process may take a long time and appear to freeze Firefox, especially if your library is large. Please try letting the import run its course when you don't need to be using Firefox (e.g. at the end of the day, overnight, etc.).
  • edited September 2, 2007
    I keep getting "no translator could be found for the given file". I am trying to import an RIS file. It is exported from Bookends in RIS format, plain text. The file is ".txt". There are only 19 items in the file, so size shouldn't be a problem.

    Here are sample items from the text file:
    TY - JOUR
    AU - Cartmill, Matt
    T1 - Human Uniqueness and Theoretical Content in Paleoanthropology
    PY - 1990
    JA - International Journal of Primatology
    SP - 173-192
    VL - 11
    ER -

    TY - JOUR
    AU - Binford, Lewis R.
    T1 - Willow Smoke and Dog's Tails: Hunter-Gatherer Settlement Systems and Archaeological Site Formation
    PY - 1980
    JA - American Antiquity
    SP - 4-20
    VL - 45
    ER -

    Note added later: I re-exported the same info from Bookends in BibTex format, which created a ".bib" file, and was able to import with no problem. What's with the RIS problem?
  • Indi: Would you mind sending the file to support@zot....org for us to take a look at?
  • Indi: Thanks for sending the file. It looks like Bookends is generating an invalid RIS file. The RIS spec calls for two spaces between the tag and the dash—your file has only one. Adding a space with Find/Replace All allows the file to be imported.
  • Hello

    I have just imported a 3000 record reference from Endnote into Zotero. You will find it interesting to learn that although the job was done, a large number (1124) were parsed incorrectly. I am happy to supply a copy of files if you would like to check this

    I've only started examining Zotero today. I find the concept impressive but also a few snags that complicate my life. I'll look at the fora list to try and flag these up in the right places. I've been wanting to dump word and others for so long and the final reason I dont do so is Endnote, which has my doctoral dissertation database.

  • I'm currently transitioning from Endnote to Zotero. One snag that I encountered when I exported my library from Endnote (v. 6) and then imported into Zotero was that all my author first names had been changed into initials only. It will take a lot of time to re-enter all those first names.

    Also, German Umlaute didn't convert at all.

    Nevertheless, I think that Zotero will save me a lot of time over the long-term, so I'm willing to put up with this.
  • Did you take a look at the file Endnote generated for you? My first guess is that that is where the names were changed, and quite possibly the Umlautes... Did you export the file in RIS? If so you might try exporting it as BibTex, that could potentially skirt the issue.
  • edited December 17, 2007
    Thanks for the hints for importing Endnote to Zotero. With BibTex Output Style and .txt output format it worked fine to transfere data from endnote6 to zotero including german "umlaute".
    Only the field "label" couldn't be imported - thats were i noted in endnote in which library I found the book. It would be great, if all fields that do not match a field in zotero could be put into the "extra" field or if there would be a list of fields to change corespondences.

    Now I face a second problem: I have already written about 120 pages of my dissertation in word 2000/endnote6 combination. Is there or will there be in the near future a way to transform a word document with endnote references/citations into a word (or even better openoffice - I only sticked to word for the endnote integration) document with zotero references? Otherwise it will be hard work to change all references/citations manually.
  • I kept getting the same error msg for my exported endnote file - the solution I found was to export 20 or so references at a time. Seemed like doing the whole file at once clogged the import for some reason.

    The standard RIS format is set to only do initials of authors' first names - you need to edit the style in Endnote before exporting so it exports the full name. Go to edit --> output styles --> refman --> bibliography --> author name --> Initials Full Name
Sign In or Register to comment.