Copy items with tags from personal library to a group library

Hey Everyone,

I just tried to copy some items incl. tags from my personal library to a group library, but now there are no tags in the copied files (group library).

Is there a way to copy items from the personal library to a group library with the tags beeing copied as well?

Thanks up front
  • At the bottom of the Preferences/General window is an option to include (or not) tags when copying items between group libraries. It should be checked.
  • Yes, I know, that was already activated.
    But still, it doesn't copy the tags.
  • edited August 31, 2016
    Ok, I just found out, how to do it:

    rightclick → duplicate item → then drag and drop the duplicated item to the other library

    Before I was just drag and dropping the items, but it didn't copy the tags that way.

    After doing it that way it won't copy the attached file...

    So the only way to do it ist to duplicate, drag and drop to the new library, drag and drop the original item as well and then merge the items?

    I have to do that around 100 times now;(
  • edited August 31, 2016
    No, that's not the way to do it. It's just that, if you've dragged items to the group previously, dragging again won't replace them with the version with tags, and if you delete the previously dragged group items but leave them in the trash, they'll be restored from the trash when you drag the originals over again. This will be improved in the future to merge changes across libraries when dragging updated items or with new settings, but for now what you want to do is delete the old items, empty the trash, and then drag them again from the original library.

    If you duplicate them, there won't be a link between the items, so any features in the future that merge updated data across the libraries won't work.
  • edited September 1, 2016
    I did it, like I described above.

    There are a few thousand items I have to work with and they were in a pre-existing group, which is not only used by myself. That is why I had to figure out a way to tag the items in a structured manner, while keeping the group working for others.

    Without having the right to edit at first, I tried to copy the items to my own library and edit them there, to upload the edited files later/overwrite the existing items or as I have just learned upload my edited items, but delete the original items at first (as well as emptying the bin).

    Now as I have the right to edit, I made a duplicate of the group library (within the group) to then sort the items into different folders from there, so I could keep a structure and would be able to see which files I already tagged.

    To bring the items that I edited in my own library - before I had the admin rights - to the group library, I then duplicated the tagged files in my own library, copied both files to an additional folder in the group library. After having one file with a working attachment and one with the edited tags in the group library I merged those two items and ended up with working items (attachment + tags).

    I also emptied the bin.

    Even when searching in the original library I can find the items with correct attachment + tags. Why is it not good the way I did it?;(
  • Similar problem. Copy tags option is clicked in Preferences > General. Tags that were automatic seem to transfer but custom tags that I manually added do not copy.
  • Apologies. The tags all copied. Just the custom colours did not transfer.
Sign In or Register to comment.