[Pref -> Search] Broken (Report 1175244455 D2138234924) [Solved BBT]

Standalone v4.0.29.5

The search pane is incorrect. On standard start the buttons are small and have no text. With debug turned on (and restart) the buttons are labeled, but Auto-index is listed twice.

Regular: http://www.humansoul.org/Zotero/Zotero_Search.png

Debug on: http://www.humansoul.org/Zotero/Zotero_Search_Debug.png

Report ID: 1175244455
Debug ID: D2138234924
  • edited August 9, 2016
    I don't know if this is useful but here goes:

    I am on a Mac and use dual monitors. I frequently have Zotero buttons without text. In the "are you sure" dialog box to empty the trash, the "yes" button _never_ has text but the cancel button always does. The yes button displays text upon being clicked. No text is displayed with a cursor hover over the button. I have this happen in other contexts but I don't recall enough to make useful comments. This happens with the 4.0x FF plug-in, the 4.0x stand alone, and when using 5.0 beta. I'm fairly sure that there was similar display behavior with the 3.x series. I don't use an Apple mouse or trackpad but a Logitic mouse. My wife's computer with an Apple mouse does not have this display problem. She doesn't use dual monitors.

    I have always ascribed this to my non-Apple pointing tool. Evidence for this -- often, especially with Mac Mail and Safari, the cursor doesn't switch from a hand to a pointer when clicking a button or activating a dropdown menu. The hand cursor activates the button as though it was a pointer. Sometimes the appropriate cursor type is displayed. Sometimes if I click in a non-active area the cursor type switches to the appropriate image.

    I have had this issue on all machines when not using an Apple mouse. This has been a problem for me for at least 6 years across different machines and several Mac OS versions.
  • Thanks for quick reply.

    Mid-2014 MBP13r i5
    MacBook Pro (Retina, 13-inch, Mid 2014)
    Processor 2.6 GHz Intel Core i5
    Memory 16GB
    Graphics Intel Iris 1536 MB (yes it is eating a TON OF RAM)

    Model Identifier MacBookPro11,1
    Model Number A1502
    This is OSX 10.10.5

    I have no peripherals attached, also the double auto-indexing, and the change with debug on make me think this is internal software or possible plugin.
  • edited August 9, 2016
    BenCarr: Disable Better BibTeX and check again. (That Auto-index section doesn't actually exist in Zotero proper.) If that fixes the problem, you'll need to report this to the developer of BBT on GitHub.

    (DWL's comments wouldn't be relevant here. This would happen due to a code error when opening the prefs.)
  • Emiliano, if you see this, I think it'd be better to either keep BBT's modifications within its own pane or badge them somehow — I'm not crazy about the potential confusion here about what's actually part of Zotero.

    Also, is BBT causing the pref window to be very wide like this? That's not the default width.
  • Dan,
    Thanks, I'll ping him, we've worked together before, he is iterating on BBT on github all the time, may have been my plugin was out of date, though I wish it didn't push if it broke things :-\ There was a pull/update in add-ons for BBT when I restarted and that did fix this problem, I'll let him know anyway about this thread, and about your comment.

    To github!
  • That's actually another extension (by my hand) called auto-index. I'll move those prefs away and publish a new release.
  • Auto-index .38 has removed the preference from that pane.
  • Thanks, Emiliano.
  • No problem, and apologies for the disruption. I do have a reasonably large (and growing) testset, and if a test fails I can't even put out a new release, but my tests don't cover everything alas.
Sign In or Register to comment.