Word Plug-In Simple Markup becomes All Markup when adding/editing citation

Using the word plugin there seems to be a bug where if I have my word set to show "simple markup," and then I add a citation or edit a citation, the word setting somehow automatically changes itself to show "all markup." This is quite annoying, so if anyone knows a fix, or has this issue, please let me know. I'd be happy to submit bug reports if that's possible for this kind of issue. Thanks all!
  • Same here!
  • I have the same issue but no clue how to fix it. Apparently the opposite was happening before (unwanted switch from "all markup" to "simple" or "no markup") and was fixed in a recent release.
  • And for me. Very annoying when editing.
  • I have the exakt same problem. Running latest version of Zotero and Word 2013.

    When adding or editing a citation, "show all markup" is turned on. Since I am currently working on a very large document (+200 pages), this slows Word down heavily every time.

    I have used Zotero for 5+ years, and can't remember this happening. It suddenly appeared today.

    I would be very thankful for any workaround or bugfix.
  • This behavior has been the same for quite a few years now.
  • Yes, I understand from reading a few threads here that it seems so. But for me, it started happening just now. The only unusual thing I can think of is that I turned on "track changes", it seems like it somehow triggered this phenomenon, although it still happens when I turned it off.
  • I'd guess that if you rarely use Track Changes, it's likely that it had changed to All Markup without you noticing (as there would be no difference if your document had no markup).
  • Thanks, you might be right. I tried to reproduce it in a new document without TC, and it alters Show Markup the same way, although as you said, you don't really notice if there is no markup.
  • Same problem here.
  • Turn off "Insertions and deletions" in Review -> Tracking -> Show Markup.
  • Thank you numiz! This fixes the problem.
  • What @numiz suggested fixed the problem but hid the changes made recorded by Track Changes
  • thanks @numiz

    @mscmilan that was the point, no? to hide the changes. The box says "SHOW MARKUP", so the changes should still be recorded, and still be saved in the file, but simply not shown, right?
  • I second the usefulness of having Zotero add/edit citations in a way that does not interfere with the "Display for review" (simple/full markup) setting. This is because if one works on a multi-author revision in SimpleMarkup mode, with the workaround suggested by @numiz it is impossible to both see one's revisions *and* stay in SimpleMarkup mode.
  • I agree with these comments. I am not sure why Zotero would switch the Word "Display for Review" from simple to full markup anyway. I would much prefer the "Display for Review" method to stay unchanged when I add a citation.
  • (My understanding is this is a technical problem with Word 2010 not having Simple Markup View, so it’s not possible to avoid setting it to something other than Full or No Markup while supporting older versions of Word.)
  • Thanks for the info! That would explain it. Support for older versions is good. I wonder if this problem could be fixed with an "if-then-else" section in the code, testing against the current version of Word? As time goes on, more and more people are going to be using more recent versions of the software. It might make sense to allow some functions to work correctly with newer versions of Word, while providing some legacy alternate functions for older versions.
  • edited October 1, 2019
    @adomasven I think you looked into the version check option at some point. Was that infeasible?
  • Thanks, @bwiernik - not an ideal workaround, but switching to "no markup" before adding a citation then going back to "simple markup" seems to be the best I can do for the moment. It at least stops my whole document jumping around when all the insertions and deletions are shown again.
Sign In or Register to comment.