Mac Word 2016 jumps to very high processor use when using the Zotero plugin

Report ID: 278651279

I have used the plugin for Word for many years without issue, but over the past month this problem has started. When I insert a citation (not all citations, but most), Word's CPU usage immediately jumps from about 5% to 65+%. Deleting the citation makes the processor use jump right back down. This is an obvious issue as it makes both Word and the computer work slowly!

I am on a Macbook Pro. OSX 10.11.1
Zotero standalone

Thanks for any help.
  • Mine is doing exactly the same! Have you found any solution?
  • Same here?
  • I can confirm this report as well. I am on a fully updated Macbook Pro. Mac Word 2016 (v15.18, also fully updated), current stand-alone Zotero (4.0.28). CPU usage from word at 70% or higher with a document with a Zotero references, goes back to normal levels as soon as I close the document. Word is pretty close to unusable - janky scrolling and very unresponsive keyboard.

    I am happy to send a activity monitor process sample or anything else that could be helpful.
  • I have found this can be fixed by turning off spell check and grammar check "while you write" - though this is not a great fix, it does help transiently.
  • Wow - that worked completely and immediately! Thanks timp0!

    On the downside, now I have to write this paper instead of complaining about Word...
  • I can confirm this bug as well (Word for Mac 15.18)

    For me, turning off only "Check grammar as you type" is sufficient to bring CPU usage back to normal.
  • I have the same issue, but I had not yet installed the Zotero plug ins and so it's difficulty to know if the issue lies with a Zotero formatted word document or is unrelated to Zotero entirely. I had >70% CPU usage on any word document that had been generated using Zotero. Ultimately I reverted to Office 2011.
  • I have the same issue with high CPU usage. Strangely it only seems to hit with >5 references or so. Issue happens on Mac Word 2016 and not 2011.

    In my case, turning off Word grammar check as you type does fix the problem - thanks to the above post!
  • Bumping this as still a problem, running Word for Mac v 15.23 on El Capitan. At over ~20 references in a 6 page document, inserting new references causes Word's CPU usage to skyrocket up to ~90%. In my case, turning off grammar check was only a temporary fix (ditto disabling spellcheck), and the issue returned as I began adding more references.

    As previous posters noted, this bug cripples basic functionality, so without a fix I'm going to need to be looking for an alternative product for managing references.
  • Hi lkwhite,

    I haven't worked with it in a little while, so might be misremembering... But I think doing a full-on spell check, then adding all the unknown words to the custom dictionary was an important fix for me. Even turning spell check off, there must be some fighting going on between Word's spelling and Zotero's reference checking.
  • Is this still a problem? I've been wanting to upgrade to Office 2016, but I'm afraid to get the high CPU utilization problems again.
  • Addendum: I can confirm on my wife's MacBook Pro running El Capitan and Word 2016 that a file generated in Word 2011 with a Zotero bibliography results in a resting 75%+ CPU usage drops to nearly zero with unchecking spell check as you type. Zotero is no installed on that machine. No other word documents cause the high CPU utilization. I do not have this problem with Word 2011.

    Is this a known issue with Zotero modified word documents and Word 2016?
  • Bump? Are things working for other people now? I still have CPU maxing out when using Word 2016 and opening a file made with Zotero. I'd like to upgrade to Office 2016, but this is preventing me from upgrading.
  • If this occurs on a computer without Zotero installed, this definitely is a Word issue. In that case it's definitely the case that it's simply documents using many and long Word fields that'd be causing this (which is why you don't see it in other doc). I don't think there's a way for Zotero to work without those.
    My guess would be that if you don't use "Store References in Document" that'd improve or "fix" this, but I wouldn't recommend that.
  • OK thanks for the reply. I just didn't know if Zotero could be writing something to the word documents that cause the Word app to do some recursive processes that utilize the CPU. Hopefully a future Word update can fix this then.
  • yeah, not an unreasonable thought, but there's nothing in the fields that should cause Word to do anything at all.
  • And one more: here's a microsoft support thread on this issue: also with people reporting that disabling spell/grammar check fixes this. There is a claim that this is fixed with Word 15.23 in that thread, but that doesn't appear to be the case, judging by reports here. But do make sure you have that version or later to be sure.
  • Just wanted to follow up that the problem (for me) seems to be resolved and indeed was related to Word. Recent updates of Word fixed the problem. Now my CPU use is < 5% for Word most of the time.
This discussion has been closed.