Ecological Society of America journals translator

there is something not working in translator for Ecological Society of America journals (, both for table of contents pages and abstract pages for individual articles.

Article titles appear entirely in capitals with hyphens between each word. For some of the journals (not all), the citation info (journal name, volume, pages) is run together with title in the title field


Kerry Woods
  • Kerry,

    Thanks for mentioning this. I'll take a look at it.
  • I have had similar issues in the past.

    But now, I'm getting "an error occurred ..." when trying to grab the following:

    Ben Bolker
  • Just to let anybody concerned with this issue know, ESA seems to have restructured their journal site since I last updated the translator. I'm working on fixing the translator to work with the new site design. I'll post here again when the new version is available.
  • The fixed version of the ESA translator is now available. Please let us know if problems continue.
  • Thanks for working on this ... but ... I still get an error on the URL above ...
    I poked around and looked at the fixed ticket (which is a little beyond me),
    but don't know what else I can do to help fix this ... Zotero 1.0.3, checked
    for latest updates, but don't know if the fix would have propagated to
    the version I'm using ? (How could I check?)

  • works now, thanks (???)
  • looks broken again?[1227%3ALHEISE]2.0.CO%3B2

    thanks guys ...


    gives a web-page icon, not an article icon . Can work around
    it by going to "download to citation manager" ...
  • Ecology Society journals still give the generic icon
    associated with "embedding RDF" rather than
    being scraped by Zotero ... e.g.

    can still work around it by downloading to citation manager,
    but this doesn't grab the PDF ...

    (would also be nice if table-of-contents pages such as gave a folder/multiple-items

    Ben Bolker
  • bump.
  • I'm still not being able to grab articles from the ESA journals site, e.g.

  • bp_216 - which Zotero version do you use?
    The site you link to uses the DOI translator - not a specific ESA translator -
    it only works with the 2.0b version of Zotero. If you do have that version installed, please follow the steps to troubleshoot translator issues and, if that doesn't help, post an error ID here.

    That said - this means the actual ESA translator isn't working.
  • I am not able to grab preprint-articles from ESA ( try for instance this one

    However, published ones work
  • wouldn't that most likely be because they haven't yet registered the DOIs with crossref?
    if you hover over the translator, it says DOI for you, too, right?
  • edited February 9, 2010
    The doi is registered see and it can be added with the DOI identifier

  • When I try to grab 10.1890/09-1829 by DOI or by clicking on the icon at, I get an item, but it has issues; the title is:
    <title xmlns="";
    Optimal defense - snails avoid reproductive parts of the lichen
    <i>Lobaria scrobiculata</i>
    due to allocation of secondary compounds

    Also, Pages is set to "100208092343020"; that seems a little high.
    The other data (authors, ISSN, date) seem correct.
Sign In or Register to comment.