zotero very slow in long document

13»
  • I'm wondering if some of the slowdown is Word itself -- Zotero really shouldn't affect Word at all when you're not performing some type of action in the Word add-on. A long document with hundreds of footnotes strains Word quite a bit, too.

    Beyond that, there's small things you can do like not have a bibliography inserted until the end and choice of citation style, but as we say apart, large documents just aren't very fast and the best advice we can give is to author them in shorter chunks as much as possible.
  • Greetings,
    I am experiencing a similar slowness with Word and Zotero. My document is only 117 pages with about 10 pages of references and it is taking a very long time to load zotero, find the citation, and insert it after I select that citation.

    Here is my debug ID: 1341058734

    Warmly,
    Beth
  • Hi there,

    Thanks also from me to all Zotero developers! So far I've profited a lot from Zotero.

    I'm also experiencing very slow citation refresh/add/editing peformance.

    Also I'm using word for mac (now 2015, version 15.16) but actually I experienced a very similar spike in lag also using windows word on the same file (200 page thesis).

    What's the advantage of programs like citavi? Do they have connections to the word:mac devision at microsoft or is it simply their larger development resources?
  • we don't know, it's closed source. I'd be surprised if Citavi had access to a proprietary/unknown API, though, so they're likely doing something else differently.
  • Have you contacted microsoft?

    Maybe they're interested in supporting an initiative like Zotero and gain our esteem.
  • Yes, we have. We've never gotten a response.
  • Kudos to the developers of this gem. Hands down, this is one of the most useful research tools I have come across in my academic life so far.

    I have found a very simple and 100% effective workaround for the refresh lag in Zotero. It might apply to most of your writing projects, if not all.

    I usually work on 300+ pages manuscripts with hundreds of bibliographic references and different citation styles. My first book had 326 pages with 180 bibliographic entries. I never, ever remembered having ANY kind of delay in refreshing the index, adding, removing, or updating any entry, anywhere, at any time during a few years of working with the manuscript.

    Fast forward to my third book, it is 277 pages long with 60+ bibliographic entries. If I add a new reference somewhere in the text, the update/refresh lag used to be enormous, to the point that I was about to abandon further work on the book until I could find a solution for the lag. And then I recalled my first book. Why didn’t I have ANY similar lag working on a longer book with 3 times more references than this one?

    The answer? It is the citation style that was different between the two books. In the first book, I used something like Vancouver (author-date), and in the 3rd book I am using The Open University (numeric, superscript). And this made the whole difference!

    Now everything makes perfect sense and the solution is clear and definitive. Any numeric citation needs to be updated if a new reference is inserted somewhere in the text. The reason is to update all the reference numbers throughout the entire text. If a new item is suddenly added between item 14 and item 15, then the new item needs to be marked as item 15 and all the latter items need to be renumbered and incremented by +1. This will take a huge amount of time of course. It is not a bug, it is not a problem with Zotero, nor is it a problem with MS Word or LibreOffice. This is how things are supposed to work. A much faster computer would go through it much faster, but there is no immediate silver bullet to circumvent the necessary work.

    Now, if you switch to a citation style such as Vancouver (author-date), or any other style that is NOT numbered throughout the text, then Zotero does not have to renumber all the citations if a new reference is inserted somewhere is the text. It simply adds the new item in the bibliography index and cites the reference in-line. Done! No lag of any kind.

    Therefore, what I did was to switch to an author-date (or any style that is not numeric), refresh the index (took 5 minutes) and viola!

    Now I have virtually zero lag when I insert new items in the text (or update the references in any other way). It happens instantaneously, all the time, anywhere in the text.

    The solution to your problem, if you really need a numeric citation style, would be to switch to a non-numeric citation style, finish the paper (proofread, add/remove/update all the necessary references, etc.), and at the last step, switch back to your numeric citation style of your choice. Then wait for the whole conversion to complete, which might take anywhere from 5 minutes to 30 minutes or more, depending on the length of the text and the number of entries. Once you are done, make sure that the layout of the text is still the way you like it to be (since the length of the text will change when you switch from a numeric citation style to a non-numeric style and back). And then send the final copy to the print.
  • FWIW, even with author-date styles long documents can be slow, and Adomas is working on improving that. But yes, choosing a style that requires less updating is going to give you significantly faster citations.
  • It seems the new beta version with the 'delay citations update' option solves the speed problem to a large extent. I warmly recommend it :-)
  • I'm reopening this thread because I've run into the same problem, using the latest MS Word on a Mac. Working with a long doc and. Very. Very. Extremely. Excruciatingly. Slow!

    After reading this through I cut and pasted the sections into separate docs, which felt like an annoying workaround but seems to be the only way forward. The reason I'm posting is that this doesn't help at all: it's the same length of delay, even now the document is circa 20 pages. Perhaps somehow the cut and past has preserved some kind of formatting that is linking back to the original?

    If anybody has tips on this I would greatly appreciate them.

    Fwiw I've also tried: turning citation to Harvard brackets to avoid renumbering (didn't seem to change anything, despite updating many times); setting footnote numbers to reset for every section, hence in theory limiting the number that need to be changed with every addition; cutting and pasting to new doc (as mentioned). I know it says above that this is likely a word problem, but it seems relevant that if I put in a regular footnote in Word itself then it's very quick, despite still renumbering the rest.

    And I would be happy to try the 'delay custom update' option as mentioned above but can't find the beta version and wonder if it's no standard given the time between that post and this. Is there a way to set this function, normally or by getting a different version (without loosing all cites :)

    Thank you for any help, this is really . . . annoying.

  • This future has long since exited Beta. Make sure you have the current version of Zotero installed by redownloading from https://Zotero.org/download

    Then, in your document in Word, click the Zotero tab, then Document Preferences. There is a box for Automatically Update Citations. Uncheck that and click okay.
  • Thank you, much appreciated.

    I ended up reinstalling Zotero, restarting computer, and doing this and it now seems to be working normally, for the shorter doc at least, haven't yet tried the long one but will try to avoid that!

    Thanks again, very helpful.
Sign In or Register to comment.