RTF/ODF Scan problem: only a limited number of items are detected


I have an RTF document with citations. The document comes from Srivener. I formatted citations according to the the RTF/ODF Scan menu:

(Colbran, 2014)
(Lam, 2014, 36-37)
(Ferrell, Hayward, and Young, 2008, 129-137)
(Corbin and Strauss, 2014; Clarke, 2005)

All these items are in my zotero library.

Yet, in the scanned file only a limited number of items is detected.

Items detected are formatted in the same style as the items I just listed. For example, RTF/ODF Scan detected the following items:

(Loader, 1997)
(Leishman and Mason, 2003, 75)

Also, somehow '(Clarke, 1992, 239; Leishman and Mason, 2003, 75; Reiner, 2010, 178)' became '(Clarke, 1992, 239(Leishman and Mason 2003, 75)Reiner, 2010, 178)'. RTF/ODF Scan did not recognise 'Clarke, 1992, 239' and 'Reiner, 2010, 178' as citations, but recognised 'Leishman and Mason, 2003'.

I also tried to scan after changing all brackets to { and }. I got the same results.

Did I do anything wrong? What should I do to allow RTF/ODF Scan to recognise all the items that I formatted correctly?
  • So yeah, first you want curly brackets, not round parentheses. I'm not seeing round parentheses anywhere in the RTF Scan instructions, neither in the docs nor in the program itsel.
    Since that doesn', according to you, work, try opening & saving the document in LibreOffice or Word if either is available. IIRC, Scrivener's RTF isn't the cleanest, so that might cause problems.

    (You're using pure RTF-scan, btw. This has nothing to do with the RTF/ODF scan add-on. One of the reason we developed that is that it's designed to be 100% reliable. It never misses a citation.)
  • 1. I uninstalled RTF/ODF scan add-on.
    2. I saved the Srivener project as a docx file.
    3. I opened this docx file with MS Word.
    4. I saved this docx file as a rtf file.
    5. I replaced all citations with () with {}.
    6. I opened this rtf file with the RTF Scan option.
    7. The result is that, again, I have the same 6 sources mapped as before. It is always these 6 items. They had been mapped even before, when all the citations had () and when I had the RTF/OPD Scan add-on.
  • there wasn't any need to uninstall the add-on, I just clarified that you weren't actually using it.

    Best advice I then have is to try to experiment a bit with the conditions under which RTF scan is recognizing citations. I'm afraid no one at Zotero prioritizes the existing RTF scan to a degree that they'd be willing to invest the time to troubleshoot the details for you. Personally I don't think RTF scan is reliable enough for serious writing, which is the reason the ODF scan version exists. That said, basic scan functionality like what you have above should work pretty reliably, so if you can isolate somewhat better under what conditions citations aren't recognized, there may be a solution (though my guess would still be that the problem is something related to additional stuff insterted in the RTF that breaks citation recognition which is based on character patterns).
  • I see. Thank you very much for finding time to answer.

    I'll experiment with the RTF file and will start with cleaning all the formatting of the text by copying it to the notebook and then pasting it to a new rtf file created in the word and in the open office.

    Thanks again!
  • edited November 13, 2015
    I compiled an rtf file in Srivener.
    I copied the text to the TextEdit.
    I copied it into the new rtf file.
    I sent it to the RTF Scan.
    I sent the first file to the RTF Scan.

    In both scanned files there were unmapped, with {}.

    Also in bibliography some lines had one empty space before the name of the author, for example:

    <one blank space here>Alexander, Jeffrey C., Ron Eyerman, Bernard Giesen, Neil J. Smelser, and Piotr Sztompka. 2004. Cultural Trauma and Collective Identity. University of California Press.
  • Would you mind uploading the test rtf file together with a Zotero RDF export of all involved citations to dropbox or somewhere similar? Mayber there's something easy/simple to fix or at least an obvious explanation.
Sign In or Register to comment.