Cannot access zotero

Dear all,

I cannot open my zotero version anymore. I tried the standalone and firefox plugin in windows. It says basically I cannot access database as it is already in use. But it's not. Problem started after zotero crashed this morning. What can I do? I already tried to restart windows.
(complete message I get when trying to start Zotero: "Ihre Zotero-Datenbank wird bereits benutzt. Sie können nur je eine Instanz von Zotero mit derselben Datenbank gleichzeitig geöffnet haben. Wenn Sie Zotero Standalone geöffnet haben, bitte schließen Sie die Anwendung und starten Sie Firefox neu.")
  • Oh and all the literature I added for the last few days/weeks disappeared from our shared group library. Any help? It's urgent! Thx
  • do you have the Zotero data folder on a custom location like a network drive or Dropbox?
  • network drive. But the network drive is accessible. What can I do?
  • keeping the database on a network drive is not supported and is bound to lead to problems just like this.
    Move the data folder somewhere else--on a local disk--then restart Zotero, which will open with an empty library, and redirect the data directory location.

    Restart and see if that works. If it doesn't you'll want to look at the last automated backup.
    Details on all steps here:
  • edited November 3, 2015
    @Adam: I have the same problem. I have used Zotero very happily for a year now, and suddenly I cannot access my Zotero database anymore, except via the Zotero webpage. Only difference: in my case Zotero did not crash before the access blocking.

    Your proposed solution is not very useful to me, because my home directory is on our departments server, and I do not even have access to my local harddrive. I think this will be the case for many other researchers.

    Every other program I use is indifferent to the physical location of the directories. What makes Zotero so sensitive to it?

    Is there not another solution like deleting some lock file?
  • Every other program I use is indifferent to the physical location of the directories. What makes Zotero so sensitive to it?
    the fact that your other software isn't run off a database.

    What error message exactly are you getting?
  • I get exactly the same error message as Skopperman.
  • I just updated to the latest English Firefox version, so now I get the same message in English:

    "Your Zotero database is currently in use. Only one instance of Zotero using the same database may be opened simultaneously at this time. If Zotero Standalone is open, please close it and restart Firefox."
  • yeah, something is accessing your database simultaneously or not closing your database down after accessing it and it's almost certainly related to the network drive. I don't think there's much more we can say about that, unfortunately, unless Dan has additional ideas on debugging and things to pass on to your sysadmins.
  • edited November 4, 2015
    By trial and error I worked out the following workaround:

    - Uninstall the Zotero plugin
    - Close Firefox
    - Move zotero folder from ~.mozilla/firefox/randomname/zotero to external harddisk
    - Reinstall Zotero plugin
    - Point Zotero to new zotero folder location and restart Firefox
    - Close Firefox
    - Move zotero folder back to original location in hidden mozilla folder.
    - Restart Firefox and point Zotero to revived original location
    - Close and restart Firefox again.

    The moving back and forth of the zotero folder may be superfluous. Maybe others can report if just reinstalling the Zotero plugin is sufficient.

    P.S. I prefer to keep my zotero folder in the network drive, rather than on an external drive, because the network drive is automatically backed up.
  • I just noticed that in ~zotero/pipes there is an empty file which has some random number as name. It disappears when Firefox is closed. Could it be that this works like a lock file and deleting it could avoid the messy workaround described above?
Sign In or Register to comment.