Visual Basic error when attempting to use Zotero with documents on OneDrive in Word 2016

Hi there,
i'm facing the problem that since updating to word 15.15 for mac the zotero plugin does not work any longer. Every time i want to insert a citation this message shows up:
"Zotero could not perform this action.Please ensure that a document is open. If you have performed a custom installation of Office, you may need to run the installer again, ensuring that "Visual Basic for Applications" is selected."

I run the update by default, re-installed the word processor, but the problem remains. Any suggestions.
Thanks for any advice.
  • could you also provide an error report ID from Zotero after triggering that error, please?
  • of course. i triggered the error once more and following report ID is: 750112442
  • edited October 17, 2015
    Error from the report:
    [JavaScript Error: "uncaught exception: ExceptionAlreadyDisplayed" {file: "chrome://zotero/content/xpcom/integration.js" line: 247}]
  • (Simon will need to take this and the other Word error; I'm out of my depth on these).
  • brief update. Uninstalled zotero connector for chrome. Tried to cite with firefox. Same message pops up again. Hopefully someone has an idea what to do about this. Worst case for me would be downgrading to office 2011.
  • Any idea about the problem. I need this connection working for my phd thesis so bad.
  • I was experiencing this problem as well, but I noticed that the file I was working on was saved in an Office365 cloud location. I saved the file locally, re-opened the local copy, and Zotero is working again. Re-saving and working with local copies might provide a solution for some users.
  • @ronald -- does that apply to you? As a cause that makes some sense: VB could well not work/be disabled for documents saved on the office cloud.
  • Thanks a lot. Tried this and it works! But why does zotero citing work with cloud stored documents on windows 7. Tested it today in my office. Any idea - i'm just curious.
  • edited October 22, 2015
    I have this problem and my document is saved in the cloud in OneDrive. However this document was always saved in the cloud in OneDrive, and I'm sure* it worked a few days ago. Perhaps an update to Word was applied that broke the integration? Or, perhaps it breaks when more people start editing the document?

    * 99% sure
  • no idea, sorry. Additional security built into Windows 10 possibly?
  • We had reports of Word not working with OneDrive a while ago, so this may not be entirely new, but it's not out of the question that MS would have changed this as a result of security concerns over VB in cloud documents.
    Zotero did also update the Word add-on recently, so there is a chance that is the cause, but I can't see anything in that update that would be able to trigger such a fundamental error.
  • @adamsmith I doubt it's a Windows 10 issue since we have Macs.

    It seems Office 2016 for Mac is undergoing regular improvements and bug fixes, so it's a bit of a moving target for the plugin.
  • yeah, I just misspoke there - ronald is also on Mac.
  • edited October 22, 2015
    I have also been having this problem recently. It is really frustrating. Is there any possibility of it being fixed on Zotero's end. Or does it need to be fixed by Microsoft?

    Maybe it is worth sending a message? It's a real shame because I use Zotero across my windows desktop and Macbook air and it's perfect. I hope this gets resolved soon.

    Unfortunately. When I try copying the document to local storage and using zotero I get a new error message:

    'Zotero has detected an incomplete or malfunctioning Microsoft Office installation. This is typically caused an incompatibility between Office and Apple's Migration Assistant. To resolve this issue, manually copy the Microsoft Office folder from your previous system, or reinstall Office from the original disc.'

    The number is 1546319347
  • and that's a Word install that's been working previously? And you get that error in a fresh local document, too?
  • Same problem here.
    I am currently writing a document and have to switch between my MacBook and a Windows PC. I started the document on OS X, Zotero was working fine, until I got the error.

    Copied everything to a new document - worked fine for two days.
    Then I continued to work on the document on Windows, everything was working fine until I switched back to OS X today. Can't test it right now but my guess is, it would still work on Word for Windows.

    Copying the document from OneDrive to local does help as a workaround, but isn't really feasible as a long term solution.
    Really hoping for a quick fix on this.
  • note that other sync solutions still work -- so you could e.g. keep the document in Dropbox. This is something very specific that Microsoft does in its cloud.
  • I have the same problem and error messages. I use Office 365 Personal on Mac.

    I found ou tha if I create a new document and first store in cloud but then store it locally Zotero works fine on the local version. But documents stored locally and created before Office 365 e.g. MS Office 2011 Zotero do not work at all.

    I hope this gets fixed so we can use Zotero in Cloud docs.
  • Now it wors on previous created documents stored locally. So it needed a kickstar to work. But only for local stored files
  • Hi,
    I have the same problem and error message every time I try to insert a citation from within the Zotero add-in in Word 2016 Mac.

    "Zotero could not perform this action. Please ensure that a document is open. If you have performed a custom installation of Office, you may need to run the installer again, ensuring that "Visual Basic for Applications" is selected."

    I use Word 2016 with my enterprise Office 365 account on an El Capitan Mac, which I just upgraded to. I had no problem with Zotero on Mavericks.

    My Report ID is 203712813.

    Appreciate any help to resolve this.
    Thanks so much to all the folks in Zotero for this wonderful product!
  • Sonce uprade to word 15.15 same probem on my mac - document opened from onedrive is having this problem, local copy is working fine.
  • edited October 31, 2015
    In Word 15.15, AppleScript is broken for documents loaded from OneDrive. Zotero uses AppleScript to communicate with Word, so it does not work. I posted on Microsoft's forum here. Hopefully they will fix this. I'm still thinking about possible workarounds.
  • I spent a couple hours trying to find a workaround here, but my efforts were unsuccessful. So for now, your only options are to use local files instead of OneDrive, or to roll back to Word 2016 15.14 or earlier (although these versions have bugs that result in random crashes on El Capitann). Sorry folks. I hope Microsoft will have a fix for us soon.
  • Hey, folks!!

    Recently I have actualized my office to office 2016. And the problem of Zotero and one drive, at least for One drive for business had been solved.
  • I have similar problem. with Report ID: 164458272

    It says
    Zotero experienced an error updating your document.

    [JavaScript Error: "couldn't open library C:\Users\IKEORA\AppData\Roaming\Mozilla\Firefox\Profiles\56fft5ey.default\extensions\\resource\libzoteroWinWordIntegration.dll: error 193" {file: "file:///C:/Users/IKEORA/AppData/Roaming/Mozilla/Firefox/Profiles/56fft5ey.default/extensions/" line: 48}]'[JavaScript Error: "couldn't open library C:\Users\IKEORA\AppData\Roaming\Mozilla\Firefox\Profiles\56fft5ey.default\extensions\\resource\libzoteroWinWordIntegration.dll: error 193" {file: "file:///C:/Users/IKEORA/AppData/Roaming/Mozilla/Firefox/Profiles/56fft5ey.default/extensions/" line: 48}]' when calling method: [zoteroIntegrationApplication::getDocument]

    i need help ASAP.. I have a project work to finish up
  • Almost certainly because you're using the 64-bit version of Firefox. That doesn't currently work with Zotero Word integration.
  • ok all i need to do i download a 32 bit version?
    though my PC is 64 bit. I hope this doesnt come with some compatibilty problems. Awaits your reply.
  • edited July 2, 2016
    The 32-bit version is the standard version that runs on any platform, so no concerns there. If you want to keep the 64-bit version, you can also install Zotero Standalone and use the Word integration through that. It'll share the same data directory as the Firefox add-on.
  • wooh. Thanks a lot. You are a lifesaver.
Sign In or Register to comment.