Serious Problems in Word - Zotero is Deeply Flawed, Unreliable

As a student at George Mason University, I'm deeply disappointed that this software is being relied upon by professors at GMU. It's completely unstable on the mac OS, the forums are flooded with unresolved issues. Every response seems to be "update to the latest version of Zotero", which obviously does little to resolve anything.

I installed Zotero on my sister's macbook pro which was at the time, running Yosemite. However, she updated to the latest El Capitan, and Zotero is pretty much useless. She's also using Word 2016. I installed Zotero, both the desktop stand alone version, as well as all the plugins (Firefox, Safari, Chrome...) but when I go to Word 2016 to insert a citation using the "add-on" menu, Zotero crashes! Every. Single. Time.

So, here are the steps that I will be asked to go through, surely by some Zotero developer:

1. Yes, she's running the latest version of Zotero.
2. Yes, I uninstalled/reinstalled.
3. Yes, I even reset the zotero data so all her citations are gone.
4. Yes, she is logged in and supposedly (synced).

Here's why I say "supposedly". When I input her login info, zotero ALWAYS says "login failed" no matter what, that ridiculous yellow triangle with exclamation point never goes away. -- And the username and password are correct.

Here's my question to the devs, is Zotero is compatible with El Capitan? And why is the login/sync so terribly awkward? It never seems to actually work.

As clever as this application could be, no wonder hardly anyone outside of graduate level academia has heard of it-- because it's too unstable to rave about.
  • Zotero works fine — on El Capitan, which many of the Zotero developers use, and everywhere else — for the vast majority of people. If you think this is an effective way of getting help, you're mistaken.

    Once you've read that and perhaps rethought your approach here, some notes and questions:
    when I go to Word 2016 to insert a citation using the "add-on" menu, Zotero crashes!
    What do you mean by "crashes"?
    1. Yes, she's running the latest version of Zotero.
    We need a Report ID for any problems, and we need exact versions of other relevant software (e.g., Word). Saying you have the "latest version" isn't helpful.
    3. Yes, I even reset the zotero data so all her citations are gone.
    No one recommends this, and in fact it's strongly discouraged, including in the pane itself.
    When I input her login info, zotero ALWAYS says "login failed" no matter what, that ridiculous yellow triangle with exclamation point never goes away.
    "Login failed" isn't a string that appears in the Zotero client, and a yellow triangle with an exclamation mark isn't used for password errors. See Reporting Problems — we need Report IDs and exact messages. For login issues, a Debug ID for a sync attempt may be helpful.
  • edited October 26, 2015
    edit: deleted to prevent confusion. Basically what Dan says.
  • I don't need to read your post guidelines. I get it. By crashed, I mean exactly that. The error literally says, "Zotero crashed/quit." Of everything I noted, that is the most straight forward.

    By the latest version of Zotero, I mean as if: she completely uninstalled the software and re-installed it from the website. Again, simply stated, the latest download. In order to get the Report ID I will have to re-create the problem which I can't do at the moment because my sister is currently in the process of writing her paper.

    My sister doesn't really care that her citations are gone, because she wasn't able to insert them in the paper anyway. So that's the least of her problems.

    I'm sure you know what I mean when it says "login failed" that may not be the exact message, but there a several other posters who mentioned issues with login. So, it's not as if this problem doesn't exist. But, if you want it put simply: She can't login with her correct login info.

    I wish these message boards allowed attachments, it would be much easier to show through screenshots what I am seeing on my end.

    But here is what the exact words say: "The Zotero Sync server did not accept your username and password. Please check that you have entered your login information correctly in the zotero sync preferences."

    This message appears when I click on the red circle with an exclamation point in the right-hand corner of Zotero.

    While I would love to go through all the many, many troubleshooting steps to debug, I really don't have the time. I'm a graduate student, I have three major projects coming up, I work, I'm a teaching assistant, and I live 45 minutes from campus so I commute and I don't have time to deconstruct the issues of zotero.

    I'm not a computer guru, but I'm not a novice either. I sat in zotero "class" and other students had similar issues, so the software is far from user friendly. I'd love to see a version that runs much soother on Macs. I don't mean to come off as harsh, but just because the developers don't see the problem on their end, doesn't mean the problem doesn't exist on the user end.

    I will try to get a Report ID for you.
  • you can put screenshots on any free image hosting site (imgur, dropbox) and put the link here.
  • @Adamsmith Thank you, that's actually really helpful info to know, I will do that.
  • I don't need to read your post guidelines.
    Well, then I don't feel the need to read your obnoxious posts.

    Also, if we're asking you questions, you can either A) assume that we're deliberately wasting your time or B) assume that we know what we're doing and are trying avoid common sources of imprecision (e.g., different uses of "crash", ambiguous error messages) so that we can help you quickly.

    Anyway, I'm done here. If your sister would like to post and follow the very basic reporting guidelines, we'd be happy to help her.
  • Helping me quickly, is what Adamsmith seemed to do. He gave me a way to easily show you what I mean. Sending me to read pages of troubleshooting is assuming that I have hours and hours of time to spend on the issue. I'm not trying to be obnoxious, but I am trying to be efficient here. I'm shocked by your lack of customer service finesse... which reminds me I'm definitely getting help from either a student or a student/teacher tech. But okay, later, I will try to post screen caps of what I'm seeing, but I won't be able to recreate the problem until tomorrow, unless my sister goes to her school to get help, which she might-- and in that case, they may be able to resolve the error.

    By the way, I've already read the post guidelines, I read it weeks ago in the zotero class. So, that's why I didn't need to read them, again.
  • We help many people a day in these forums, and almost everyone's issue is resolved quickly and pleasantly. Most people provide the basic information we ask for very quickly, and most people are also smart enough not to be belligerent and uncooperative with the people volunteering their time to help them. Since neither of those are apparently the case here, you're on your own (unless you get lucky and someone else decides to put up with your unpleasantness, but I'm not sure why they would).

    The "pages of troubleshooting" are a request for two pieces of information that take a few seconds to provide (which is why almost everyone provides them in their initial posts): a Report ID (or Debug ID in the case of the syncing issue) and an exact error message. So far, we don't know what versions of anything your sister is running, and we don't know the actual messages she's receiving. (No, it did not "literally" say "Zotero crashed/quit", and we can't do anything with that.)
  • #findhopefilms. Please calm down before posting again. When you aren't making wild and hostile generalizations and can clearly describe the problems you are experiencing; it is unlikely that your problems will remain unresolved for very long.

    That said, you must follow the instructions for reporting problems (Dan's link above). I have used Zotero in El Capitan and the previous several versions of the Mac OS with no or very minor problems. When I have had problems I have had help here in the form of clear instructions about tracking down what might be wrong and what to do to resolve the issue.

    Although I remember the pressure of being a graduate student, that stress does not give license to be rude and obnoxious. Clearly, if you really read the guidelines for posting to the forums, you are ignoring those rules. By intentionally violating the guidelines concerning civility, you make it difficult for any of the volunteers here to help you.

    I have worked with literally hundreds of graduate and undergraduate students over the past few years to show them the basics of how to avoid plagiarism, cite sources, find sources, and keep order to their collections of documents. Many have used other bib management systems including the commercial industry leader. I regularly hear how much better they like Zotero over their previous software. More than half of the students use Macs.

    If Zotero is not working for you there is something about your computer that is different and that must be identified before your problems can be identified.
  • Wow, you guys are wonderful customer service representatives. Implying that your clients, stupid, or "not smart enough". And belligerent... well I guess if such highly intelligible and understanding men say it, then it must be so. But let me calm down before I terrify you any further.

    Here's the information you requested.

    Report ID – 244466000

    [JavaScript Error: "Invalid username or password" {file: "chrome://zotero/content/xpcom/sync.js" line: 2595}]

    [JavaScript Error: "Invalid username or password" {file: "chrome://zotero/content/xpcom/error.js" line: 38}]

    [JavaScript Error: "1445822284393 Toolkit.Telemetry ERROR TelemetryStorage::loadAbortedSessionPing - error removing ping: PingReadError JS Stack trace: PingReadError@TelemetryStorage.jsm:80:15 < TelemetryStorageImpl.loadPingFile<@TelemetryStorage.jsm:1440:13" {file: "resource://gre/modules/Log.jsm" line: 749}]

    1445828832308 addons.update-checker WARN Update manifest for did not contain an updates property

    1445828832340 addons.update-checker WARN Update manifest for did not contain an updates property

    [JavaScript Error: "1445832243572 Toolkit.Telemetry ERROR TelemetryReportingPolicy::get dataSubmissionPolicyNotifiedDate - Invalid date stored." {file: "resource://gre/modules/Log.jsm" line: 749}]

    [JavaScript Error: "1445832243572 Toolkit.Telemetry ERROR TelemetryReportingPolicy::get dataSubmissionPolicyNotifiedDate - Invalid date stored." {file: "resource://gre/modules/Log.jsm" line: 749}]

    [JavaScript Error: "TypeError: is undefined" {file: "" line: 83}]

    [JavaScript Error: "Error: Script error" {file: "" line: 8}]

    version =>, platform => MacIntel, oscpu => Intel Mac OS X 10.10, locale => en-US, appName => Zotero, appVersion =>, extensions => Zotero Word for Mac Integration (3.5.12.SA., extension), Zotero LibreOffice Integration (3.5.10.SA., extension), Silverlight Plug-In (5.1.40416.0, plugin), Default Browser Helper (600, plugin), QuickTime Plug-in 7.7.3 (7.7.3, plugin), SharePoint Browser Plug-in (14.5.7, plugin), Shockwave Flash (, plugin)
  • However, she updated to the latest El Capitan
    Is this report from your sister's computer? The debug output you posted says "Intel Mac OS X 10.10", which is one version older (Yosemite).
  • @findhopefilms
    I am just another thankful Zotero user. And I was a graduate student until recently. Your title and the entire first paragraph comes across as harsh and sweeping generalizations of how disastrous Zotero is. Most of us disagree and some of us like Zotero so much, we contribute actual $ (by buying space) even though there isn't a requirement to do that.

    The people commenting above know what they are doing. You will benefit by internalizing that they mean well and are the shortest route to the solution of your issue.
  • In case anyone is concerned, the account in question is now syncing, after a password reset. That doesn't necessarily rule out some sort of bug, but it's not something we could debug without cooperation.

    (Also, despite findhopefilm's claims, all recent access from the account appears to have been from Yosemite (10.10), not El Capitan (10.11) — which of course is why we ask for Report IDs.)

    We can't do anything about the Word/crashing issue without more info, starting with the exact error message and Word version.
  • I just want to back up Dan and the Zotero developers here. I've used the program for years. It has worked wonderfully, and when I have had any problems their responses have been fast, courteous, and effective. This kind of rant is depressing and destructive.
Sign In or Register to comment.