All my in-text citations disappear & Zotero trashes my desktop

Zotero is a terrific piece of software, but I'm experiencing some rather disturbing glitches. This is a 'bug report.' Hope I put it in the right place and that I have not duplicated a previous bug report (couldn't find anything on this).

When I use ReferenceMarks for inserting in-text citations, save the file in either .rtf or .doc (XP version) format, close the document, and reopen the document, then all my in-text citations disappear. While the citation text does not disappear, it is no longer possible to generate a bibliography and inserting the cursor in the citation and hitting "Edit Citation" results in an error message saying the cursor is not in a citation. When I originally put the citations in, the entire citation is gray. When I close and reopen the document, the citation is no longer gray, but there is a small gray area to the right of the citation. Inserting the cursor in that area does not allow me to 'edit citation.'

I have tried: reinstalling Zotero in my browser, reinstalling the Zotero extension in OpenOffice, restarting my computer, using different citation styles. I always get the above problem. The problem does not occur when a) I use ReferenceMarks in a .odt document or b) when I use Bookmarks with .doc (XP) format (haven't tried others).

I am using Open Office 2.4.1, Firefox 3.05, and Zotero 1.0.9. I can't find the version for the extension, but I just downloaded and installed the most recent version online and ran the above tests. I am using Ubuntu Linux 8.10, with kernel 2.6.27-9-generic.

As I was running these tests, I also discovered a reliable way to get Zotero to freeze my desktop (windows wouldn't close and moving them created a multitude of duplicate copies, windows cannot be force-quit). The recipe is: insert a citation in an Open Office document, save and close it, open a new document, try to insert a citation, the program tries to open a window about the citation, everything freezes. The operating system itself is not frozen because I can shut the system down from the command line (Ctrl-Option F4 to get to a terminal window that works).
  • Seems that one work-around for me, given that I have to submit my paper in .doc format, would be to use Bookmarks rather than ReferenceMarks. But the window for selecting Bookmarks has this to say: "Bookmarks are preserved across Microsoft Word and, but may be accidentally modified." Does anyone know what 'accidentally modified' means? Do Bookmarks spontaneously morph or is there something I could do to not accidentally modify them? Does the problem happen often?
  • Hi - the first part is actually not a bug. ..doc files can't handle Reference Marks (and I thought the dialogue made that clear, doesn't it?) So once you save as .doc they are saved as part of the text, not a citation.
    Bookmarks are currently broken for footnotes in Ooo, so Zt. doesn't offer this option to you for some citation styles (those involving footnotes), but you are right that under normal circumstances that would be your way to go.
    For in text citations, my understanding of "accidentally modified" for bookmarks is that _you_ can screw them up more easily, i.e. if you type something within the citation, not that the bookmarks just get modified without any outside influence.
  • Hi Adam: Thanks for the reply! I don't see any warnings about .doc files not being able to handle reference marks. All one's citations disappearing for a paper on which one has been working for hours is a bit of a shocker. There really should be some prominent warnings about not using ReferenceMarks w/ .doc or .rtf files. At least something in the first dialogue, but better still would be some code that detects what type of format the file is in or the user is about to christen a file and warns that this will make the ReferenceMarks disappear. Also helpful would be something explaining that 'accidentally modified' means the user typing something in the reference marks causing problems, not spontaneous errors.

    Sounds like Bookmarks will be a solution for me.

    Many thanks!

  • Another glitch the Zotero team should consider: When I copy and paste text from one document to another, the bookmarked citations I inserted become inactive. I can no longer 'edit citation' (I get an error that brings up an OO Basic command window) and I can no longer create a bibliography with these citations. This limits the use of Zotero as a reference program for academic work, which often does require transferring pieces of earlier writings to later writings.

    Bookmarks seem to transfer alright when I create them myself directly in OO--that is, when they are not part of implementing citations in Zotero.
  • edited January 17, 2009
    I am happy to say that this works fine in Zotero Sync 1.5, with the matching plugin. The only slight hitch is that I had to create a separate citation in the blank document into which I pasted the Zotero references, to "wake the document up" for Zotero. Other than that it works without a hitch, I was able to open the pasted reference for editing and continue working. So this one's been solved.

    The plugin for 1.0 is pretty badly broken in several ways; if it's an option for you, I would recommend (making a copy of your database and) moving to 1.5 (and backing up regularly just in case).
  • Thanks fbennett! It's reassuring to know that these problems are being fixed, given that I'm now committed to Linux, my work requires a good bibliography program, and Zotero is the only good bibliography program for Linux (unless I have the time to learn TeX...).

    1.5 sounds a lot better, but given that it's beta and not available for automatic download, I'd guess there are some issues there as well. May be best for me to wait, or?

  • If you can, wait, it looks like that would be a safer choice. Better is coming, it's just a matter of when.
  • Good advice!

    Incidentally, I wonder whether anyone else is having issues with speed? I've got about 1500 references many with copious notes. The search function or even opening and closing the Zotero window in Firefox is sluggish, despite being on a rather fast computer (dual core, 2.2GhZ AMD Athlon 64 w/ 64 bit OS). It's not a huge problem, but it is time-consuming and will likely become more so as I add new references. Part of the problem, I imagine is that search automatically and immediately starts looking for any matching letters in any field (several fields?) as I type. That's handy with smaller numbers of references, but not with the kind of volume academics come up with.
  • If you begin your search with quotation mark ("), the search will not begin until you press enter. You do not need to end it with a ".
  • Ah, quotation marks--great tip! Thanks arggem.

    I wonder if the general idea here is that the software framework on which this is built will get faster over the next few years. Hopefully.

Sign In or Register to comment.