[Juris-M] Cannot "relate" items

Clicking the "Add" button beneath the "Related" tab at item level opens a pane from which to select a related item, but clicking "OK" after highlighting a selection appears to do nothing. No related items appear under the "related" tab. (Relating notes appears to work fine.) Thx, M
  • It's working here with Juris-M v4.0.28.2m42, which is the latest release. Is that your version?
  • I am on the same version (Juris-M v4.0.28.2m42); sorry forgot to post that info. I was within a saved search results pane yesterday when attempting the action described. I just now tested it in a non-search pane, with success. Are we supposed to be able to link at the item level between hits in a search results pane? Thx!
  • I just tried in a saved search, setting relations within the same saved search and into a different one. With a heavy search there is a bit of a lag (a second or so), but it comes through. Are you able to reproduce the fault?
  • Yeah. Still acting goofy. Some items I tried to link appeared after a while (after closing all programs and being away from the computer for several hours). But not all attempted links appeared. Also, even in the main pane (no search) at the highest level showing the entire library, I noticed that the "related" tab would sometimes grey out and other times remain black as I scrolled down through the item list. Either grey or black tab might show "0 related." Seems inconsistent behavior. Just now I selected the related tab beside the first item in my search list. I linked it to the second item in the same list. Nothing appears in the related tab for the first item. But it states : "1 related" followed by nothing. If, however, I select the second item, under its related tab the first appears! I waited a minute or two to see if it would generate in both items, but it did not. The target reflects the source, but the source does not display the target. Thx, M -->>P.S. Firefox 40.0.3 on Ubuntu 12.04LTS
  • That certainly doesn't sound right. Just in case, try checking database integrity:

    (1) Open Preferences -> Advanced
    (2) select "Files and Folders"
    (3) click "Check Database Integrity"

    If the database checks out okay, could you send a report of the failure by mail?

    (1) Open Preferences -> Advanced
    (2) select "General"
    (3) click "Enable"
    (4) Produce a simple failure
    (5) Preferences -> Advanced
    (6) click "View Output"
    (7) Select all in the popup, save to file.
  • edited August 31, 2015
    Okay. "No errors in database." Sending file. Thx again! m
    P.S. I just pasted the output into the Zotero email pane for fbennett; hope that's the way.
  • Nothing has arrived via the Zotero.org "Inbox." I sent a copy of my email address, but maybe messages aren't getting through at the moment.

    You can send it to my personal account, biercenator@gmail.com (as an attachment is best)
  • Many thanks, received. Try this, it addresses an error shown in the log, and may work better:

  • Just to close the thread, Frank resolved my problem in short order. Thanks Frank! M
Sign In or Register to comment.