bibliography alignment

Since the last update 4.0.27.*, I found the bibliography is become very bad.
Before, in the 4.0.26.*, between each item in the bibliography is separated by ¶ {enter}. Since the last update, it changed, separated by ↵ {shift+enter}. We can see it clearly if you try to show all symbol in the word.
Furthermore, we cannot roll back the zotero to 4.0.26.*, since it said it is not compatible with current firefox 39. With the current situation, it is impossible to make justify alignment in the bibliography.

I hope this bug can be fixed as soon as possible.
  • This is not a change that would be associated with 4.0.27. What version of Word and what style are you using?
  • edited July 16, 2015
    I think, it is. Because I tried to install firefox portable 38, with zotero 4.0.26, and I can fix this problem "temporary".

    I have word 2010 and I tried with almost all style that normally I use (Wiley, Elsevier, ACS, Physical review), giving always same problem.
  • I would guess this is related to the citeproc-js update. I can dig around, but perhaps fbennett knows the cause?
  • OS: El Capitan Public Beta 1
    Office Version: Office 2016

    In the picture i use the citation style: "Elsevier Vancouver (Engineering Structures)". Normally there is no shift+enter after each reference. In previous version of Zotero the shift+enter also did not appear. Please help us find this out. Your warm-hearted help is sincerely appreciated.

    This is another example in which i use the citation style "American Society of Civil Engineers". As you can see, in this style, the shift+enter does not appear. So i think it is a style-specific issue.

    As far as i can explore, this issue only occurs in "numeric" styles, while the "author-date" styles don't have this issue.

    Thank you @Simon and @Adamsmith

    It's been a week waiting this issue to be solved.
  • edited July 20, 2015
    Sorry that I hadn't noticed this. I've been a little distracted with work to restore word processor functionality for users of my own project, following the introduction of ID checks in the recent Zotero WP plugin releases.

    I'll try to take a look at this issue tonight.
  • edited July 20, 2015
    Okay, so it looks like the long-standing cross-nesting bug fixed in response to Vladimir Sobolev's report (linked by Rintze above) was masking another error. The style behind the current report uses second-field-align="flush", and this resolves internally to a bunch of things, including display="right-inline", which wraps the final block of text in the cite. For some reason, the wrapper was being lost, so the explicit trailing RTF \\line declaration that is causing problems now went unnoticed for years. Removing it seems to fix the current issue.

    I'll make a release after I get home and am able to run the current processor tests. It would probably be a good idea to do some more testing, if there is concern.

    Anyway, more later.
  • just wanted to note that I observed the same behaviour with "Angewandte International Edition", which in turn uses second-field-align="flush" as well.
  • Yes, the same issue will affect most styles that use second-field-align.
  • @hintze, @bbbear2002: Try installing the Processor Patch plugin. (If it doesn't work, uninstall it.)
  • Thank you @fbennett for bringing us this patch. BTW, is there Processor Patch for the Zotero Standalone Version, please? Firefox is not installed in my computer and i only have standalone.
  • You can download the XPI file and then install it in Zotero Standalone manually.

    Go to Tools -> Add-ons. Click the gear button (top right) -> Install Add-on from File, then select the XPI file and follow the prompts.
  • Thank you @fbennett and @aurimas, this patch works, so far no error. That is very great!
  • Hi all, I was dealing with the same issue here. Many thanks @fbennett, @aurimas for the fix and @widianta.gomulya for bringing the issue here.
    Hope it will be included within the next update.
  • I am still seeing this problem with IEEE style and Word 2013. Zotero is at I do not see any "Processor Patch" plugin on the link provided by fbennett. Any thoughts?
  • The name of the plugin is "Propachi Vanilla," under the link above.
  • Perfect, and it works, thanks!
Sign In or Register to comment.