Drag'n'drop not working [1.0.9/Linux]

Using Zotero 1.0.9 with Iceweasel 3.0.4-1 (=renamed firefox browser in Debian GNU/Linux) in Debian "lenny" I noticed that after upgrading from 1.0.7 to 1.0.9 dragging an entry to a collection does not work anymore. I click the entry, hold the left mouse button but no draggin'.

To make sure this behaviour is not caused by any of my installed extensions and did work with 1.0.7 (do not use drag'n'drop very often) I created a fresh firefox profile, installed 1.0.7 -- and yes, with 1.0.7 drag'n'drop works fine. Upgraded to 1.0.9 and it's gone. To make sure it's not a problem of the upgrading process I created another fresh firefox profile, installed 1.0.9 directly and it does not work, too.
  • edited December 29, 2008
    I had the same problem, and for me it was linked to my Firefox version - i.e. it works for me in FF3.0.5 but not in 3.0.
  • Same setup and problem here.

    mark: you're using a different version than we are.
  • Dragging to collections works for me in 3.0.4 on Ubuntu, though file dragging in and out of Firefox is still broken on Linux.

    1) What's your Quick Copy setting in the Export pane of the Zotero prefs? Does changing it have an effect?

    2) What are the last few lines of the debug output when you attempt a drag?
  • 1) I tried Chicago, Nature, and RIS with no effect.

    2) It's the "get item" output from acknowledging a click

    zotero(5): SELECT IA.itemID FROM itemAttachments IA NATURAL JOIN items I LEFT JOIN itemData ID ON (IA.itemID=ID.itemID AND fieldID=1) NATURAL JOIN ItemDataValues WHERE sourceItemID=? AND linkMode=? AND value=? ORDER BY dateAdded DESC LIMIT 1

    zotero(5): Binding parameter 1 of type int: 980

    zotero(5): Binding parameter 2 of type int: 1

    zotero(5): Binding parameter 3 of type string: "http://www.pubmedcentral.nih.gov/articlerender.fcgi?artid=1226105"

    zotero(5): SELECT linkMode, path FROM itemAttachments WHERE itemID=6116

    zotero(5): SELECT creatorTypeID AS id, creatorType AS name FROM itemTypeCreatorTypes NATURAL JOIN creatorTypes WHERE itemTypeID=? ORDER BY primaryField=1 DESC, name

    zotero(5): Binding parameter 1 of type int: 4
  • To clarify, it's not that I drag it and it just doesn't "go there"; it's that there is no recognition of a held click, ie no moving item graphic.
  • I have the same problem ( I think) I started using Zotero now and I am trying to have my pdf files in my collection. I try to drag them but they "don`t go". I am using firefox 3.0.5 and the latest version of ubuntu. Is it the same problem? If not, do you have a solution to mine? :P
  • Actually, this is just a different manifestation of the same problem Mark experienced. Firefox 3.0 returns "1.9" as the platform version, while later 3.0.x releases return "1.9.0."-something. Iceweasel 3.0.4 returns "1.9" for some reason, even though the official 3.0.4 release returns "" (and Iceweasel includes the full version in the user-agent string).

    Zotero was checking for "1.9.0" or "1.9.1" to choose between old and new drag-and-drop APIs, but since it didn't identify 3.0.0 and Iceweasel as 1.9.0, it was trying to use the new API.

    This is now fixed in the latest 1.0 dev build. You could also apply the fix yourself by modifying zotero.js.
  • bigrev (and others not using Iceweasel): To see if you're experiencing the same problem, you'd want to check Report Errors after attempting a drag to see if you have this error:
    "[JavaScript Error: "event.dataTransfer is undefined" {file: "chrome://zotero/content/xpcom/itemTreeView.js" line: 1596}]"
    3.0.5 on Ubuntu returns "" for me, so I wouldn't expect Ubuntu users to see the same problem.
  • I can confirm that drag&drop as described works fine under ubuntu
  • Thanks Dan, I confirm that your fix works.
  • Happy new year and tanks for the quick fix. Modifying zotero.js as mentioned by Dan fixes the issue for me.
  • Im having a similar problem with drag and drop pdf files to a citation, but firefox cease to work when doing this.
    Firefox (3.013) on ubuntu jaunty and zotero 2.0b6.5.
    Should this fix apply in this version also, I can seem to find the zotero.js file??
  • there are two different issues: drag&drop _within_ Zotero has always worked in Ubuntu (and did last time I checked on exactly the same config you're running).

    Dragging files to Zotero from the file system (e.g. from a nautilus window or the desktop) has never worked in any linux - not sure what the problem is, but the described fix won't do anything for that.
  • Ok thanks, I was refering to the second issue.
  • edited November 26, 2010
    Using Ubuntu 10.4, Firefox 3.6.12 and Zotero 2.0.9 - issue still exists.

    Can't drag and drop within Zotero, e.g. to add an item from the main library to a collection. As far as I can see, there is no other way than drag + drop to do this...

    Is there an updated fix?

    UPDATE: Oh well. For some reason, preparing for debug output (http://www.zotero.org/support/debug_output) and killing + restarting firefox via terminal has it work now. I had started + restarted firefox before several times, but it hadn't done anything. Now drap'n'drop is smooth. -shrug-
  • Same here, can't drag within zotero.

    Ubuntu 10.10 (linux 2.6.35-25-generic x86_64 GNU/Linux)
    Firefox 3.6.13
    Zotero 2.0.9

    Made a debug report which seems to contain the drag try: The Debug ID is D291475539.

Sign In or Register to comment.