ZotFile - Advanced PDF management for Zotero

  • edited April 4, 2015
    Ok, I've missed this zotfile renaming menu (sorry).
    Now, I get this error : « Attachments skipped because they are top-level items, snapshots or the file does not exist »
    My attachment is a JPG picture that I've linked (ctrl+shift+drag&drop) to an item.
    Is there anything else I've done wrong ?
  • Check in the Zotfile preferences under Advanced Settings. Is "Only work with the following filetypes" checked? If so, either uncheck it or add the other extensions (jpg, png, and others) to the text box
  • edited April 4, 2015
    Thank you very much. I've missed this too. Everything works fine.
    One more question : by default, the renaming process of attachment is also a moving process of it (in Zotero or in a custom folder). Is there any way to disable the moving action ?
    In Advanced Settings, first tab, I can choose where attachments are moved, but not disable it.
    Is there again someting I've not understood ? Or, is there a hidden option in about:config ?
  • I believe there is no way to leave a linked file where it is while renaming it with ZotFile, no. (But I'm not 100% certain about this, someone else may know better).
  • Actually, a user just contributed a patch that will rename the file in place if no location is specified.

    If you install the beta version of Zotfile from github (instructions here), this functionality will be enabled for you.
  • edited April 6, 2015
    Ok, I've tested the beta version (4.1.4), the 'renaming process without moving' is working, but there is a little bug.

    If an single item has more than one linked attachments, normally in the renaming process, zotfile add a digit as suffix for the second one, the third one, etc (to avoid a situation where differents files have same names).

    With this patch, when you rename a group of linked attachments of one single item : 1/ all linked attachments get the same name (no suffix is added), what is not possible, so 2/ all the files attached are deleted, except one, and 3/ the group of differents linked attachments become a group of identical linked attachments.

    I hope that I'm clear. If I don't, ask me for détails. :-)
  • Hey guys,

    here's just another case of a stupid user. Any help is highly appreciated. The problem is this:

    I wanted to move entries including attachments from my group libraries to my library. Because space was very limited I first tried to locate my attachments in my OneDrive folder with the help of Zotfile. Nothing happened. So I tried the same with Zutilo. Nothing happened.

    After a few restarts of Zotero Standalone and Windows it eventually worked. At that point however I had already decided that it's probably more convenient to just invest a little bit of money and upgrade my Zotero storage.

    Now I would like to restore the file associations back to the original zotero storage for sync. But whenever I move entries from the groups to my library the attachements end up in my OneDrive folder.

    I changed the folder settings in Zotfile but it didnt solve the problem. I couldn't really find how to restore the file associations with zutilo. I guess if I tell Zutilo to use my zotero/storage folder they still won't be synched because of the folder names, right? Restarts and reinstalls of Zotero, Zotfile and Zutilo (I'm using the browser based Zotero again) didn't change the situation.

    The problem should be relatively easy to solve. The libraries as they are now are fine. It's just about restoring the original settings for future entry/attachment movements. Any keys in the about:config I can change to make it happen?

    I know the main reason is obviously my stupidity. Sorry about that! Thanks!
  • ZotFile set to "Store Copy of Files" under "Location of Files" in the general tab of the preferences should do the trick.
  • Tried that but it doesn't work. I'd guess that Zutilo overwrote/writes those settings. Uninstalling Zutilo made no change by the way. Any way I can change that manually in the about:config?
  • jh23 -- Start a new thread, this is getting too involved.
  • maybe this is important. When I first moved entries from one group to my library I set zutilo replace all instances of partial path string.

    now when i copy an entry from this specific group library to my library it only shows a link that points to the onedrive location while the original attachment is in the zotero storage.

    when i move files from other groups it just does what it should, place the attachment in my zotero/sotrage folder.

    so i guess that's what i have to undo just no idea how
  • here we go: https://forums.zotero.org/discussion/48090/restore-attachment-path-to-default-after-modifying-it-with-zotfilezutilo/
  • Thanks archi02! I forwarded your bug to the person who contributed that feature
  • archi02, I just pushed a change to github contributed by Soham Sinha that might fix the problem. Can you give it a try?
  • edited April 7, 2015
    I've done few tests. The last commit solves the problem, thank you very much. I also notice that the warning message about 'renaming without moving' has disappeared, it's a good thing.

    But, in my opinion, one little thing could still be improved. In this last version, when renaming a item several linked attachments, the order of them change, and it should not be.

    For example : an item called "Letter from the President" has three pdf files attached : page1.pdf ; page2.pdf; page3.pdf. The files are attached in alphabetical order, that isn't very important but very useful (especially when there is a lot linked attachments). Actually, the renaming process get : Letter from the President2.pdf ; Letter from the President3.pdf ; Letter from the President.pdf. The first page has no suffix added so, after the renaming process, it displayed in the last place of the list (if I manually add "1" as suffix to the first attachment, it cleans things up).

    To sum up, I wonder if the renaming process should, when an item has several attachements, add a suffix from the very first one.
  • Thanks for checking. I agree, the numbering is not optimal but a different approach would require a number of changes so I won't get to it anytime soon.
  • I've got a file that extracts nonsense characters. Extractions on other files work fine. I've tried both ways of extracting (pdf.js and popper), but neither work. I CAN copy and paste from the pdf.

    Any chance someone could look at the file and tell me what I can do to extract? I don't know where I can upload it, though.
  • If you can post the file somewhere (e.g. Dropbox) and link to it here, we can take a look. Otherwise you may have to email it to someone (probably Joscha) for further debugging.
  • Here's a link:

    https://dl.dropboxusercontent.com/u/32296931/Unextractable page.pdf

    This is a link to just one page of the document (the document is a 645-page pdf).
  • I don't think there is any hope for this one. How can you copy text? I clearly can not copy any text from the pdf. Neither with Preview nor with Adobe Reader. So there is nothing that can be done.
  • @mbabicz: Safe your Unextractable PdF as Tiff image with Acrobat (this will trim the messed-up text layer), re-import the individual tiff-pages into Acrobat and create a single pdf from the tiffs. Then OCR the document afresh to generate a new text layer. I just tried this with your unextractable sample and it worked well. (You will have a neglectable quality loss in the resoultion of the resulting document.) Try the ClearScan option in Acrobat, which will give you a cleaner text and smaller file size.
  • @mbabicz

    You can also save a step in @kithairon's instructions by Printing to PDF from Adobe and choosing the "Print as Image" option in the printing preferences.
  • @bwiernik: I've never actually managed to do what you elegantly suggest; on a Mac the Adobe Print Dialog stops you from saving the "Print-to-image" back to PDF – I can only send it literally to the printer. (In the older versions there was an actual "Adobe Print" driver appearing in the printer GUI that could be selected instead of a physical printer). Happy to learn of any other options.
  • When I use Zotfile to extract annotations from a PDF as a note, then "generate report" from the reference, there is a page break on the report between the reference title / author / volume etc. and the heading "Notes". This puts a empty page between the reference and the notes when printing.

    In contrast, when I manually write note in Zotero then generate report and print there is no page break.
  • @kithairon

    Ah, I see that Adobe has switched to using Mac's native pdf printer, which doesn't allow "Print as Image". (This isn't the case on Windows, which is why I didn't realize until now)

    There are two options. First option: Install PDFWriter (http://sourceforge.net/projects/pdfwriterformac/) a pdf print driver that will show a PDF printer in the print dialogue (allowing you to use "Print as Image").

    Second, open the file in Preview. Then, File -> Export -> Export as TIFF. Then open the .tiff file in Preview and File -> Export as PDF. The advantage of this method over what you describe is that it exports to TIFF as one file, not several, making for a much faster workflow.
  • I've been using zotero + ZotFile with the tablet synchronization feature for a while now on different computers between which I synchronize my zotero library. Through sync conflicts it seems the state of the tablet files has become somewhat inconsistent. As a consequence, there is an increasing number of items in those 2 collections for which the attachments are no longer in the sync folder.

    When switching to either the "Tablet Files" or the "Tablet Files (modified)" collections I get a few dozen popups with the message "ZotFile Warning
    The information stored in attachment notes is missing for an attachment on the tablet. Make sure you do not delete this information manually" for different Zotero item ids. There are console logs of the form

    Security Error: Content at moz-nullprincipal:{a2ba0a12-b640-4ce9-96ac-8375472944a1} may not load or link to zotero://open-pdf/0_8QBGE9DZ/5

    Indeed all of these items are already "processed" i.e. have annotations extracted and have been removed from the sync folder.

    However for some reason they still have the _tablet or _tablet_modified labels. Strangely even removing the label manually does not remove the items from the search collections (even though they should be based on the search criteria).

    Even deleting and re-creating the searches doesn't help.

    My main platform is Linux Mint 17 64bit with Firefox 37.0.2 and zotero, ZotFile 4.1.4

    Any hints why this might happen an how to avoid/fix it are much appreciated. I'd be happy to provide more information if that helps.
  • However for some reason they still have the _tablet or _tablet_modified labels. Strangely even removing the label manually does not remove the items from the search collections (even though they should be based on the search criteria).
    Make sure you're removing the tag from both the Zotero (parent) item and the PDF attachment. There's no way the item can show up in the saved search if the tag is not assigned to either of those items.
  • edited May 1, 2015
    Excellent help; tried both of your methods; either of them work as described. This is truly useful, thanks. (And definitely preferable to what I described above.)

    Anybody else listening in on this: the PdfWriter's output lands in YourHD/private/var/spool/pdfwriter. There is a folder-alias in YourHD/Users/Shared/PDFWriter that points to the above location.
  • @aurimas Brilliant! I hadn't realized that attachments could also have tags. That was indeed the issue!
  • I have two questions:

    1) Is it possible to nest subfolders in the folder defined at Zotfile Options>General>Settings>Location of Folders>Use subfolder defined by?

    For instance, assuming my custom folder is ABC, I want subfolders named after the year of publication in ABC, with each such subfolder having further subfolders named after the journal. This third level subfolder needs to have the attachments.

    Currently I use "/%y /%w" to give me the year name first followed by the journal name.

    2) What is the Watch Folder function supposed to do? I assumed giving a custom location there and adding all my PDFs into that watch folder will automatically move them to the Zotero library. But nothing happens.

    Am I missing something?
This discussion has been closed.