URGENT Unable to load any items

I moved the library to an External Disk to increase the space available, and it was working perfectly.
Today, however, when I tried to open it the library was not uploaded, no items appeared, only the structure.

This is the Error Report: 1089743182

Not sure what happened, but I urgently need to solve the problem.

Any advice much appreciated.
  • Is your preference setting still pointing to the new location?

    Might you have made the change with Z for FF and then today used Z Stand Alone (and didn't change the the preference location)...or vice-versa?
  • No, I always use Zotero standalone, never Z for FF. I think the problem is with the external drive in some way, but apart from Zotero it does work
  • Is it a network drive?

    Also, what OS are you using? What version of ZSA?
  • It's a USB external drive for a MAC OS X 10.9.5

    ZSA Version
  • Is the data folder still on the external HD?

    Did the drive letter change?
  • Yes, everything is there, and the drive letter is the same.

    A doubt I am having right now: do I have to transfer on the external drive the whole Zotero directory or only the storage one? because this might be the problem
  • I mean only Storage or the files such as zotero.sqlite etc. too?
  • Sorry, I can't answer that question, and I'm out of ideas. You will need to wait for someone more knowledgeable to come along.
  • Thanks very much for your efforts. Really appreciate it.
  • A doubt I am having right now: do I have to transfer on the external drive the whole Zotero directory or only the storage one? because this might be the problem
    You'd have to transfer the entire Zotero data folder, not just storage.
    When you say "only the structure" in your first post, what exactly do you mean? You're still seeing your collections, but no items in the middle panel? Could you take a screenshot, upload it to a free image hosting site (imgur.com, dropbox...) and link to it here?
    You've tried restarting Zotero I assume?
  • OK, I actually did transfer the whole Zotero data folder (I assume I can erase it on the other side, right?)

    I did restart Zotero and once the computer. Nothing changed.

    What happens is that I can see the list of collections from the very start, then after a couple of seconds the arrows appears showing that I have more subfolders, but the items do not appear.

    I will send a screenshot on dropbox and share the link here
  • (I'd keep the data folder in the other location around as a back-up until we have this sorted).
  • This is the dropbox link

    The red mark next to the Sync button says:

    Transaction in progress in Zotero.sync.server._checkSyncUser

    In the middle column just says in Italian that an error happened. Restart Zotero. Send a message about the error at etc. (nothing helpful really)
  • That shows that you are looking at a group library, not your personal library.
  • no, that error message is for all of Zotero.
    If this is, in fact, urgent, I'd revert back to your local harddisk. Running Zotero of external disks occasionally causes problems.

    Dan will be around and may be able to say something more specific based on the error report ID in the first post.
    You could also try to check your database Integrity in the Advanced tab of the Zotero preferences.
  • @adamsmith, I wasn't commenting on the significance of the error message (if indeed your comment "no, that error..." is directed at my statement. I was simply noting that that a group library is clicked on in the left panel, not the personal one, if that would make any difference.

    I apologize if I've confused things.
  • right -- what I mean is that once that error message appears, it doesn't matter what you have selected on the left. Zotero can't read the database on a pretty fundamental level.
  • I did try both the personal and the shared library to see if there was a difference, so it is just by chance that you got that screenshot. In both cases there are no items.

    I can still access Zotero from my desktop but soon I will need to work on the notebook in libraries etc., so it is kind of urgent but not REALLY urgent :-)
  • Check your database integrity from the Advanced → Files and Folders pane of the Zotero preferences. But yes, this might just be a problem with the external drive.
Sign In or Register to comment.