"this.registry.registry[myid] is undefined"

Im having a problem with a large document, 70,000 words or so, when I add a citation Im getting the error message: "this.registry.registry[myid] is undefined", but when I retry the citation a second time it works.

I use MLZ New Zealand Law style, Firefox 36.0.4 browser and the word plug in is 3.1.19

Any thoughts?
  • Note that it's possible that mlz styles fail when used with regular zotero. If you're using mlz, you would need to say so and edit your first post so that that's reflected in the subject line so that the mlz dev sees your post.
  • Dan I tried doing 'report errors' but get a message "invalid response from repository". Adam, I can restart this forum with MLZ in the heading. Is there anything else I should provide to help figure the problem out?
  • I copied an pasted my entire document into a fresh word doc and it worked fine for two or three citations then failed. A fresh doc with only half a dozen pages failed after the third attempt with the same citation.

    I opened a fresh document and noticed that when I used different citations each time there was no problem, but when I used the same citation more than twice it failed.

    Testing different citations and some prompt failure when used consecutively and some dont. In general once I start working every citation fails.

    Opened a fresh doc and used Chicago style instead of NZ Law and it worked fine. A new doc using NZ Law failed, so its definitely something about the MLZ plugin. Who would I notify about that?

    I can work with this problem, and have been doing so for some time, but its pretty frustrating...
  • (Note that you can always edit your original post to change the thread title. There's no need to create duplicate threads. Anyhow, I'll delete this one now.)
Sign In or Register to comment.