ZotFile - Advanced PDF management for Zotero

  • RE: Zotfile Rename - Show File?

    I've been unable to solve a problem from last June concerning problems associated with the "Show files" function in Zotero for files renamed with Zotfile. I'm currently running Zotero Standalone 4.0.26 and Zotfile 4.1.3, and still seem to have this problem. The original posting follows below:

    "I've noticed that after renaming my files via Zotfile (v3.1) in Zotero Standalone (4.0.20; Win 7), the "Show File" option in Zotero no longer opens the directory containing the linked file. Is this the expected behaviour for linked files? I've found the Show File option very useful when attaching PDFs to emails, and would like to recover this option if possible. Is this problem already known?"

    I'm happy to run any troubleshooting you suggest - just let me know. Its a relatively minor (but frustrating) error, and I can't figure out where it originates!

    Thanks for your help,

  • edited February 20, 2015
    Hello Tony,

    I also faced the problem, and I think I know when it happens.
    Can you please tell us what are the options you are choosing? Right from attaching the file up to Renaming?
    By options, I want to mean like "Attach Link to File"/"Attach Stored Copy of File"?
    Then when you rename with ZotFile, what option did you select in ZotFile Preferences > General Settings > Location of file?
  • Sohamsinha,

    Thanks for your mail. New entries are typically added directly from Firefox along with PDF attachments. References are checked for consistency upon import. If journal titles are inconsistent with other database entries, these are corrected, and attachments are renamed using Zotfile (Manage Attachments|Rename Attachments). All references are stored locally in a custom Zotfile folder (Journal PDFs\%w PDFs), a nested structure in which all references from the same journal are located together. References are named according to %w%v-%f (ie. JournalVolume-Pages).

    Interestingly, all PDFs open fine, and its only the "Show file" option which does not work. All references added before 2/22/13 work as expected.

    A bit of a puzzle. Any suggestions?


  • @Tony
    Sorry for late reply.

    I tried it in my machine with Zotero Standalone. I followed exactly your steps. However, I didn't find any error, and it works for me. I am sorry. I don't think I can help you in this!
  • Hello,

    Very glad that Zotfile exists! I've been combing this thread to see if my question has been answered, but no luck yet. I'm setting up Zotfile to work with Standalone, and have successfully gotten it onto FF, however, when I try to find the xpi file in my downloads folder it's not there and a search of my Mac doesn't turn it up. Any suggestions? (And would be happy to be pointed in the right direction if I missed the answer previously!)

  • This is for a different add-on, but the instructions are essentially the same:
    download using right-click-->save link as, install from the tools-->add-ons menu.
  • @adamsmith, thanks for this suggestion. Unfortunately, when I use these steps the SaveAs file is .html and not an .xpi, so I think that's the problem. When I point Standalone to it the file doesn't exist in my downloads folder. Any other way to get ahold of that file?

  • if you right click on "Add to Firefox" on https://addons.mozilla.org/en-US/firefox/addon/zotfile/contribute/roadblock/?src=dp-btn-primary&version=4.1.3 you definitely get the .xpi not an html file. You probably just have to click through one more time than you currently are.
  • Thanks adamsmith, that did the trick.

    So now another noobie question: I have made a dropbox folder for the pdfs so that I can edit them on my tablet. However, now it seems that in both Zotero standalone and on FF it won't automatically download pdfs with the references. I just get the ref data and a snapshot, but the pdf itself gets a red x next to it, and it doesn't go to my zotero-pdfs folder. Is there somewhere I can see how to do this?

  • edited February 24, 2015
    that has nothing to do with ZotFile, please start a new thread on that.
    edit: and include the URLs for some of those pages as you see them.
  • edited February 24, 2015
    Ok started the thread. The URLs of the Proquest pages you mean? Don't think that will work because it's behind an institutional firewall.
  • Hi Joscha,

    Zotfile recently started not to rename attachments when I try 'Manage attachments - Rename attachments.' Instead it shows the following message:

    Attachments skipped because they are top-level items, snapshots or the file does not exist.

    I checked that the file does exist and that they are attached in the Zotero's data folder. I also tried renaming from both the top level item and the attached item (the PDF file.)

    I suspected that this might have started after I started synchronizing Zotero database using the Zotero server, but the problem was not solved even when I stopped synchronization.

    Curiously, when I choose 'Rename File from Parent Metadata' from the context menu, it does rename the file in the Zotero database. But what I ultimately want is to move the file between the Zotero folder and another folder in Dropbox, which is not working.

    What can cause this problem, and how can I solve this? Please let me know if I need to try something.

    I use FF 36.0, Zotero, Zotfile 4.1.3 on Mac OS X 10.10.2. I do not see any entry with 'zotfile' in Browser Console.
  • Dear Joscha

    I'd like to second the suggestion that which Guppy made on Feb 13th 2012 on the 7th page of this thread,

    "First, thanks for this awesome plugin! I have a question and a couple of suggestions for new features.
    1. I would love to be able to optionally extract each comment to a separate note. Then I could tag and access the notes individually later.
    Thanks again for your work.

    I like the way that individual notes make the notes visible when using Zotero e.g.

    Thanks again,

  • (devs have specifically asked Joscha not to do this because too many notes slow down Zotero and, especially, syncing).
  • edited March 2, 2015
    Thank you.

    That is a shame. Perhaps it might be left as a hidden option, with a warning not to sync if one uses it, for those of us who do not sync.
  • Hi Joscha,

    Thank you for the plugin. Just a question relating to what I'm currently facing and if there is any solution to it.

    I have my zotero standalone installed in my work computer in university as well as my laptop at home. Every single time when I need to do writing at home, I will need to export the whole library to an external storage to be imported into the zotero standalone in my laptop at home (I can't use the web server for zotero due to the space limitation and I have each hardcopy attached in my whole list of references. It takes a LONG time to export and import into the zotero standalone for both computers.

    I have recently discovered zotfile and has been renaming the attachment to a cloud storage (dropbox) to ease access as well as thinking it will reduce the export library time since the files are not exported. However, it seems like whenever I export my library in my work computer, the attached file is exported as well. Is there anyway of not exporting the attached file but to linked both of my zotero standalone (work and home) to the renamed files/attachment in dropbox? After importing the library to my other zotero standalone, it appears that the metafile is seen as a hardcopy attachment rather than being linked to the renamed files in the dropbox.

    Any help is appreciated.
  • You probably should take this to a new thread since your questions are about Zotero's export, not ZotFile.

    But once you do that, may I ask why, once you have the attachments linked to dropbox, you don't just sync? There are no space limitations on data sync, just on attachments.

    Even if you don't want to go that way (and you really, really should) you can transfer via the data folder instead of doing export/import (which has all sorts of other problems, especially once you want to work with the word processor add-ons):

    Again, though, any more on this should go in a new thread as clearly ZotFile is working for you as advertised.
  • Greetings,

    I am working my way through utilizing zotero for indexing and searching pdf files with its highlights and notes. I am currently using zotero v and zotfile 4.3.2 on a windows xp pro sp3 machine.

    I am having a problem configuring the app to open note links in the respective pdf file. I am using foxit for making notes. The annotations are properly found and added to an items note. But the links to open the pdf to a location do not work. I have tried both store copy of file and link to file attachments. In both cases I have a link in the form of zotero://open-pdf/0_82XHCMN9/5. If the pdf is a link to file, zotero does nothing when I click this link. If the pdf is stored, zotero opens a new & blank 'note' window. In both cases I can use the 'view file' right click option to view the pdf in the system default pdf viewer. I have tried entering the path to the pdf view/app in the about:config 'pdfwin' item but it makes no difference.

    I feel I'm missing something very basic here. But I can not figure out what it is. I'd appreciate some help.


    Be well,

  • likely just that the PDF opening command ZotFile uses to identify your PDF reader and open the file at the appropriate location doesn't work on Windows XP--pretty sure no one ever tested that. Your setup sounds fine.
  • Greetings adamsmith,

    Thanks for the reply. Is there a log file I can enable/grab? And should it be for zotfile or zotero? I don't know where to look to find out how the macro 'zotero://open-pdf/0_82XHCMN9/5' is expanded.

    Be well,

  • I simply can't test all the system/pdf-reader combinations so problems like this are not surprising. If you have some experience with coding, take a look at the file "openPDF-protocol-handler.js" on github to check how zotfile deals with these links. I think on windows zotfile uses something like "[path to pdf reader] /A page=[page] [path to file]" but I would have to check in detail to be sure. A first step would be to confirm that and then try whether it works manually from the command like or whether your pdf reader uses different command line options. Another possible problem is that zotfile does probably detect your pdf reader but I would look into afterwards.
  • Greetings Joscha,

    Thanks for the reply. I will take a look at the js file in a day or so.

    Be well,

  • Joscha,

    I looked up the foxit command line parameters. Strangely, to me, they place the command after the file name! So, I grabbed a copy of pdfxc viewer which places the command before the file name, entered the program location string in pfgwin and ... it works!! In both cases. However I'm still getting a zotero note window opening at the same time.

    Still, your memory of the macro expansion was correct. Since I haven't used foxit in many years (I prefer sumatra), I can't tell you when they may have changed their command line format.

    I appreciate the time you and adamsmith spent on this. It does remind me of the days of compuserv !!!! LOL!

    Be well,

  • I use Zotfile with Zotero, which I use on Firefox. My OS is Windows 8.1. I have about 20 files that are showing up in my "Tablet Files" folder, and keep showing up even though I have attempted to "get them from tablet" numerous times. Any tips on how to alter this? I manually deleted the _tablet tag on these files, and they still show up here. (Curiously, none of the PDFs actually show up in my Dropbox tablet folder.)
  • You could try deleting the "Tablet Files" Saved search and recreating it (there's an option in ZotFile). Maybe that'll work.
  • I doubt recreating the saved search would help. Are you sure the tag is not still assigned to the file attachment? (rather than the parent item)
  • edited March 30, 2015
    Is there a way to change the cite-format, when using the 'Extract Annotations' feature?

    I have found the option to do some adjustments in extensions.zotfile.pdfExtraction.formatAnnotationNote, but the %(cite) variable does not seem to be configurable?

    Right now it comes out as "%(author) %(year):%(page)" and I would like it to be "%(author), %(year), p. %(page)" instead (APA-style) (exampled with fictitious variables, but I hope it makes sense).

    I.e. "Clegg et al, 2005, p. 150" instead of "Clegg et al 2005:150".

    But I seem to have hit a wall, so any pointers or hints, would be greatly appreciated.
  • edited March 31, 2015
    I don't think that it is possible right now. It makes sense and I opened a github issue: https://github.com/jlegewie/zotfile/issues/175
    I won't implement it anytime soon though. But feel free to send a pull request if you have some coding experience.
  • edited April 3, 2015

    I'm testing Zotfile to rename attachments with a specific pattern and specific wildcards. But Zotfile don't manage to rename, even with the defaults pattern « {%a_}{%y_}{%t} » and defaults wildcards. If I try to rename an attachment, Zotero is doing it, not Zotfile (visible because the default zotero pattern is used, and the not zotfile's one).
    I precise that :
    1/ the box "use zotero to rename" is not checked ;
    2/ and that the preview works well (even with my own patterns and owns wildcards);
    3/ with the linked documents or saved document in zotero, this strange behaviour is the same.

    What's happens ? What I'm doing wrong ?
    I'm using Ubuntu 14.04, Firefox 36.0.4, Zotero et Zotfile 4.1.3.

  • how are you renaming? Automatically? To trigger ZotFile to rename use "Manage Attachments --> Rename Attachments"
    Rename File from Parent Metadata will always use Zotero's renaming.
This discussion has been closed.