LibreOffice plugin requires legavy Java on Mac

I'm using Zotero on Mac OS 10.10. When trying to install the LibreOffice plugin, I'm asked to install the "legacy Java SE 6" runtime. Since I don't want to install that, is it possible to make the plugin work with more recent versions? Thanks!
  • no. LibreOffice doesn't work with 64-bit Java versions, there's nothing Zotero can do.
  • Ok thanks anyway.
  • edited February 19, 2015
    Hmmm.... This might be similar to my situation.
    I have Zotero Standalone on a MacBook Air with OS X 10.10.2. I didn't download Firefox, I'm using Safari, and, I don't have Word for Mac. I have no idea if I have 64-bit java or what. Never understood what the 64-bit and 32-bit terminology is about.
    I want Zotero Standalone and LibreOffice to be able to communicate with a plug-in. My professor says he thinks it's possible so I told him I'd look around. I quit looking when the looking got painful! I couldn't find a plug-in, or anything that says that it's possible to install a plug-in so Zotero Standalone and LibreOffice can communicate without having Firefox installed, and without using Word for Mac! If you know the name of the plug-in or where to find it ... PLEASE ... tell :))
    I know there's a plug-in that I can use if I install Word for Mac, but I won't install it unless there's no option.
    Any advice?
  • The LibreOffice add-on comes pre-installed in with Standalone, you can find it (and potentially re-install it) in the Cite tab of the Zotero preferences/options.

    There's a good chance this may not be working out of the box because of said java issues (which are a problem of Mac/LibreOffice, depending on who you ask, but definitely out of Zotero's control), but let's make sure you at least tried first.
  • Actually, I got the LibreOffice extension to work by installing jre-8u31-macosx-x64.dmg from, and reinstalling LibreOffice (as suggested at ).

    This is with OS X 10.10.2 and LibreOffice The extension wouldn't install with Apple's Java 1.6.0_65 I had installed, and LibreOffice wouldn't recognize Oracle's version until I reinstalled LibreOffice.
  • :))
    Thanks much. All this stuff is confusing to me. Can't get Java installed. But that's okay. I've uninstalled Libre and have decided to go with the flow ... Word. Just installed Word for Mac. I live in Thailand, and people who know much about Macs is small, and I certainly don't know much about computers in general, so I lean on others. Thanks much, and cheers to you all for making things work for you :))
  • Installing the latest version of Libre Office Version: on OS X El Capitan 10.11.6 caused lots of problems and Zotero plugin couldn't be installed and no JRE appeared in LO preferences.
    SOLVED by installing the Java JDK (not JRE) (following this advice )
    Link for JDK download:
Sign In or Register to comment.