File attachment sync error -- file permissions

I'm using ubuntu, and my zotero folder is on a separate NTFS partition. The problem is: Sync cannot download my attached files, and complains about file permissions. That doesn't make sense because (1) The file permissions are fine--They allow every user to create and delete files. (I just checked the exact file which zotero is complaining about. The permissions are "-rw-rw-rw-". The whole zotero folder is "drwxrwxrwx"). (2) I can successfully create files in my zotero folder via "Attach snapshot of current page". I can also successfully change the database by adding notes and tags. (4) The same partition has my Dropbox folder living on it, which has had no problems.

Here is my error message -- See Report ID 1065213038 for the whole thing.

[JavaScript Error: "bad script XDR magic number"]
[JavaScript Error: "[Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIFile.lastModifiedTime]" nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)" location: "JS frame :: chrome://zotero/content/xpcom/storage.js :: Zotero.Sync.Storage</this.checkForUpdatedFiles/</checkItems/</</</< :: line 1053" data: no]" {file: "chrome://zotero/content/xpcom/file.js" line: 657}]
[JavaScript Error: "The file '/media/steve/213E2996268ED049/zotero/storage/62ISH6ZU/Yao et al. - blahblah.pdf' cannot be updated.

Thanks very much in advance!! :-D --Steve
  • There have been problems with encrypted drives on linux in the past. Should be fixed in 4.0.23, but if you're still running a version before that, start by updating.
  • I'm using The NTFS partition that the zotero folder is in, is not encrypted (I'm 99% confident). On the other hand, my home folder *is* encrypted ... does that matter?
  • Do you mind saying which distro you're on? That might provide further clues. I don't think an encrypted home folder would make a difference.
  • The new one, 14.10. I can't say whether 14.04 had the same problem or not, because I changed the partitions at the same as I upgraded.
  • sorry, I read over the ubuntu part before. Ubuntu has never caused any trouble before--a lot more weirdness on Arch, in particular--so that should be fine. Let's see if Dan finds anything in the error report when he gets in later.
  • The issues with encrypted filesystems on Linux that we fixed were related to filename length. I don't know that we've seen access denied errors that didn't mean what they said. But if it's not a permissions issue, I'd guess that it's some issue with the NTFS interface. Here it's trying to set the mod time, not just write to the file, and it's possible that the NTFS interface doesn't like that for some reason. In any case, not something we could do anything about.

    But out of curiosity, did you actually set those things to 777/666, or is that just what all files on the NTFS show up as? (I'm guessing the latter, since it wouldn't necessarily have a place to store those.) What do you see for the 'storage' folder and the '62ISH6ZU' folder?
  • Dan, you're right! Following your hint, I found this discussion which I think will answer my question, or at least point me in the right direction:

    Apparently you can have NTFS mounts where it looks like you have full access but nevertheless there are permission problems. So it's not zotero's fault, like you say.

    I will try messing around with the mount options as suggested at that link above. If I find something that works, then I will post it here for reference. :-D

    To answer one of your questions, the only way to set NTFS permissions is while mounting the partition. (e.g., chmod doesn't work on NTFS files.)
  • In case anyone else reads this, here's how I got it to work: I added uid=steve,gid=steve to the line in /etc/fstab (steve is my linux username). So now my account owns the partition. (Earlier, root was the owner, which I thought was OK because everyone had good permissions, but apparently it's not good enough.) For what it's worth, the whole line in my fstab right now is:

    UUID=blahblah /path/to/mountpoint ntfs-3g uid=steve,gid=steve,rw,auto,user,fmask=0111,dmask=0000\0400\0400,x-gvfs-show 0 0

    Thanks again Dan and Adam for your help, --Steve
Sign In or Register to comment.