Syncing not implemented for collections?

I got some errors and used the Report function. A dialog said to report this code to the forum: 1669825093

All I did was open Zotero and click on a collection. The info pane said: "An error has occurred. Please restart Firefox." Soon a sync reconciliation dialog came up and it tried to reconcile two items, but after clicking Next through them, it reported "Syncing collections not implemented" (approximately)

I'd like to use sync. To get around this, do I just make sure not to add any new collections?
  • Please try 1.5 SP3, now available. If it still occurs, you'll need to clear one side.

    Collection syncing is supported, but not collection conflict resolution, which includes moving items in or out of collections on both sides between syncs. There are currently a few cases where collection conflict resolution can be triggered even if you don't change both sides between syncs.
  • I just updated to 1.5 SP3 and restarted Firefox. Now it's worse. :-|

    At the end of attempting to upgrade the database, I got this error:
    TypeError: rows[k] is undefined

    I clicked through to submit the report to Zotero under id: 1289396849

    Now the Zotero icon in the status bar has a caution triangle on it and when I click to open Zotero it says simply, "There was an error starting Zotero" and all I can do is click okay.
  • OK, pushed an SP3.1 that fixes this upgrade error.
  • Ok, SP3.1 upgraded correctly. I'll have to get to my other computer to try out syncing again.

    In the meantime, I tried exporting an RDF backup in order to try the "clear one side" procedure, but I got the error message, "An error occurred while trying to export the selected file." which I've reported under 1643039845.
  • This is fixed on the trunk. We'll be putting out an SP3.2 later tonight that fixes RDF export issues.
  • FYI, successfully upgraded to SP3.1 on my Windows box (was Mac earlier).

    My local library wasn't in sync with so I planned to Clear Server Data. First I wanted to delete some duplicates that appeared in my library after earlier problematic syncs.

    When I deleted an entry, I got an error about adding a tag to an unsaved entry. I just submitted it as 2071047790.
  • Just to clarify, are you sure you got that on delete? That's actually the error that occurs in the Sync Preview when you try to duplicate an item with tags...

    Are you able to reproduce it consistently? If so, generate debug output for the delete attempt and send it to
  • I wasn't able to reproduce it, so maybe I was duplicating when I thought I was deleting. I've deleted since without difficulty.

    I've also done the "clear one side" procedure and have my library synced happily now.

    One new thing I've noticed, though it doesn't impact me much, is that the list of items has many entries with the title "&nbspc;". Clicking on them they seem to all be attachments. Other attachments appear under the bib records they're attached to. I suppose the error is with the item listing web code and not the syncing system.
  • One new thing I've noticed, though it doesn't impact me much, is that the list of items has many entries with the title "&nbspc;"
    This should be fixed. Thanks.
Sign In or Register to comment.