Drag and Drop references in external programs


I used to be able to just drag and drop the references (according to whatever style was selected in "Create Bib. from item") into external programs such as Evernote. Now this does not work anymore. Can I activate this somewhere in the program?

Version (standalone)
Windows 7 x64

  • The style used for drag&drop is and always was the one selected as "Default Output Format" in the Export tab of the Zotero preferences. Check that you've something selected there. Nothing about this has changed on the Zotero side, so it should just work.
  • Thanks: I checked the export tab and a style is selected. However, I can't drag and drop. If I instead mark a reference and press Ctrl+Shift+C, I can copy the reference into evernote (or any other outside app). Any ideas?
  • Can you provide a Debug ID for an attempt to drag a single item?
  • also, check if this is Evernote specific. Can you e.g. drag to the Enter you comments window here?
  • Hi Dan: The Debug ID is: D1422613302

    @Adam: This behavior is not evernote specific; it also happens in notepad.

  • A few things:

    1) You appear to be using a custom style. Does this happen with a standard style or export format?

    2) Does this happen for any item, including a new, mostly blank one with just a title?

    3) There are a few different errors in there, but they might not be related. Can you temporarily disable auto-sync, restart Zotero, and then generate another Debug ID for this?
  • Hi Dan:

    1) Now I used one of the styles that comes with Zotero

    2) Yes, in the attached debug ID, I created a new journal item with the title "test" and tried to drag and drop into notepad. Didn't work.

    3) I disabled auto-sync, restarted Zotero, and this is the new debug ID: D1838368019

  • What about with an export format?

    It's not necessarily related, but you are getting this error, which suggests you have an invalid style in your data directory:
    [JavaScript Error: "Error loading style '_.csl': undefined" {file: "C:\[...]\Zotero_DB\styles\_.csl" line: 0}]
  • Thanks Dan:

    Instead of the drag and drop, I also tried to "ctrl+shift+c" and then paste into notepad. The debug ID for this is D136287219 (it shows the same JavaScript Error but when I press ctrl+v in notepad, it is inserted correctly.)

    Also, when I try the drag and drop, the mouse cursor becomes a crossed out circle when the mouse is in the notepad text area.

    Does the drag and drop work for you? I know it worked for me until very recently (maybe a few weeks).

  • it shows the same JavaScript Error
    Did you restart Zotero? The error log is only cleared on restarts. If you're getting that message, there's definitely an invalid style that you need to delete or fix, so I'd start with that.
    Does the drag and drop work for you?
    Yes, on OS X, though I can't test on Windows right now. But the visual feedback is a bit different that it used to be due to a recent change — it doesn't show anything happening while the drag is over the middle pane, but it does over collections and also if you hover over a text field. (That's technically correct, since you can't drag a top-level item anywhere else in the middle pane, though it's a bit unsettling.) The drag-and-drop code behaves pretty differently on different platforms, so it's possible that that change caused breakage on Windows. I would think we'd have heard about this sooner if dragging references was totally broken, though.

    Can someone else on Windows check?
  • Well, and did you try an export format?
  • Dear Dan:

    Yes, the error in the debug log also shows up after I restart zotero. D&D does not work but I can insert the reference in a text editor when I use ctrl+shift+c and then ctrl+v.

    Can someone confirm that D&D works on Windows?

  • @ssauerw: There is one more remaining question. What happens if you select an export format, rather than a bibliography style, in the Export tab of preferences?
  • (and in case that's not clear as an instruction--when selecting a default output format, once you scroll past all installed styles, you can select export formats like bibtex or RIS. Try one of those, e.g. bibtex)
  • edited July 6, 2014
    And again, if you're still getting that error, you need to delete or fix the invalid style that's causing it. It may be totally unrelated to this problem (the answer to the export format question would provide some indication), but I'm not going to bother with this further until that's no longer in the error report.
  • Adam: Thanks! I found the export format + when I select bibtex, I still cannot D&D into notepad or evernote. I tried further, and it seems D&D works when I drag the items (either reference or export format) into MS Word. Why would D&D work in Word and not Notepad or Evernote?

    @Dan: I'd love to delete the reference style that causes this error. However, the error report does not specify which reference style is at fault. What's the best way to find it?

  • Is there a file with the filename _.csl in the styles subdirectory of your Zotero data directory? If so, delete or rename it.

    Also check the <id> tags in your custom styles — one of them is likely messed up.
  • I can actually confirm this issue on Windows 7, Zotero on Firefox 30.
    Specifically, drag&drop

    _does_ work to:
    - Word
    - Firefox, including this forum and google docs

    _does not_ work to:
    - Notepad
    - Notepad++
  • Simon can reproduce that on Windows, but it happens on Fx29 and 4.0.20 too, so this doesn't seem to be a new issue, at least. If someone else doesn't get to it, I can take a look later this week when I have access to a Windows VM again.
  • Yes, I can confirm that Drag and Drop (Quick Copy) is not working with Notepad nor Notepad++. It has not worked for some time, therefore I have not seen it as a bug. Maybe more examples are useful

    drag&drop _does_ also work to:
    - Wordpad
    - Thunderbird Messages
    - JabRef
    - WinIBW (Pica client)
  • I found the same issue yesterday. It always worked when I was a more active user (until about a year ago). Tried to demo zotero to a customer and it failed :-(

    D&D does also _not_ work on
    - Texniccenter

    DOES work in
    - TeXworks
  • However, it is possible to use the context menue (right-click) and create bibliography and save it to the clipboard: https://www.zotero.org/support/creating_bibliographies#right-click_to_create_citationbibliography
    Then it is possible to paste the content also in Notepad or Notepad++.
  • as ssauerw notes, even the quick copy shortcuts -- ctrl+shift+c and ctrl+v to paste -- work, so this is very specific to drag&drop.
  • This is happening to me too. Also dragging files to some applications (not to windows explorer). For example dragging a file to attach into an email does not work anymore. Something that I used a lot.

    Summary, dragging references to paste reference text in email applications or text editors does not work. Dragging files into some applications does not work either.


  • +1 to drag-and-drop failing between Zotero 4.0x (both from FF30.0 and standalone) and text fields in Chrome, or Notepad++. Shortcut keys do work (never used those before, always just DnD'd). OS = Windows 7 64bit.
  • OK, here's the situation, best as I can tell:

    1) Dragging to many programs (e.g., Word, WordPad, Firefox, Thunderbird) already worked, as noted above.

    2) Dragging to Notepad doesn't work from anywhere (Firefox, Chrome, WordPad), so that's irrelevant.

    3) Dragging to Notepad++, Chrome text areas, and probably most non-Notepad non-working examples above worked from Firefox itself (which is the usual test for whether something is a Zotero issue or a Mozilla issue). It didn't work from Zotero for extremely complicated reasons related to Windows/Mozilla drag/drop support. I've fixed that in the latest 4.0 Beta, though at the cost of Zotero now showing 'copy' cursor feedback for all drags, even when using Shift to move items between collections. (Previously, it showed the unadorned 'move' cursor at all times, even when doing the default copy. That'd be preferable, but not being able to drag to some programs is worse.)
  • I really loved and used this feature quite often, so I am eager to see it resolved.
  • Dragging to Notepad has never worked for me and I did not think of this as a problem, assuming that it happened because Notepad did not allow any kind of formatted text, something most styles have (italics, numbering, bold, etc)
Sign In or Register to comment.