cannot copy/cut and paste into zotero

When manually creating/editing Zotero entries in Zotero Standalone, Cut/Copy and Paste does not work at all-not for fields, notes, etc. this is especially annoying for long titles and URLs I am updated to the latest version of Zotero, and use a plugin from Chrome.
  • have you tried using keyboard shortcuts (ctrl+v etc.)?
  • Yes. When I right click paste, it is available as an option, but no text pastes.
  • That wasn't adamsmith's question. If you use a keyboard shortcut, does it work?
  • Also, what OS is this?
  • Sorry, misstyped. Keyboard shortcuts do not work either. Using Windows 8.1
  • edited April 29, 2014
    Both right-click -> Paste and Ctrl-V work for me on Windows 7.

    Where are you copying from? Have you tried copying from another Zotero field, as opposed to an external program?
  • edited April 29, 2014
    Various sources, including url box, general website text, etc. I have even tried copying and pasting the text into a blank word document to remove formatting.

    The only thing that seems to work is to paste it into word or gmail, then a Zotero Note, and then into a Zotero field such as url, etc.
  • But again, you didn't answer my question — does it work copying from one Zotero field to another?
  • Are you running any sort of unusual software on your system? Have you tried temporarily disabling security software? I don't believe anyone has ever reported this, so it's likely something specific to your system.

    Do you have the latest version of Zotero (currently 4.0.20)?

    If you have Firefox installed, have you tried Zotero for Firefox with Standalone closed?
  • So it sounds like it's an issue with rich text on the clipboard (though I'm surprised about the address bar, since that should be plain text — from what browser?). If you paste first into a plain-text editor (does Notepad still exist?) and then copy from there I suspect that would also work. Word, website text, etc., would all be rich text.
  • Also, I doubt there's an error for this, but if possible provide a Report ID after trying to paste.
  • I am using Chrome, and am not running any unusual software. Using webroot for my security software.

    Report Error is: 118994117

    [JavaScript Error: "TypeError: this._editor is undefined" {file: "chrome://zotero/content/bindings/styled-textbox.xml" line: 200}]
  • Have you tried disabling your security software?
  • That seems to have done the trick, and I can now copy and paste. Is there any way to fix this without disabling the security software each time? I use webroot.

  • edited April 29, 2014
    Added Zotero application as a manual exception under Identity Protection settings in Webroot, and problem seems to be solved for now...
  • OK, thanks for the info. I've added this to the Incompatible Applications section.
Sign In or Register to comment.