Report ID 765734730: Zotero and Firefox Crash when LibreOffice opens MS Word Document with citations

MS XP 5.1 Build 2600.xpsp.080413-2111 SP 3 (C) 2007
Zotero LibreOffice Plugin 3.5.8
FireFox 27.0.1
MS Word version 14.0.7015.1000 (32 bit)

1. open firefox and Zotero window
2. create a document in MS Word with Zotero citations (call is Document A)
3. open Document A with LibreOffice Writer
4. click on Zotero toolbar icons, note that nothing happens
5. close firefox
6. try and open firefox, get message that cannot open firefox because it is already running

I have reproduced this bug many times.
- I have removed firefox and all Zotero data and reinstalled Firefox and reproduced this error with only three citations in zotero database
  • this is connected to the following bug post....
  • Can you restart your computer and try again with Zotero LibreOffice Integration 3.5.9, just released? It is unlikely to make anything work that didn't before, but it should give you an error message instead of crashing.
  • Thank you for your quick reply!

    Did the version of Zotero LibreOffice integration at that link ( change since last night? I thought I was using the link at that location and that it was version 3.5.9 . Perhaps the title at the top of that screen should be changed.

    Either way this is what I noticed and learned with 3.5.9 installed as per your suggestion,
    1) the firefox crash bug is no longer there (I tried several times to repeat my previous crash and was unable to. It was very reproducible last night
    2) LibreOffice would then crash when I try to open the MS Word document. I would have to close LibreOffice and re-open it in order to be able to edit again.
    3) eventually after installing and uninstalling Firefox and Zotero several times, when I would no longer get 2 above, but rather messages:
    Your document must be permanently upgraded in order to work with Zotero 2.1 or later.

    "It is recommended that you make a backup before proceeding. Are you sure you want to continue?"


    "Zotero cannot update this document because it was created by a different word processing application with an incompatible field encoding. In order to make a document compatible with both Word and, open the document in the word processor with which it was originally created and switch the field type to Bookmarks in the Zotero Document Preferences."

    When I switched the citation preference to bookmarks in Word as per above and saved it as a *.doc file, then everything worked!

    It would help to know if you or someone changed the version of the libreoffice integration add-on since my post. If it wasn't changed then I wonder about the stability of my system or the code and what others might experience. Either way I like Zotero a lot and want to start trying out LibreOffice! I thought I would have to finish my paper in the newer version of Word they just installed on my new computer at work, but now I can finally go open source with my office apps!

    thanks again!

  • Did the version of Zotero LibreOffice integration at that link ( change since last night?
    yes it did. As you say in your initial post, you used version 3.5.8, Simon updated this to 3.5.9 last night.
    eventually after installing and uninstalling Firefox and Zotero several times(...)
    as I said in the other thread - this is really not a good troubleshooting technique. If it does fix things it's likely by coincidence.

    The errors you're getting are likely due to a corrupted citation. If you do want to fix that see
Sign In or Register to comment.