Authors don't appear bold in MS Word

I'm using the Firefox Add-Ons Zotero, Zotero Word for Windows Integration 3.1.15 on Windows 7 32bit in Microsoft Word 2010.

I insert citations and a bibliography using the style "The Journal of Experimental Biology". Format Using: Fields, automatically abrreviate journal titles, store references in document both checked.

Now the style of the journal foresees that the authors should be in bold in the bibliography. However, they are not.

But if I use "Edit Bibliography" and click on a reference the preview of the References correctly shows the authors in bold. Now if I edit one of the citations in the editor suddenly all references in the bibliography will be shown correctly, with the authors in bold.

Any ideas, how this odd behavior can be fixed?
  • Would you mind posting the first reference of your bibliography here? Don't worry about formatting like bold or italics.
  • Abrams, J. K., Johnson, P. L., Hollis, J. H. and Lowry, C. A. (2004). Anatomic and functional topography of the dorsal raphe nucleus. Ann. N. Y. Acad. Sci. 1018, 46–57.
  • could you try adding a journal article (can be fake) reference to the document that only has one author that would be sorted before Abrams (Abu Aardvark or so). I think there is a good chance that will fix this.
    Same for Fabian. If that doesn't change things we can look further.
  • Thank you very much for your help

    Here are some more details in case it helps figure out the issue.

    1. I forgot to mention that my citations in the text also appear in bold. At first I was manually converting them to regular font, but then I noticed that if I do a 'Refresh' to update any changes I've made to an item's metadata, they all go back to bold. I was planning to just de-bold them at the very end.

    2. If I copy and paste some of my main text, with citations in it, to a new document, and then do 'Insert Bibliography' in Word, the Bibliography comes out correctly formatted.
  • and adding the reference doesn't help?
  • I duplicated a random journal article and changed the last name to "Aar", single author. Didn't make a difference.
  • sorry since I don't have Word to test here, I'm fishing in the blind a little. Could you update your styles ("Update Now" in the general tab of the Zotero preferences) and then, in your document, switch to a different style and back. I've fixed up some small things in the style, maybe that will do it.
  • I did what you suggested and the problem persists. Thank you for trying to figure this out, I really appreciate it. But because I'm on a deadline, I'm just going to copy my main text into a new doc, insert biblio and then just grab the biblio and paste it into the original document. That should do it for now.
  • Last detail...

    I told you the problem didn't go away even after the updating, right? It turns out I had to do control+z 4 times to undo the bibliography insertion, and this is what happened with each undo command
    1. Went from times new roman size 12 to 11
    2. Font changed to arial
    3. Font changed back to Times, spaces between each reference disappeared AND the formatting got ALMOST correct. Italics are right, but regular text and bold text are swapped i.e what should be regular text is in bold and what should be bold is in regular text. A select all and bold should reverse this and make the formatting correct - which makes me think you might be close to figuring out the problem's source??

    Hope this helps!

  • edited January 9, 2014
    Unfortunately that doesn't get me any closer, no. There is no hurry, but once you're done with your deadline, could you see if this also occurs in a fresh document? The fact that copying the text over fixes this might mean it's entirely not-reproducible and the fact that we had two reports is a fluke (maybe because you're on the same deadline)
  • edited January 9, 2014
    I can't replicate this. Can you replicate it in a new document? I.e. open a new document, insert a reference using that style. Then insert a bibliography.

    If that works correctly, create another new document, copy paste the first page or two from your original document (containing citations) and insert bibliography.

    If that works correctly, copy-paste the whole document except for the bibliography (maybe omit like the last word of text preceding the bibliography) into a new document and insert the bibliography.

    Edit: err.. I missed the pat where you tried this already.

    Try selecting the last word of your main text preceding the bibliography and delete everything until the end of the document (cursor before last word, then SHIFT+Page Down until you hit the bottom, then delete). Re-insert the bibliography.
  • edited January 10, 2014
    I created a new document where I recreate the bug.

    I looks like this:

    ### Document Start ###
    Bla (Eeden et al., 1996)

    Eeden, F. J. van, Granato, M., Schach, U., Brand, M., Furutani-Seiki, M., Haffter, P., Hammerschmidt, M., Heisenberg, C. P., Jiang, Y. J., Kane, D. A., et al. (1996). Mutations affecting somite formation and patterning in the zebrafish, Danio rerio. Development 123, 153–164.
    ### Document End ###

    remark: The italic style for the journal works.

    I did as adamsmith suggested: I added a fake journal citation with only one author sorted as the first one. Then the formating worked correctly:

    ### Document Start ###
    Bla (Aaaa, 2000; Eeden et al., 1996)

    Aaaa, F. (2000). Fake. Fake J. 99, 99–999.

    Eeden, F. J. van, Granato, M., Schach, U., Brand, M., Furutani-Seiki, M., Haffter, P., Hammerschmidt, M., Heisenberg, C. P., Jiang, Y. J., Kane, D. A., et al. (1996). Mutations affecting somite formation and patterning in the zebrafish, Danio rerio. Development 123, 153–164.
    ### Document End ###

    Does this tell anything?
  • Can you upload the test document that does not show bold formatting somewhere?
  • This is a known Word bug/issue, yes: If the first reference in a bibliography contains more than 50% of a formatting - in the past that's mostly been italics, but bold will do the same - Word removes that formatting for the entire section (in this case the bibliography) when it's inserted.
    According to Simon there is no real way we can fix that on the Zotero side, so you'll have to work either with the workaround I suggest or the one that you found (editing the bibliography). Thanks for reporting, though, I hope this helps others who encounter the same issue.
Sign In or Register to comment.