cannot find webdav server

Hi If anyone could give me some advice that would be great. On my mac I have zotero syncing find with my uni sever.

Set it up on my windoze laptop and keep getting an error when trying to verify the server:

The server could not be reached.

folder have synced fine from the zotero server. I have updated windows and java. Have also tried with zonealarm firewall off.

Any advice would be great


  • Trying loading the URL (with https://) in Firefox itself on Windows and see if you can access it.
  • i have a similar problem.
    (i think)
    i can load my webdav server in firefox with http://
    but not with https://
    which is what zotero has embedded in the prefs
  • Thanks Dan, I dont know why I didnt think of it before - loading in firefox mad me install the certificate and make an exception, all working fine now!

    joh good luck!

  • edited September 7, 2008
    joh--Here are some file syncing directions--looks like you have to use a service that accepts https:// urls.
  • ah merde!
    i use dreamhost and it doesn't look like they offer https webdav.

    may i ask if zotero will support standard http webdav at some stage?
  • edited September 7, 2008
    may i ask if zotero will support standard http webdav at some stage?
    There's no technical reason it couldn't. It's HTTPS-only at the moment mainly based on the notion that, in 2008, there's little excuse for transferring private data (and login credentials that are potentially used for other important services) via an unencrypted connection, and Zotero server sync uses HTTPS as well. But, if there's demand for HTTP, we can add that as an option (perhaps in a drop-down with HTTPS as the default).
  • thanks dan. i imagine there might be quite a few users who only have access to http webdav. such as those of us who use dreamhost. not that https is not an often requested dreamhost feature. i'l write to support and see what they say because i can see the sense in what you are saying about transferring private data via unencrypted connections.
  • update :
    dreamhost do offer ssl but it requires purchasing a unique IP address ($50 per year) and a SSL certificate ($90 per year)
    that is not feasible for me so i will wait for http webdav to become available for zotero and create a special dummy user+password
  • I agree with Dan that there's little excuse for transferring data using unencrypted connections. Unfortunately, I think there are lots of people, including people in IT departments, who perceive security as nothing but work, expense and inconvenience.
  • HTTP will be an option in the next release.
  • Good to hear! It would probably be good though to include a warning that this will send your credentials unencrypted over the internet.
  • Hi all,
    Computer knowledges about creating webDAV paths from servers for my zotero are so far from me.

    I'm confused about syncing possibilities in storage server option from preferences...
    I'm working with 1,5 zotero version.
    1. Does storage server option help me sharing my library with other partners?
    2. I have a dropbox account and a one. I've tried to introduce my URL path but I have no results with uploading my zotero profile in there. What are the necessaries steps to achieve my correct Webdav? In fact, I don't know which data have I to introduce in there to achieve my library from other computers...

    It would be interesting to share my library with partners and sync and comment our documents in webdav platforms but, as you see, I can't evaluate if it is a stupid idea.

    Is there any angel to save me from my absolute ignorance?

  • I'm also using DreamHost, but can't afford SSL (I'm a lowly grad student and jumped on a 2-year plan for $21.48, or 90 cents a month).

    I set up my WebDAV directory: and entered it into my Zotero preferences (making sure not to select WebDAV secure on the drop-down box), along with my user name and password, but when I try to verify, I get this message:

    The server could not be reached.

    Is there anything I can do to fix it?
  • dstatman: Make sure you can connect to that address in Firefox itself before trying it in Zotero.
  • Hi Dan,
    Thanks for the quick reply. I typed my dreamhost zotero directory in my Firefox address bar, it asked for my username/password, and then loaded the empty parent directory for "Index of /zotero", Name, Last Modified, etc.

    Is that what you meant about ensuring I can connect in Firefox?
  • Never mind, I just tried verifying the server in Zotero and it was successful in setting up file storage. Maybe it just took time for my new Dreamhost WebDAV directory to initialize, I'm not sure.

    But thanks for your help!
  • I have a webdav set up. When I type in username/ on firefox, it asks me for my username and password. i type them in and them in and it brings me to the parent directory.

    I tried entering all of the information into Zotero's Sync options and it says this:


    The storage server did not accept the username and password you entered. Please check your storage settings or contact your server administrator.

    What could be going on?
  • blocked Zotero:
Sign In or Register to comment.