Problem with database repair tool

So, this afternoon I started getting an error message saying

"The Zotero database 'zotero' appears to have become corrupted.

Please restart Zotero to attempt an automatic restore from the last backup."

When I hit "restart now", it quits Zotero; if I then start it up again, it initially says

"The Zotero database 'zotero.sqlite' appears to have become corrupted.

Your data was restored from the last automatic backup made on 12/16/2013 at 18:00:55. The damaged file was saved in your Zotero directory."

But, a couple of minutes later, it'll return to the original error message. I tried using the Zotero database repair tool, but it won't let me upload the zotero.sqlite file or a file: it seems to think that both files are larger than the 100MB limit (the uncompressed database is 67MB, and the compressed one is 29MB). So, now I don't really know what to do.

Can someone help, please?
  • Try updating to the latest version of Zotero (4.0.18) if you haven't already.
  • Just updated (to 4.0.17, which seemed to be the latest version available?) - problem still remains, unfortunately.
  • ZIP files weren't working earlier today. Try again now, and let us know if it's still not working.
  • I'm having the same or similar problems. Same message. here's the text of the message window:

    [Exception... "Component returned failure code: 0x8052000b (NS_ERROR_FILE_CORRUPTED) [mozIStorageConnection.executeSimpleSQL]" nsresult: "0x8052000b (NS_ERROR_FILE_CORRUPTED)" location: "JS frame :: chrome://zotero/content/xpcom/db.js :: <TOP_LEVEL> :: line 149" data: no] [QUERY: DELETE FROM itemTypeFieldsCombined] [ERROR: database disk image is malformed]

    This window appears after I have declined the "restart now" option (using instead, "restart later" button) in order to open Firefox. When I hit the Zotero icon to open it in the browser, this message appears. It also appears when I try to open the standalone version.
  • I forgot to mention that I tried repairing the zotero.sqlite file with the automated repair process on the Zotero site.
  • Unless you have your database on a damaged disk or in Dropbox, etc., it's highly unlikely that you'd be getting that after correctly running your database through the repair tool. Try again, and make sure you replace the correct file.
  • Dan, thanks for your help. I found the right zotero.sqlite file, entered that into the data base repair tool, and it did the trick.
  • OK, I spoke a bit too soon. Zotero will now run (I only tried the Firefox browser version). But in trying to sync with the database, an error window popped up: I reported it. Report ID: 1939891801
    Error message:
    "Cannot set key after object is already loaded in
  • This could be a problem with your database, but first try disabling all your other Firefox extensions, including your third-party Zotero-related extensions.
  • And if that doesn't help, provide a Debug ID for a sync attempt that fails.
  • A Debug ID would be helpful, but if disabling other extensions doesn't help, unless you have a lot of unsynced local data you're probably best off doing a Restore from Zotero Server in the Sync -> Reset pane of the Zotero preferences.
  • Dan, I turned off all my other extensions, except for Zotero, started up Firefox again--same error message (this time ID: 594783954). In the diagnostics window it said:

    Direct3D 9 DeviceManager Initialized Successfully.
    Driver: igdumdx32.dll
    Description: Mobile Intel(R) 4 Series Express Chipset Family

    [JavaScript Error: "[Exception... "Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface]" nsresult: "0x80004002 (NS_NOINTERFACE)" location: "JS frame :: resource://app/modules/WindowsJumpLists.jsm :: WTBJL__clearHistory :: line 457" data: no]" {file: "resource://app/modules/WindowsJumpLists.jsm" line: 457}]
  • I just checked my Zotero, both the standalone and the Firefox browser. They both have data missing from multiple entries (e.g., Titles, dates, etc).
  • OK, here is my Debug ID: The Debug ID is D265300167
  • OK, so Restore from Zotero Server is your best bet. If you have recent data, you could export that to Zotero RDF and then import it again after the restore.
  • Dan, I feel a bit dense (perhaps fri aft can do that to a person). But I'm not seeing how to "Restore from Zotero Server" and I've tried to look in the Forum but can't locate this.

    I'm not worried about recent data, my zotero library on the server seems quite up to date.
  • I say above: "in the Sync -> Reset pane of the Zotero preferences"
  • Dan, thanks for your patience and perseverance. It all seems to work right now.
  • Hi there - sorry for disappearing, I was away travelling and then, y'know, doing Christmas. Still having some trouble uploading my database file, but that might be because I don't have great bandwidth where I am now. I'll try again when I've got a better internet connection and see if it works.
  • Okay, managed to upload it successfully this morning; everything now seems to be working fine again. Thanks for your help!
Sign In or Register to comment.