MS Word Alpha

I'm not sure where you want the discussion of issues with the MS Word Alpha addin, so feel free to move it if you want.

Two things:

1. the Blog says "For Windows users it should be located in C:\Program Files\Microsoft Office\Office\Startup". For my setup (Win XP; Office 2003), I had to put it in C: \Documents and settings\username\application data\Microsoft\Word\start up.

2. When I insert a citation it ends up BEFORE the (), instead of between them.

I think I'm going to like this!
  • Yes, the blog was incorrect—we've fixed it to reflect the correct path for Windows users. Thanks.

    The parentheses issue is a bug in Beta 3 itself (rather than the Word plugin), but we wanted to get the plugin out so people could start playing with it. Documents created with this version can be updated once the next version of Zotero comes out (which should be within the next two weeks), and the citations will auto-correct.
  • Well done. Works very well except for the the bug described (#2) above.

    Can't wait for the next update!
  • Did anyone else have these problems?

    1. I had to set MS Word macro security level to Low to get Insert Citation to work. You might want to include some guidance on handling this.

    2. When selecting multiple sources I couldn’t couldn’t remove an item from the right (selected) box. Clicking on the left pointing arrow didn’t do anything.

    Other than these two issues, it installs and operates fine. This is just in time for a presentation we are making to faculty/staff next month.
  • about the parentheses issue;
    although i have this problem when using the word add-on, i do not see this problem when i send the citation to the clipboard, and then paste it in word.
    is this what you mean?

    but a great idea anyway.
  • This is great… as great as Zotero! :-)
    Please keep going: I love when open source apps are so easy to use, user friendly and efficient!

    Just one thing to fix for the next (beta?) release: it would be even better if the popup windows appearing to select the ref or the style opened directly in M$word instead of calling firefox. (as it does now under mac os x 10.4.8 with firefox

    Would it also be possible to allow the user to easily create a new bib style?

  • malundy said:

    "1. I had to set MS Word macro security level to Low to get Insert Citation to work. You might want to include some guidance on handling this."

    Even after I changed my macro security level to Low, I could not insert citations or a bibliography. Instead, I get the following message: "The macro cannot be found or has been disabled because of your Macro security settings." When I go to Tools-->Templates and Add Ins the file is checked. Any advice?
  • I'm having the same problem as kristenkim and would definitely appreciate some advice.
  • I have one question and 3 problem reports:

    @ d_leaper: How do you "send the citation to the clipboard"?

    My main problem with this addin is at the moment that it initially does not get focus: I have to click with the mouse before I can enter some Text (say in the search field or the page field). Mouseless handling would be nice.

    For me it is not possible to enter multiple citations: After selecting several items and adding them to the right pane, only one citation is inserted.

    Lastely: citations and bibliography are inserted as fields ("Felder" in german localization of MS Word) but when I refresh/update ("aktualisieren") this field produces an error message: "Error! Textmark not defined." ("Fehler! Textmarke nicht definiert.")
  • @ gzattler
    right click on the entry in the zotero, and choose Create biblio from item, and from the pop-up select Copy to clipboard.
    i must admit it took me some time to find out, and at first i though u can only use zotero with thos biblio software.
  • @ d_leaper:
    I see. But this produces a bibliography -- as in:

    Rendall, M., Clarke, L., Peters, E., Ranjit, N., & Verropoulou, G. (1999). Incomplete
    reporting of male fertility in the United States and Britain: A Research Note.
    Demography, 36(1), 135-144.

    , whereas I wanted to insert a citation -- as in
    (Rendall, Clarke, Peters, Ranjit, & Verropoulou, 1999: 135-137)

    Bye, gzattler
  • Strangely, I have to put it in C:\Program Files\Microsoft Office\Office\Startup, I absolutely cannot find anything as C: \Documents and settings\username\application data\Microsoft\Word\start up in my computer. (I use XP Pro, Office 2002)

    Also, MS Word simply forbids me to use Zotero after installing it, even if I set the macro security level to LOW. A window pops up which says something about Visual Basic, but (very unfortunately) I have no idea what it means.

    Even more strangely, when a 2nd time to re-open Words, it works. Then the 3rd time, it doesn't. I'll have to try my luck.
    I suspect the set up is not very stable, would it be?

    Having said all these, Zotero is a GREAT tool, and certainly has a lot of potentials.
    Honestly, the best reference management tool I've ever encountered -- whether free or commercial. Keep it up!
  • one more thing: it would be good that repeated entries occur only once in the bibliography list (and thus receive the same index in case of note format)...
    For the time being, a new entry is created each time you cite the ref.

    Thomas, enjoying Zotero :-)
  • Hi. I am going to use Zotero for my essays this spring - good stuff. One issue:

    I tried the Word app for Mac, and inserted reference to two articles by the same author the same year. The first appears as Wade 2003(), which is ok - know the parenthesis issue is identified already. The second appears as Wade 2003b, which is also fine. However, the FIRST should then at the same time change to become Wade 2003a, which it doesn't. Would be fantastic if this could be fixed in future releases, betas, alphas, or what it's called.

    Keep up the good work.
  • You might be interested to know I tried this with Word 12 on windows XP and it worked - though I had to change the security settings. Won't be using till the parenthesis problem is fixed though.
  • Yam,
    did you resolve the issue with the Word giving you the Visual Basic error message? I am having the same problem, the Word does have the appropriate buttons, but when I click on them the same error message appears. I also set my security on low, but it did not help.
  • maichlerova,
    Basically I have got Zotero to work on Word. But over the last few days, I've been seeing the Visual Basic error message sometimes (not always). Anyway, it is working, so I just ignore the message
  • The Word pluggin problem comes back again all of a sudden, out of nowhere.
    I have been working on a document and the zotero has always been working there. I've been generating footnotes directly with the pluggin. But suddenly, just now, it stopped working and gave me the error message.
    I have no other ways to explain this supernatural phenomenon except that the pluggin is unstable. Can anyone help me solve the problem?

    (btw, I've encountered the same situation before. I went around the problem but opening a new doc and cut & paste the whole thing over there. It worked on the new doc. Mysterious, isn't it?)
Sign In or Register to comment.