No Icon in my Firefox toolbar


All of a sudden I cannot see the little book icon in the toolbar to import bibliographic information from sites like Amazon. I have tried disabling certain add-ons and the other methods mentioned on the translator troubleshooting page (I don't even know if that is the issue, honestly). I use Zotero standalone. Any help would be much appreciated. I'm betting it's something stupid that I just missed.

  • Make sure your Firefox Zotero add-on is updated to version 4.0.5
    If that's the case, run through these:
    most easily with Standalone closed.
  • Ok the add-on is definitely not updated (3.0.11), but it won't let me update it for whatever reason. The button is there and I can click on it, but nothing is happening.
  • yes, that's the problem - the add-on needs to be version 4.0.5
    update by installing from . You got your original version from mozilla add-ons so it's not updated automatically anymore.
  • Great. That did it. Thanks a lot.
  • Ok. Now I am running into some problems setting up zotero on my new laptop, in terms of the add-ons required to get the microsoft word plug-in and the firefox plug-in. I tried to mirror what I had done on my iMac, but to no avail. I use zotero standalone, but when I try to download the add-ons for firefox and word, it seems to also generate a separate zotero library built into the browser. Thus, the word plug-in draws from this other library, as does the firefox plug-in. How do I connect word and firefox solely to my standalone zotero? Even more, how do I neutralize this browser zotero? On my iMac, while the icon is in the bottom right corner of the browser, clicking on it simply defers to the standalone. I hope this makes sense. Thanks again.
  • Point your Zotero for Firefor data directory to your Zotero Standalone data directory's location.
  • (though I thought this should have given you the option on install - does that only happen when the FF add-on is installed first?)
  • No, it should work both ways, but apparently it didn't. Can't test this on a Mac myself though.
  • I should say that I did not run into this problem on my other iMac, but, then again, I don't exactly remember the order in which I installed everything on that one.
  • On that second link, first paragraph:

    "By default, your Zotero library is stored in the 'zotero' directory of either your Firefox profile (Zotero for Firefox) or in the profile of Zotero itself (Zotero Standalone). If you install Zotero Standalone when you already have Zotero for Firefox installed, you will get asked during installation whether you want Zotero Standalone to use the same library used by Zotero for Firefox (the reverse holds true if you install Zotero for Firefox after installing Zotero Standalone)."

    My situation was the latter, but it did not ask me.
  • Alright, I tried to choose the data directory location of zotero standalone as the data directory location of the firefox zotero, but it will not let me choose it or any other applications, for that matter.
  • You're just supposed to be choosing the folder. Open Zotero Standalone. Go to Preferences -> Advanced -> Files and Folders. Click on Show Data Directory. Copy the path to that directory. Close Zotero Standalone.

    In Firefox open Zotero. Go to Preferences -> Advanced -> Files and Folders. Under Data Directory Location, select Custom and click Choose. Either navigate to the directory that I said to copy above or (if it's possible on mac) paste the path wherever the path is in that dialog box. Click Select Folder. Close Firefox. Now everything should be synced
Sign In or Register to comment.