Automatic abbreviations not working

Tested with Elsevier Harvard and Vancouver.

I tried a number of journal titles, none of them worked at all (where abbreviations are in the journal abbr. field they still come through.)
This is using 4.0.2 in a new document Libre Office 3.6.22 document and the 3.5.6 version of the plugin, with the abbreviations box checked (I tried unchecking and checking with no effect).
I haven't tried this with all plugins disabled yet - would be happy to do that and other debugging if this is working for other people.

edit: to be safe I tried this with Academy of Management Review which is definitely in the list - doesn't work either.
  • This looks completely broken for non-beta users. It will be fixed in 4.0.3. For now, you could create a new boolean pref extensions.zotero.cite.automaticTitleAbbreviation and set it to true in about:config.
  • great, adding the extension works.
    Do you expect to push out 4.0.3 soon? Then I'll just tell people (e.g. here: ) to wait.
  • Yes, we'll push 4.0.3 tonight.
  • 4.0.3 is now available.
  • Hi,
    I'm using Zotero 4.0.8, the 3.1.12 version of the Word plugin and Word 2007. I've tried different styles (ACS, IEEE, Nature), but with none of them the automatic abbreviation works. I've tried with titles indexed by Medline and with titles not indexed by Medline.
    Thanks for your help,
  • Works for me. You've made sure the box for automated abbreviations in the document settings is checked?
    And you're using the word plugin, correct? This currently won't work for citations generated directly with Zotero (i.e. right-click --> Create Bibliography).
  • The box for automated abbreviations in the document settings is checked. I've tested this functionnality with Zotero 4.0.1, and it worked well. I've made an attempt with OpenOffice and the 3.5.6 version of the plugin, it doesn't work either.
  • provide an error report ID after trying this.
  • Report ID 1364600715
  • Try disabling the Abbreviations for Zotero extension.
  • Thank you Simon, it works when the Abbreviations for Zotero extension is disabled.
  • Good to know. I can take steps in the plugin to avoid this source of confusion.
  • For some journals, automatic abbreviation does not work (in Better Biblatex exports). Is there a way to update databases such as Elsevier (Harvard) with the journals that they are missing?

  • I think BBT just grabs whatever Zotero produces and that should abbreviate every journal. Do you have an example that's not working?
  • The problem is, Zotero is not abbreviating certain journals the way I want it to. The database it refers to for abbreviations is simply incomplete. Is there a way to add specific abbreviations to the database it consults?

  • Not easily, no. And it's not just a database -- it's a database combined with an algorithm, so if journals aren't abbreviated at all, something isn't working right, which is why I was asking for an example.
  • For instance, a journal that I want to publish in says that the journal "Marketing Science" should be abbreviated to "Marketing Sc." Zotero doesn't do this automatically. And I have a lot of "Marketing Science" citations--can't do it one by one.

  • I should add that many journals are being abbreviated correctly--so it is not a general abbreviation problem.
  • BBT indeed just grabs whatever Zotero produces. There's half-finished code that could load JabRef abbreviation lists, but a) I never could settle on a good UI for them, and b) it would be pretty surprising to most users if BBT started generating different abbreviations than Zotero does.
Sign In or Register to comment.